1. Are you ready for the Galaxy S20? Here is everything we know so far!

Sandisk 32gb class6 MicroSD stopped working, cannot be detected, cannot format....

Discussion in 'Android Devices' started by phichanad, Sep 11, 2012.

  1. phichanad

    phichanad Lurker
    Thread Starter

    My case involves a Sandisk 32gb class 6 MicroSD card. Initially my S3 says that I have a blank card, but later it can detect the card again. For a few days this keeps on happening, on and off. Until the S3 continuously says the card is blank for a whole day. I took out the card, then it worked again....but after a few minutes, the S3 says the card's blank again...and again...until the microsd card is undetectable.

    I took it out and plugged it into my PC using the Sandisk MicroSD adapter, but the PC cannot detect it. I tried the plug it into at least 4 different laptops and PCs but it still cannot detect. I put it back to my S3 to try to format, but it didnt format. Now I can't do anything but ask here.

    What happened to my microSD card? Is it only me or did this happen to someone else here? Anyway I can bring it back to life?

    Thanks in advance

  2. Jon_LTD

    Jon_LTD Android Expert

    I hate to be the bearer of bad news, but it sounds like your SD card has died. With your phone only temporarily recognising it at times (and now not at all) sounds like to me that it was on its way out, and now it's gone. As memory cards are mass produced, and relatively cheap, unfortunately they can lack in quality and not be as reliable and just die.
    I'd invest in another card with a reputable brand (such as Kingston) but even these have been known to fail.
  3. Shotgun84

    Shotgun84 Extreme Android User

  4. WAWood8

    WAWood8 Well-Known Member

    While it may be the SD card, it could also be your phone. I had a Lexar Class 10 32GB micro SD card -- and it did much the same. Suddenly, it wouldn't mount and then gave me an error message that the card might need to be reformatted. Like your, nothing could read mine after that.

    I mounted it in my PC, ran RecoveryMyFiles against it and discovered that hundreds and hundreds of my MP3 files had been zeroed-out.

    Not long after that, the phone started crashing with filesystem failures.

    So, it's likely your phone is failing, too.
  5. mrhomiec

    mrhomiec Android Enthusiast

    or get the Samsung flash cards. i have the 32 GB Class 10 Brushed Metal, and it works great. :)
  6. Jon_LTD

    Jon_LTD Android Expert

    I wouldn't put it down to the phone yet as 4 PC's didn't recognise it either.
    mrhomiec likes this.
  7. Jon_LTD

    Jon_LTD Android Expert

    Ditto :) - cheapest option on Amazon for a 32gb card.
  8. phichanad

    phichanad Lurker
    Thread Starter

    Thanks for the replies guys, really got disappointed that up to now I didn't buy a new MicroSD card even if the largest electronics mall in this country is just a 5-minute walk away...sigh...

    Hopefully it's not my phone that's having problem though...I'm temporarily using a China-made 1GB microsd card from my old 2007 Nokia phone for now (considering its not a branded one but a generic fake China card, and after 5 years it's still damn working!)...can only fit 1 movie!
  9. LandLockedPH

    LandLockedPH Well-Known Member

    Switched to two G3's last week and one of them would not recognize that I had a SD card installed. Transcend 32gb. The card worked flawlessly in my Razr Maxx and in older phones AND with my computer. So back to Verizon I went. Switched out the phone and the new one works fine. It "might" be the GS3.
  10. phichanad

    phichanad Lurker
    Thread Starter

    pre, I just do hope it's not the phone, I've been using it for 3 months already and this has been the only flaw I encountered. So far I'm using my 5 year old CDR King (China made counterfeit unbranded) 1GB since my Sandisk 32gb failed me, and its still working perfectly fine...for now.
  11. WAWood8

    WAWood8 Well-Known Member

    Well ... that was the case with MY SD card problem. Got a new phone and have had no problems since.
  12. blackdeath88

    blackdeath88 Lurker

    my problem is the same.. this is my 3rd transcend 32 gb micro sd card that crashed. maybe the problem is on the unit.
  13. A9230

    A9230 Lurker

    Hi, I,ve got a Dapeng A9230 doing a similar thing. My Adata 32gb microsd works great for awhile then my phone say theres a problem with the card and it might need to be reformated. So I reformat and away I go again for awhile maybe 3-4wks then same problem. Very annoying
  14. klausington

    klausington Lurker

    I had the same issue with my S3 (I9300). 32GB generic card bought off ebay - worked fine for about 3-4 weeks and then came up with an error message and was not recognised by the phone. Computer doesn't recognise it either.
    Tried all the forums etc for info, but basically it appears to be a dead card - lost lots of music and pictures. I have sent the card back to the ebay seller in China and I await a new one.....if I'm lucky!
  15. EggletM

    EggletM Lurker

    I have a S3 and it has just trashed my second Sandisk 32GB class6 MicroSD card.
    Original from Amazon which failed on 26 days, which they replaced, 2nd died on 32 days so outside their 30 day return window.
    I can not work out if it is the phone or a dodgy batch of microSD cards so who I should complain to..
    Has any one had better luck with different manufacturers or different size cards?
  16. WAWood8

    WAWood8 Well-Known Member

    My guess would be that it's the phone. My wife and I have identical phones and HAD identical SD cards. My phone overheated and trashed the card, hers did not. I replaced the card, and was able to demo to a Verizon person how the internal file system got corrupted also -- so they replaced the phone.

    New phone has not had this SD card problem.
    EggletM likes this.
  17. klausington

    klausington Lurker

    I forgot to note that after my 32GB card died in my S3, I put in an old 1GB card (brand: Kingston) and have been using it fine for over a month. In terms of 'overheating', one of the applications I use makes the phone very warm / hot indeed for extended periods, but the card does not appear to have been affected. The mystery continues....
  18. BabelFish

    BabelFish Newbie

    okay, here is my story. :)

    My wife and I have S3's (32Gig version Sprint). We both bought Sandisk 32Gig cards. After 30ish days, my microsd card died. It could not be read by any device I tried it on (even my wife's S3). Sandisk replaced it for free.

    <Fast forward another 30ish days>

    Just the other day, the replacement died! Again, it wont be read by any device including my wifes S3. (it does however pop up with "blank card, do you want to format" every once in awhile)

    The weird part is that each time this has happened I _am_ able to read by wife's card just fine.

    I also have tried to format the microSD card (when the phones are able to read the card) with both S3 phones. It says that it is formatting and then it returns to the mount screen and it pops up saying "blank card, do you want to format".

    So, do you think it is my phone or two bad microSD? I dont see how the phone could corrupt the card so badly that a format would also fail.

    Thanks in advance.
  19. blue_sector

    blue_sector Lurker

    I had a 64GB Sandisk SDXC card behave similarly. Worked for 5 days, then reported itself as write-protected 31MB card and a day or two later stopped being recognized entirely. I'd already destroyed the retail packaging so I had to go through Sandisk RMA process which took a few weeks. The replacement card arrived yesterday. I'm curious...Seems there are numerous reports of these sorts of failures in various online forums. It seems that most, if not all, involve Sandisk cards of various sizes. Has anyone had this sort of problem with a brand other than Sandisk?
  20. peepmob

    peepmob Lurker

    similarly i used transcend 32gb class 4 for my phone which died immediately and got it replaced the same day, and the new one worked for 2 weeks and died. i think it could be something to do with android ics as one of my other friend too had the same problem but now he is using 16gb and its working fine.
  21. lukeskope

    lukeskope Lurker

    Just stumbled across this thread, wanted to add my 2 cents, don't think it is an ICS issue, I have 2 Transcend 32GB micro SD cards, one in my ICS phone ~6 months, one in my Jellybean Tablet (Gingerbread ~1 year, upgraded to JB ~3 months) with no issues. Did have an 8GB Kingston die which is how I got here.
  22. forafauna

    forafauna Lurker

    just joined this forum as my s3 corrupted my sd card as well.

    luckily not much on that wasn't duplicated elsewhere. but it is a scary thought that everything was just wiped like that. this has never happened to me before on any phone. it is odd becuase i usually think, if the phone packs in at least my data is safe...

    after reading around (in other forums as well) not sure if it is comforting or not to know that there are quite a few s3's that do this. it is known problem.

    the card will now not be read by any other phone or device. it is shot & can't be reformatted.

    i lost today's photos as they hadn't uploaded to g+ yet. very lucky escape.
  23. trparky

    trparky Android Enthusiast

    That sounds like what an SSD does when it dies. Nothing can be accessed on the SSD. Usually that happens when the flash memory has catastrophically failed.

    Any number of things can cause flash memory to catastrophically fail like that. The silicon can break down, the blocks in the flash memory fail because of overuse, etc.

    There was talk in some circles that as we make the memory smaller through the process of die shrinkage, there's a chance that in the process of making it smaller you reduce the lifetime of the memory in the process.

    Maybe, we are indeed pushing the boundaries of what flash memory can do in the form factor that we are making them in, namely the MicroSD card. If you really look at it, a MicroSD card is really tiny.

    Also, not all flash memory is created equal. Cheaper brands will probably die sooner. I'd stick to Sandisk or Kingston.
  24. Grrman

    Grrman Guest

    Just stumbled out of the bar and into this thread. I've had weird things happen with my SanDisk 32 GB and 64 GB cards. When I purchased a new 64GB card, S3 didn't recognize it at all. Dropped it into a reader for my desktop and my Mac Pro wouldn't recognize it either. Brand spankin' new card, out of the package. Stuck it in the reader of my Macbook Pro, and viola, read and formatted without a problem. Put it in the S3 and it said, hey, new card. 63 and some change available. Go figure. I took my 32GB card, copied everything to another drive, then copied that to the new 64 GB card. Placed it in S3, not a problem with it in the phone since. Try it in my Mac Pro to add more music files, card isn't recognized. Gets funky at times when in the S3. No worries, So I use Dropbox to transfer.

    Don't you just love tech toys...
  25. toasterz

    toasterz Lurker

    It happen to me too 2 weeks ago. When i put the drive in window it ask me to format the drive i say no. The drive is a Sandisk 32Gb showing only 31 megs to be formatted.

    I didn't backup all data to dropbox or google+ at full resolution so i wants to recover my files, i just install a lot of program to do that, and nothing :
    - icare card recovery free
    - Recover my file v5
    - Recuva
    - EaseUS partition master
    - testdisk 6.13 (photorec)

    Even with winhex, everything is 00 00, not MBR at all. No wonder no program can recover this broken partition.

    I have found several program that can format the drive from 31 megs back to 32 gig. The partition should be primary first instead of logical. This program seem to do the job fine : fat32format from Ridgecrop Consultants Ltd (source: forum.xda thread = 1698672)

    But i am still looking to recover my card first !

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date

Share This Page