1. Check out our companion app, Forums for Android! Download from Google Play

General SOLUTION: Galaxy S2 ICS 4.0.3 IP Address: Unavailable / WiFi Connection Problem

Discussion in 'Android Devices' started by RomanK, Jul 8, 2012.

  1. RomanK

    RomanK New Member
    Thread Starter

    Jul 8, 2012
    Many of you experience this frustrating problem, when you have Full Wi-Fi Signal but nothing would boot up in Internet Browser or Play Store or Facebook etc... all you gonna get is Connection Error

    Thats due to your I9100 being unable to get IP Address from router.
    What requires to do, is manually assign IP Address to your Galaxy S2,
    that is simple can be done with third party app from Google Store, such as WiFi Manager by Kostya Vasilyev.

    Once you've obtained the app, run it and find your Wireless Network that you would like to connect

    Enter you password first.

    Then Tick box with "Show Advanced Settings"
    two new option will drop out
    The one you need is "Assign IP Address" tick that box

    Here is screen shot of my setting which are pretty standard for most users out there with home routers, however i would like you to check setting and local ip address on you Router, Lapton or other wireless device first.
    One thing i should mention that "Address" Line is IP address that you going to assign to your Galaxy Phone must not be take by other wireless device.




  2. Samsungsally34

    Samsungsally34 New Member

    Sep 19, 2012
    Hi, this has been really useful, I did as you said & my wifi was connected but when i tried to use the wifi it wouldn't connect at all.. what did you have the security set as?
    Many thanks.
  3. Peg228

    Peg228 New Member

    Feb 27, 2013
    This solution worked for me with my Galaxy S2 for a time... and then it failed again entirely and I can't resolve the issue at all no matter what settings I try. I intermittently got Wifi back - mostly when I'd connected wifi somewhere else, but often for no apparent reason I'd get an IP when back within range of my wireless.

    I'm now using the app WiFi Connection Fixer (I can't link to it in my first post) - which has immediately fixed this annoying problem... Root access is required.

    I have no association to the developer at all - just a satisfied user. I've joined solely to ad this comment to this old thread... since it looms large in google searches for this very common issue.

Share This Page