1. Download our Official Android App: Forums for Android!

Root Unable to restore

Discussion in 'Android Devices' started by xstefen, Jan 6, 2013.

  1. xstefen

    xstefen Android Expert
    Thread Starter
    Rank:
    None
    Points:
    93
    Posts:
    981
    Joined:
    Dec 10, 2012

    Dec 10, 2012
    981
    207
    93
    Male
    EUC Specialist @ Fidelity Investments
    Under your bed
    I have no idea what I did, im on hboot 1.57 with TWRP 2.3x and I no longer restore any Nandroid backups. Including one I JUST MADE. Restoring system done. Restoring data done. Restoring boot done [5 seconds?] Then it says E:size (12mb) of backup '/sdcard/TWRP/etcetc' and Restore Complete Failed. the 4th partition is WiMax, which i never use anyways but just always backup those 4 partitions. Unable to boot after failure. I have to completely start a new with a full wipe and flash. Any ideas?:(
     

    Advertisement

  2. ramjet73

    ramjet73 Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,418
    Joined:
    Jun 22, 2011

    Jun 22, 2011
    1,418
    821
    233
    Honolulu, Hawaii
    S-ON or S-OFF?

    If you are S-ON restoring a nandroid is the same as flashing a ROM and you need to either start recovery with a "fastboot boot" command or flash the boot partition separately.

    ramjet73
     
  3. xstefen

    xstefen Android Expert
    Thread Starter
    Rank:
    None
    Points:
    93
    Posts:
    981
    Joined:
    Dec 10, 2012

    Dec 10, 2012
    981
    207
    93
    Male
    EUC Specialist @ Fidelity Investments
    Under your bed
    Thanks for the quick response.

    S-Off, Hboot Jbear 1.57. And now after performing full wipe and flashing new vers of MidnightSenseless, boot loop during evo3d animation. Bahaha, fml :(
     
  4. davidmargolin

    davidmargolin Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    957
    Joined:
    Mar 6, 2012

    Mar 6, 2012
    957
    229
    93
    Male
    Brooklyn, NY
    not sure what your problem is but i can suggest another restore option...

    choose one of your backups...
    fresh flash the rom those backups are based on...

    then use this app ---> https://play.google.com/store/apps/details?id=com.handyandy.appextractor.beta

    simply select the backup in the app

    it will let you restore both system and data partitions... you will get all your system apps, your data apps, you texts, you wifi passwords, and most anything else you need...

    it has helped me when my roms would not boot and when my backups become corrupt...
     
    xstefen likes this.
  5. ramjet73

    ramjet73 Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,418
    Joined:
    Jun 22, 2011

    Jun 22, 2011
    1,418
    821
    233
    Honolulu, Hawaii
    You can try flashing another hboot, but I don't think that's your problem. I would try using 4EXT instead of TWRP and if that doesn't work you may need to reinitialize your phone by flashing an RUU.

    ramjet73
     
    xstefen likes this.
  6. ramjet73

    ramjet73 Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,418
    Joined:
    Jun 22, 2011

    Jun 22, 2011
    1,418
    821
    233
    Honolulu, Hawaii
    Good suggestion, but it sounds like he's having trouble getting a bootable ROM. :(

    If he can get something bootable, that's a good way to get his data restored.

    ramjet73
     
  7. xstefen

    xstefen Android Expert
    Thread Starter
    Rank:
    None
    Points:
    93
    Posts:
    981
    Joined:
    Dec 10, 2012

    Dec 10, 2012
    981
    207
    93
    Male
    EUC Specialist @ Fidelity Investments
    Under your bed
    I can get roms to boot, USUALLY. Idk why this just happened. My whole Nandroid restore problem started about 2 weeks ago after flashing gangnam style, ugh. Im thinking i need to backup/format my sdcard. Thanks for the suggestions, its just weird that I never had any problems before downgrading to hboot 1.04, which wasnt compatible with twrp 2.3, so i went back to twrp 1.1, now ive upgraded them both and everything typically works fine, just fails restoring. This P.O.S. is getting on my nerves, I hate stuff that doesnt make sense
     
  8. ramjet73

    ramjet73 Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,418
    Joined:
    Jun 22, 2011

    Jun 22, 2011
    1,418
    821
    233
    Honolulu, Hawaii
    You might want to try the JBear 1.50.5050 hboot, which is compatible with TWRP 2.3.3.0 and runs all the ROM's that ENG 1.04 does, and most of the Sense based ROM's that 1.57 supports. The only ROM's that still require 1.57 are the stock ROM, Cool ICS and older versions of Viper3D.

    ramjet73
     
  9. xstefen

    xstefen Android Expert
    Thread Starter
    Rank:
    None
    Points:
    93
    Posts:
    981
    Joined:
    Dec 10, 2012

    Dec 10, 2012
    981
    207
    93
    Male
    EUC Specialist @ Fidelity Investments
    Under your bed
    UPDATE: Unchecking WiMax on restore completes successful, but boot loop during boot animation still. Going to downgrade to hboot 1.50 and see if I can get a successful boot, thanks

    Downloaded JBear 1.50 for HTC EVO 3D CDMA, I get CID Incorrect everytime I go to my bootloader to flash it :(
     
  10. ramjet73

    ramjet73 Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,418
    Joined:
    Jun 22, 2011

    Jun 22, 2011
    1,418
    821
    233
    Honolulu, Hawaii
    Just so you know, the stock hboot 1.50 is different from the JBear 1.50.5050 version and doesn't support some of the fastboot commands like "flash" and "erase" unless you unlock the bootloader, even with S-OFF. That's why I recommended the JBear version.

    ramjet73
     
  11. xstefen

    xstefen Android Expert
    Thread Starter
    Rank:
    None
    Points:
    93
    Posts:
    981
    Joined:
    Dec 10, 2012

    Dec 10, 2012
    981
    207
    93
    Male
    EUC Specialist @ Fidelity Investments
    Under your bed
    Im getting CID incorrect with Jbear 1.50
     
  12. ramjet73

    ramjet73 Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,418
    Joined:
    Jun 22, 2011

    Jun 22, 2011
    1,418
    821
    233
    Honolulu, Hawaii
    Yes, that's because the one on the unlimited.io site is setup to only flash on Sprint (SPCS_001) and not VM (SPCS_002) devices. Download it from this post and it should flash fine.

    ramjet73
     
  13. xstefen

    xstefen Android Expert
    Thread Starter
    Rank:
    None
    Points:
    93
    Posts:
    981
    Joined:
    Dec 10, 2012

    Dec 10, 2012
    981
    207
    93
    Male
    EUC Specialist @ Fidelity Investments
    Under your bed
    Thank you, got that installed. Still getting reboot loops during boot animation. How the hell did this happen? Only thing I did today was flash Slimrom, it looped, so i tried to restore my backup, which failed, which is when I started this thread :(



    UPDATE: Full wipe and flashed MobHD again, my most recent stable daily driver, let it reboot loop twice, then it decided to boot up and work. Wow. Wow wow wow... Thanks for your help guys as always its much appreciated. I guess Im back up and running, and im not flashing a damn thing for a while lol
     
  14. ramjet73

    ramjet73 Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,418
    Joined:
    Jun 22, 2011

    Jun 22, 2011
    1,418
    821
    233
    Honolulu, Hawaii
    Hard to say, but I do know that the ENG 1.04 hboot has caused problems for other TWRP users, so I'd stay away from that unless you switch to 4EXT.

    On the Evo 3D XDA forums a number of users have had to install an RUU to reinitialize the phone after flashing bits and pieces of firmware, bootloaders, ROM's and kernels and having similar booting problems. It's pretty easy since you are S-OFF, so if your booting problems resurface I highly recommend taking that course.

    ramjet73
     
    xstefen likes this.
  15. xstefen

    xstefen Android Expert
    Thread Starter
    Rank:
    None
    Points:
    93
    Posts:
    981
    Joined:
    Dec 10, 2012

    Dec 10, 2012
    981
    207
    93
    Male
    EUC Specialist @ Fidelity Investments
    Under your bed
    I definately will do. Thanks again for all your help. You're a life saver
     
    ramjet73 likes this.
Tags:

Share This Page

Loading...