1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

3G Drops & Standby Battery Drain (Solutions)Tips


  1. Ziflin

    Ziflin Member

    My wife and I purchased two Optimus V phones on 3/6/2011 and both were experiencing the 3G drop and no-reconnect problem. She also charged hers (stock apps only) fully before going to bed and the next day it was completely dead. Mine was left charging overnight, but by 5pm it was down to 30% battery.

    I called the VM escalation line last night and they were of little help. I did what they said to do (reset my phone #) and 30 minutes later I lost 3G again. I lost 3G about 5 times yesterday and turned the phone on/off to fix it (or airplane, etc).

    I assume these two problems are now related, so as someone here mentioned, I went to *here* and followed the steps by "pre" (posted below). My phone and my wife's both were showing 50% "Time without a signal" -- which is definitely odd because I can see the cell tower from my office and my living room. After following his steps I have now had my phone on for 18hrs and with moderate use and "Syncs" on (but not WiFi) I'm at 75% battery -- I'm also now showing 0% "Time without a signal" and I have had no 3G drops. The steps were as follows:

    * Check "Time Without a Signal": Home, Menu, Settings, About Phone, Battery Use, click "Cell Standby" and not the value. It should be close to 0% if you've been in 3G range. 50% indicates a definite problem.

    To "Fix" - Note the original poster says this change will reset if you reboot the phone and need to be redone:

    * Dial *#*#4636#*#* which will go to the phone's "Testing" menu.
    * Click "Phone Information", then Menu, then click "Select radio band".
    * Click "Force Close" and return back to "Phone Information"
    * Scroll down to "Set preferred network type:"
    * Click the "Set preferred network type:" button and select "CDMA only".
    * Click the "Set preferred network type:" button again and reselect "CDMA auto (PRL)".

    As mentioned in the link, now charge your phone to reset the battery usage statistics and after an hour or so monitor the "Time without a signal" value. The problem seems to be from an incorrect network type value that is originally set/saved despite it showing the correct value.

    This has fixed both of our phones so far today. If anyone else is having this problem and is able to test this fix, please let me know if it works so that I might try to contact VM for a permanent fix.

    Until then, you might wish to get the "Any Cut" app which can create a shortcut to the phone's "Testing" menu to avoid dialing the above number. Once you have the app:

    * Click and hold on desktop
    * Select "Any Cut"
    * Select "Activity" and "Testing"

    Some people also note that they get better battery usage with WiFi left on vs 3G. I'm not sure if this is due to this issue or not, but I'll do further tests leaving WiFi on tonight after a full recharge.

    The default WiFi "Sleep Policy" on the Optimus V is set to turn WiFi off "When screen turns off". If WiFi is truely better, then one would need to set this to "Never". (Note on some other phones WiFi defaults to "Never" sleep.) To change the setting:

    * Home, Menu, Settings, Wireless & Network, Wi-Fi Settings
    * Click the Menu button and select "Advanced"
    * Select "Wi-Fi sleep policy" and change to the desired value

    Finally, if anyone has talked to a VM tech support person and found a permanent way to fix any of this, please post the solution that you found.

    Advertisement
  2. JustMe0815

    JustMe0815 Active Member

    i will give it a try, thanks
  3. duane_black

    duane_black New Member

    Time without a signal on my phone was 68 percent. Crossing my fingers here. I will be so happy if this fixes the data disconnect issue.
  4. cvc7chris

    cvc7chris Well-Known Member

    This is interesting. same things happeninig to me and my gf's phones
  5. digitaljeannie

    digitaljeannie Well-Known Member

    Or an easier thing to do to fix the 50% time without signal bug is to, every time you reboot the phone, after it regains signal, put it in airplane mode & then immediately take it back out of airplane mode. You will notice the TWOS start to go down until you have 0%.
    syav likes this.
  6. gigg423

    gigg423 Well-Known Member

    This just started happening to me, I hope this fixes the issue.
  7. KentInPhilly

    KentInPhilly Well-Known Member

    I had horrible battery life (< 8 hours) and high "time without signal" when I first bought the phone. Toggling that CDMA field fixed it right away and now I get over a full day every time, and time without signal is always at 0%. I've had it for a month now, so I feel secure in saying that this resolved my issue and I no longer have battery life problems.

    I just have to remember to do it whenever I turn off the phone (which isn't often... mainly if I have to get on an airplane or something).

    It's stunning that I have to do this to get reasonable battery life, but I can live with it. If it's a known problem, they should patch it, but oh well... seems like you need to be a little of a hobbyist to get the most out of droid phones at this point. If I hadn't found this forum with the instructions on how to do it, I'm not sure I could have lived with a phone that doesn't last 8 hours.

    You can use the mangelow network app on the droid market to get to the CDMA toggle menu in one click rather than entering in all those numbers.
    w0rd likes this.
  8. Ziflin

    Ziflin Member

    For the record, I testing charging to 100% last night, disabling 3G, and enabling WiFi with WiFi Sleep Policy set to "Never". I left it on from the same time as the previous night when I had WiFi off and 3G on (but using the above "fix"). When I checked it today the battery usage was still at 100% and it's only gone down to 98% so far (vs it being around 93% yesterday with 3G).

    I'll try to see what it will be today with 3G left off but WiFi on while I'm near work or home.
  9. David73

    David73 Well-Known Member

    It keeps force closing when I click select radio band
  10. good job neil

    good job neil Member

    Read the instructions in the first post again.
  11. duane_black

    duane_black New Member

    Just a follow up. Since the above post my " time without signal " is at 0 percent. I haven't had a data disconnect yet. Yesterday by now I had approximately 5 or 6 disconnects that required reboots / air plane mode cycles.

    Would be awesome if this fixes it.
  12. gpel461

    gpel461 New Member

    Does this affect all LG Optimus V phones? Or should I exchange for new Optimus V if I have this.

    I just purchased an LG Optimus V 3 days ago and I had exactly this same problem. The first night the battery drained from 100% to zero in about 8 hours on standby! Before I found this thread, the lowest I was able to get the battery use on standby was still poor at about 4-5% per hour by turning off GPS, WiFi, auto-updating of apps, syncing, etc.

    After I followed the instructions at the top of this thread my battery use on standby dropped to less than 1% per hour. This is a dramatic improvement and obviously a bug in my phone.

    Should I exchange for a new LG Optimus V or are they all like this? I think I can live with it if they are all like this because otherwise it is a great phone for a great price.
  13. KentInPhilly

    KentInPhilly Well-Known Member

    I don't know if they're all like that, but it seems to be a common enough problem that it seems like a good bet that your next phone would have the same problem if you just swapped it.

    There's not much reason to turn the phone off usually, so I just toggle the setting and live with.

    The only other thing that occasionally drains my battery now is the Gallery application not closing itself and eating up the battery, but this is much less frequent than the Standby problem was.
  14. Ziflin

    Ziflin Member

    I don't imagine that you'd have much luck with a new phone, but if you do decide to and it helps, please let us know. As I mentioned, I purchased two phones and both have the problem. And as it can be temporarily fixed by the above change, it seems like VM should be able to fix the problem.

    If the steps above are working, I might try calling VM tomorrow to see if there's a way to save the setting or if they plan on pushing a fix.

    The best battery usage for me is still to just use WiFi until I leave work or home, and then switch on 3G. Seems like someone might have mentioned an app for this, but if not I might look into it because the difference is substantial.
  15. Ziflin

    Ziflin Member

    Ok, (thanks to the internetz) I found that this should happen automatically. However, you will want to change the WiFi Sleep Policy to "Never" so that 3G doesn't kick in as soon and you go into standby mode (because WiFi will turn off in standby by default):

    * Home, Menu, Settings, Wireless & Network, Wi-Fi Settings
    * Click the Menu button and select "Advanced"
    * Select "Wi-Fi sleep policy" and change to "Never"

    With this on and 3G enabled, I can disable WiFi using the Power Control widget and 3G automatically turns back on. If I turn WiFi back on, 3G turns off automatically. I'll do some tests at lunch today to make sure this works as I leave WiFi range as well.
    KentInPhilly likes this.
  16. TVCCS

    TVCCS Well-Known Member

    Most people have reported success with Juice Defender...or get the Mangelow Network app and switch off 3G when it's not being used. It's pretty clear from many posts at the major forums on this that hunting for 3G is the biggest battery eater on the phone.

    https://market.android.com/details?id=com.latedroid.juicedefender

    https://market.android.com/details?id=de.mangelow.network

    If you search a little...there are huge threads on this here and at Howard...with tons of discussions and solutions.

    http://androidforums.com/lg-optimus-v/270848-excessive-battery-drain-even-standby.html

    How to get better battery life on your Optimus
  17. gpel461

    gpel461 New Member

    Yes, but the fix in this thread reduces standby battery consumption by a factor of 4-5 on my phone with all other things being the same (including with 3G on).
  18. gpel461

    gpel461 New Member

    P.S. I also had JuiceDefender installed
  19. KentInPhilly

    KentInPhilly Well-Known Member

    I believe the "Y5 Battery Saver" app does what you want.

    It turns off WiFi when you're out of the range of one of your stored locations (like your home network).

    http://market.android.com/details?id=pl.polidea.y5
    mmr5000, PhilRiverSt, ejlmd and 2 others like this.
  20. WhiteRabbit360

    WhiteRabbit360 New Member

    Does "Rebooting" the phone just mean turning it on and off? If I shut it off at night, do I need to do this step again in the morning when I turn it back on?
  21. Ziflin

    Ziflin Member

    I believe you will need to redo it any time you get the boot screen (power off/on or something that causes a reboot). I will try tomorrow and verify though.
  22. k-dog

    k-dog New Member

    Thanks for this thread. I purchased my new Optimus V on Friday and the battery life has been the only real disappointment. This has made a huge difference!
  23. Leslie Ann

    Leslie Ann Well-Known Member Developer

    Keep in mind that this is a two or three part problem, which may explain some of the confusion people are having. Also bear in mind that VM did have some data troubles, but I suspect they are being blamed for a lot more than they should.


    Now, I'm not saying this will fix everything, but I can repeat the results over and over again. I went 2 weeks without a problem, installed a single app and immediate had trouble again. Yes, I had spots where I lost my signal as I traveled through a dead spot, but it always returned within 30 seconds or so. That was not the case 2 weeks ago. 2 weeks ago, I would lose my data while my phone sat on my nightstand. It's not the phone, it's more likely a bug being aggravated by the apps you chose.






    The first part of the issue is any program that changes your radio connections, GET RID OF IT.


    There is speculation that the radio listings are WRONG on this phone. Keep reading and you will probably feel the same way. So while you use the #*#*number*#*# trick, you may just be creating your own problems. Now, considering that many apps are just enabling you to access this menu (the
    Annonymous7, syav and AnciusD like this.
  24. lynx2cross

    lynx2cross Well-Known Member

    Thanks for the tip, I'm tired of fooling around with this phone, I shouldn't have to jump through hoops to get it to work correctly. If there is an issue with the menu system then it is up to VM and LG to issue a software update to fix this, customers shouldn't have to troubleshoot and figure out these solutions. I like most other people have a busy life and a stressful life and the last thing anybody needs is a cell phone that doesn't work properly.
  25. gater

    gater New Member

    Are you saying not to flash another rom when you say "you need to go back to a fresh rom" or do you think it's alright to use a gingerbread rom?

Share This Page