A2DP bluetooth stereo stutter & skip -- possible solution


Last Updated:

  1. Rjohnjr

    Rjohnjr Active Member This Topic's Starter

    Joined:
    Nov 4, 2009
    Messages:
    32
    Likes Received:
    4
    I have been experiencing some frustrating audio stuttering or skipping while using A2DP Bluetooth stereo. After a lot of web searching and experimentation, I seem to have found a solution and thought I would pass it along just in case it may be of help to others.

    First, the problem. I am using a Sprint Samsung Moment Android v 1.5 phone and an Altec-Lansing/Plantronics Backbeat 903 bluetooth stereo headset. This combination has generally been working great so long as I am indoors or in my car. Oddly, though, as soon as I start moving around, especially outdoors -- and especially in a downtown area -- I would begin to get persistent drop outs, stuttering, skipping, etc.

    Research on a number of websites suggested two potential general sources for problem:

    1. A2DP uses most or all of the bluetooth bandwidth and a fair amount of processor; this can create a problem of insufficient bandwidth and/or system resources. A number of sites and posts suggest various approaches based on this notion, most of which involve turning off or shutting down as many resources as possible including wifi, gps, unnecessary applications, or even restarting the phone to clear out such processes. I already do most of this just to try to keep my battery alive through the entire day. But there was one item I had not turned off and it seems to be making a significant difference: Wifi notification. (Menu --> Settings --> Wireless controls ==> Wi-Fi Settings --> Network Notification.) I have run across several theories as to why this would work. Some suggest that when you are walking outdoors (especially in an urban area), the wifi notification function encounters (moves in and out of) a lot more wifi networks and that the stuttering occurs when it is sampling or processing each of these new networks. In any event, turning this feature off seems to have made a significant difference. This seems to make a difference even if you already keep wifi turned off.

    2. The other line of potential causes could be a problem with signal strength. One post suggested that bluetooth signals are stronger (or are reflected back) indoors or in a car -- but simply dissipate when you are outdoors. The suggested fix for this (as odd as it may seem) is to simply move your phone to the other side of your body. The purpose here is to avoid the bluetooth signal having to travel through your body. It turns out that Altec-Lansing actually makes this same recommendation on their support page. To my surprise, this also seems to work. The bluetooth receiver on the Backbeat headset is apparently on the left side. Being right handed, I have always preferred to carry my phone on the right. But moving the phone to my left side helped to dramatically reduce the stutters and drop outs I was experiencing with the headset.

    These two steps have really helped to solve this problem for me. Using my bluetooth stereo headphones has become a real joy instead of an ongoing source of frustration. I hope this experience can be helpful to others.
     

    Advertisement
    Goreygirl likes this.
  2. jcmtyler

    jcmtyler Well-Known Member

    Joined:
    Dec 7, 2009
    Messages:
    125
    Likes Received:
    12
    Thanks for the tip, I've been getting increasingly frustrated with the bluetooth stereo performance of my NexusOne and the 903 BackBeat headset. It works beautifully when I'm standing still or walking around indoors, but can skip horribly when walking outside. I generally carry my phone in my back-left pocket of my jeans or in a left-side pocket of my jacket, and I haven't found a consistently better location to hold the phone. I already had WiFi notifications turned off, I just turned off the WiFi radio itself so I can compare this afternoon when I'm walking to class. Hopefully this makes a difference!
     
  3. Rjohnjr

    Rjohnjr Active Member This Topic's Starter

    Joined:
    Nov 4, 2009
    Messages:
    32
    Likes Received:
    4
    I find that what makes the most difference outdoors is to have the phone on the same side of my body as the headphone's bluetooth receiver. With the Plantronics Backbeat headset I use, the receiver is on the left ear. So, at least when I am outdoors, I need to keep the phone on my left side. Otherwise I get the stuttering and skipping when I am outdoors. If this is not working for you, it may be that your headset has its bluetooth receiver on the right ear and you may want to try moving the phone to your right side to see if that helps.
     
  4. gmann001

    gmann001 New Member

    Joined:
    Jun 10, 2011
    Messages:
    1
    Likes Received:
    0
    Not sure if this is related, but I have the Droid 2 with 2.2. Most of my mp3's played great via bluetooth (on the Motorola headset (S9-HD)), however, there was always a few that would stutter consistently. After trying nearly every suggestion out there, I found that when I unchecked the ENHANCED STEREO option under the bluetooth settings, the stuttering stoppped. Unfortunately I did lose some sound quality.
     
  5. Neo Matrix

    Neo Matrix New Member

    Joined:
    Nov 23, 2011
    Messages:
    1
    Likes Received:
    0
    I tried that but still got skips with the 903 backbeat and the ZET Warp 2.3 android I turned off the Data enabled under the network settings and seem to get better results. I have had much better luck with the Motorola S9 HD hope this may hekp someone with this problem:D
     

Share This Page

Loading...