adb not working (OS ubuntu, phone LG optimus GT540)Support


Last Updated: 2011-12-06 12:40:33
  1. navalsaini

    navalsaini New Member

    Phone - LG Optimus GT540
    OS - 2.1-update 1
    Development host machine - Ubuntu 9.10
    Android SDK - r15 (nov. 2011)



    Problem: adb devices does not show my LG phone, while lsusb clearly detects it.

    # adb devices
    List of devices attached

    #



    Using android r15 sdk. Other settings,

    (1) Phone set to development mode and stay awake always

    (2) Changes in etc directory (after checking that lsusb is indeed detecting the phone and showing its product id as 61b4).

    2.a FILE - /etc/udev/rules.d/51-android.rules

    SUBSYSTEM=="usb", ATTRS{idVendor}=="1004", ATTRS{idProduct}=="61b4", MODE="0666"

    2.b FILE - /etc/udev/rules.d/99.android.rules

    SUBSYSTEM=="usb", ATTRS{idVendor}=="1004", ATTRS{idProduct}=="61b4", MODE="0666"



    Have been trying for a very long time and would appreciate help. I still have to check on windows machine (but device availability is bit of an issue)

    Does anyone have an adb working on a linux machine. Can you tell me yours adb version and other details?

    Advertisement
  2. Bertolomych

    Bertolomych New Member

    may be this will helps:
    1. make files android.rules readable for all:
    $ sudo chmod a+r /etc/udev/rules.d/51.android.rules
    2. restart adb as root:
    $ adb kill-server
    $ sudo /path/to/your/platform-tools/adb start-server (sudo often can't see adb without full path)

Share This Page