Bluetooth not working after upgrade to ICSSupport

Last Updated:

  1. imish

    imish Member

    I upgraded today to ICS and my bluetooth is not pairing with my device. It says invalid PIN or password. It does not provide me an option to enter the PIN or password. Has anybody encountered this issue.

    The same audio bluetooth is working on other phones, so i dont see that as culprit. I performed factory update twice with NO LUCK :(

    Network: AT&T
    Android Version: 4.0.3
    Baseband Version: I777UCLE5
    Build Number: IML74.CLE5

  2. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Have you tried doing a factory reset to see if this can resolve the issue? Usually a factory reset right after an OTA (Over the air) update can fix bugs like this.
  3. imish

    imish Member

    Yes, i did that twice too....
  4. archittech7

    archittech7 Well-Known Member

    I'm having the same issue too! Can't get my Pro Plantronics bluetooth headset to pair. I'm getting the same error with no place to input the right code. :(
  5. lunatic59

    lunatic59 Moderati ergo sum Moderator

    When you are paring the phone with the headset, do you see a notification in the notification bar? You may have to pull down the bar and tap on the notification to enter the pin.
  6. imish

    imish Member

    The bluetooth headset was already configured previously (on gingerbread). It shows up in available device and when i tap on it, it throws error.

    I don't see any notification to enter the PIN on top of the screen.

    Also what i know in gingerbread you can tap on the available devices which were already configured and hold it for few seconds and than options would pop up to forget it etc.. i dont see that happening on ICS too.
  7. lunatic59

    lunatic59 Moderati ergo sum Moderator

    If you got to settings>bluetooth and tap on the gear symbol to the right of the connection, you can forget that and repair. That should fix you up.
  8. dbasnett

    dbasnett Member

  9. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Have you been able to pair correctly to ANY Bluetooth device without rebooting?

    You can easily get back to Gingerbread if you'd like. Pretty good tutorial here. How to Unroot AT&T Galaxy S2! [SGH-i777] | Galaxy S2 Root
  10. dbasnett

    dbasnett Member

    So is that AT&T factory settings? What worries me is that the AT&T rep told me if I do something like that and the phone doesn't work I'll have an expensive paperweight.

    I can use my logitech speaker adapter as long as I don't turn WIFI on.

    BTW - thanks for taking the time to reply.
  11. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Yup that will put your phone back to out-of-the-box condition. Technically the rep is right, that flashing custom firmware will void your warranty, but this isn't really custom firmware, it's the same thing they'd do if you sent it back to be reflashed.

    As for the paperweight, as long as the phone is working, they are very hard to brick. The one thing that will mess you up is interrupting a flash, either by powering off or pulling the USB cable out. So, don't do that and you'll be okay.

    Did your speaker adapter work with WiFi on in gingerbread?
    dbasnett likes this.
  12. dbasnett

    dbasnett Member

    Yes it, the speaker adapter, did.

    The closest I had to a problem with this phone was that it occasionally wouldn't pair with the Logitech device without turning off / on BT. Since ics a different story.
  13. imish

    imish Member

    Finally it worked for me, performed below steps:

    Restarted Phone
    Restarted Bluetooth Device
    Went into settings --> applications --> all -> bluetooth share - and clear all data
    Went into settings --> applications --> all --> Bluetooth Test - and clear all data
    Tapped already paired bluetooth device and hold it for few seconds and at the same time hold the bluetooth device

    and here you go, it got paired....

    Not sure if this process works for all, but it certainly helped me

    Thanks for all the help, and i never saw the GEAR icon on the already paired device :)
    DiddyKong likes this.
  14. lunatic59

    lunatic59 Moderati ergo sum Moderator

  15. archittech7

    archittech7 Well-Known Member

    Glad you got yours fixed. Should I start a new thread? Now, my phone won't even see my bluetooth headset. :(

    EDIT: Nevermind. I fixed mine by turning off my Pro Plantronics headset. Then, I held the power button in until it started flashing blue and red. I did a scan for it and it paired. This was after I did the clear data thing, so maybe that helped too. Anyway, fyi for anyone that comes across this thread.
    DiddyKong likes this.
  16. dbasnett

    dbasnett Member

    Thankfully my phone was only a few months old. The warranty folks are sending me a new phone.
  17. dbasnett

    dbasnett Member

    Replacement phone arrived, with gingerbread installed, and once again all is well with the world. Thank you AT&T and especially Jeci Martin at the Jefferson City, MO AT&T store!
  18. wolfyboy359

    wolfyboy359 Well-Known Member

    That was quick! Did they ship it overnight?
  19. DiddyKong

    DiddyKong New Member

    so i also have a pare of Plantronics headset and i performed both of these steps. i am now listening as i type. :D :D :D :D :D :D :D :D :D :D
    Thank you to everyone that posted here!
  20. applemac

    applemac Active Member

    I did the ICS update and my Jawbone started acting crazy. People kept telling me I sounded like I was in a barrel? So, I went to phone and deleted my Jawbone under Bluetooth devices. Then I re-paired the phone and bluetooth and it has worked fine since...knock on wood!
  21. OrionNebula

    OrionNebula New Member

    I had the same problems of my Galaxy SII not pairing with a TomTom bluetooth immediately after upgrading from Gingerbread to ICS. The solution turned out to be simple, just clear the data in Applications -> All -> Bluetooth Share and BlueToothTest, and then do a soft reset on the TomTom (hold in the on/off button for about 30 seconds until you hear a drum roll). Immediately after this the SII recognised the TomTom, and paired with it straight away. This was in contrast to suggestions I saw elsewhere about deprecating the SII back to Gingerbread (which I am glad I did not follow before experimenting a bit more) - and which in my case this was not necessary. So now the TomTom/bluetooth co-exists happily with the ICS upgrade, and seems to be stable.
  22. trdonnan

    trdonnan New Member

    This did not work for me, same problem!

Share This Page