Bootloader 30.04 Err:a5,70,70,00,1F


Last Updated: 2013-08-09 17:27:43
  1. Need help fixing my Droid X. I rooted it and added superuser when it was on Froyo. It was then upgraded OTA to Gingerbread. The other day I tried to flash it back to stock and botched it. I now get the following:

    Bootloader
    30.04
    Err: A5,70,70,00,00,1F

    MEM_MAP Blank
    Service Req'd
    Battery OK
    OK to program
    Connect USB
    Data Cable


    Can someone please please point me in the right direction. Does it matter what RSD version you use with which SBF file? I have tried numerous combinations. Even tried to the LINUX ISO disk to flash it but nothing seems to make a difference. Really need to know for certain what SBF file I should be using. I thought the full 602 version was it.

    Advertisement
  2. colchiro

    colchiro Well-Known Member

  3. Yes, I thought I had read enough before starting but was saddly mistaken! lol The procedure you mentioned was the last one I tried before I gave up and decided to ask for some help from you guys that know whats going on.

    After trying that proceedure I am still getting the same boot error. Any other suggestions? I will try it again also.

    Can you tell me is the version of RSD critical? And if so how do you know which version of RSD will work with which SBFs?

    I have tried multiple SBF files with several RSD versions and cant seem to find a combination that works for my phone. Even though the flash always shows "pass" it just boots back up with the same error.

    (Sorry for putting this in the wrong area, wasnt sure if it should be in the root or the the trouble shooting area) Thanks!
  4. colchiro

    colchiro Well-Known Member

    I use 4.9.
  5. The first file I tried to SBF to was VRZ_MB810_2.3.34_1FF_01.SBF, not sure if that helps shed light on the problem or not.

    Since then I have been trying to flash VRZ_MB810_4.5.602_1FF_01.sbf using RSD LIT 5.4.4 to no abvail. Each time RSD says the flash passed, but when the phone reboots it comes back with the bootloader error in the original post. I have tried pulling the battery and holding the home key while powering up but I cant get it to do anything but give me the boot loader error....
  6. colchiro

    colchiro Well-Known Member

    Try a factory reset in stock recovery, if you can get to it.

    There was an error similar to yours, where the fix was to shorten the sbf file name by one character until it worked.

    FWIW, my sbf is called 602.sbf. I assume that's what I used last time.

    BTW, make sure you pull your battery when you're not flashing your phone. It will not charge until you can boot it back up.
  7. colchiro, I really appreciate you taking time to help me with this issue.!

    I am not able to get to the stock recovery. And the actual file name of the SBF is 602.sbf, but folder its sitting in is named VRZ_MB810_4.5.602_1FF_01.sbf.

    Is there a chance that I have somehow messed up the boot loader? All the info I have been able to find so far looks like others how had this same issue were able to simply SBF the 602 and were back in business.
  8. colchiro

    colchiro Well-Known Member

    I've seen this several times in my searching for that error, "you need to use the 2.3.32 sbf"

    If that works, then you can try the 602.

    EDIT: Just saw you replied while I was composing. As long as your battery is still good, I think you can recover from this. Just wish someone who knows more than me about this (I'm no pro), would pipe in.

    Do you have a buddy with an X that can charge your battery for you, if it comes down to it?
  9. Bugly

    Bugly VIP Member VIP Member

    you're doing fine, colchiro... same advice i would give
    colchiro likes this.
  10. OK, I just tried the link you sent with the 2.3.32 SBF from windows xp with RSD lite v5.3.1 and got the same results. As soon as it says its finished and reboots the phone it comes up with the bootloader error. I then unplugged the phone and remove the battery. Put the battery back in and hold down the home key while pushing the power button. The phone immediately goes back to the boot loader error in the original post.

    As for the battery, I do have someone I can get to charge it. But would like to know more about the problem that battery failure or unplugging during the flash would cause. I have read many people cautioning about these two events, but am wondering if they occur is your phone done for or now that full sbfs are out is it possible to recover from them?

    Also, since I cant see how much battery I have left, can I rely on the bootloader status that says battery ok? I did have a complete charge before I started trying to flash and I am keeping the battery pulled when I am not actively trying to fix the phone.
  11. ylexot

    ylexot Well-Known Member

  12. colchiro

    colchiro Well-Known Member

    I saw that too. I think 602 sbf should be the primary file now that 320 didn't work.
  13. Greavous

    Greavous Well-Known Member

    dont you have to go into factory bootloader and do a reset first? I seem to recall always having to do this or I just bootloop until the livestock come home.
  14. ylexot

    ylexot Well-Known Member

    A bootloop is a different issue than a bootloader error.
  15. OK, I have an xp and 7 pc, and numerous cables. I will try various combinations of them with the 602 load later today and post the results.
  16. Goose306

    Goose306 Active Member

    You said you got an OTA for GB, was that on 02/25? Do you remember what the system version was? This is crucial. Was it an update for .602, .605, or .621? If it was .621 you are stuck on .621, you cannot revert to .602, and doing so will give you that bootloader error you are referring to.

    Regardless if it was .602 or .621 you will need to use RSD Lite 5.4.4. Check your MD5 checksum on your SBF file you downloaded as well to ensure you didn't get a corrupted download. Lastly, make sure you are using the latest Moto drivers. If you need an updated RSD Lite, Moto Drivers, etc, there is a handy run-down of all these items @Rootzwiki. I can't post links because I just registered to give you this info, but just go to rootzwiki / droid x section, its one of the top stickied topics on the main forum.

    Now, if you did take the OTA and it was a GB update to .621, you have to SBF .621. The error you are getting is usually due to the SBF process not transmitting the info, and it can happen when you don't have the right drivers, the right cable, or the right RSD Lite, usually. However, if you were on .621 then that is what is causing the problems. You will need to use the .621 SBF file. Bear in mind there is no method for root currently on .621, and there is no way to revert back, so this should only be used as a last-resort method. However, if you were given the OTA to .621 you are already trapped there, as it is.

    If you need a .621 SBF, it can be found in my dropbox. I have it posted @Rootzwiki, however since I just registered here to provide this information I cannot post links. I can PM it to you if needed, or if you go to Rootz for the drivers, RSD Lite, go to my pinned topic about .621 in Droid X general there and click the link in my signature to get the files. My username there is the same as here.

    Again, ONLY USE THIS as a LAST RESORT and if you were given .621 AS THE OTA UPDATE YOU RECEIVED.
  17. Goose, I hate to say it but I am not absolutly certain of the version. It would have been loaded prior to 2/25/12 though as 2/24 was the last day the phone was in use with a radio signal.

    I dont mind updating to 621 and loosing the ability to root so long as it gets the phone back up and running. Hopefully in the future there will be the ability to root 621 as well. I will see if I can find it from your drop box and give it a try as all the other SBFs I have been trying have not worked after prob 4 to 5 tries on each one.

    Thanks again everyone for all yalls help!
  18. Goose306

    Goose306 Active Member

    It really does sound like you are on .621, as there are multiple people who bricked their X's across the boards when .621 came out and they attempted to SBF back to .602. You can successfully resurrect a bricked X if it was on .621 even if you tried to flash the .602 SBF by flashing the .621 SBF.

    I will PM you the link to the applicable pages @Rootzwiki; I would try downloading the .602 SBF from my dropbox first and verify the MD5 sum (I use an MD5 on the .7z compressed file). Make sure you are on RSD 5.4.4 with the latest drivers and using your OEM USB cable. This will eliminate any possibility of other problems. Since you don't know if you have .605 or .621 I would do the .602 SBF (it is interchangeable, there is no .605 SBF). If you get the same mem_map error then it is most likely because you have received the .621. Only use the .621 SBF as a last resort. Once you are there, no turning back. But if we have confirmed you do not have further options, that would be last one you would want. The 25th is *right* around the day they started rolling out .621 nationally, so thats why I'm wondering. At this point anybody can pull the OTA and I believe its live in all regions.

    P.S. RSD Lite is tricky as well, mine never shows my phone when I hit "Show Device" it hasn't populated device info since a 4.x version. However, I have never had a problem updating. Just make sure you have the line down in the bottom of RSD, let it process and make sure it gets to "Rebooting Phone" if you get past the bootloader then you are good and then you will probably need to enter stock recovery and wipe data, and it'll boot. If you are still in bootloader with the mem_map error after it gives a successful SBF and gets to "Rebooting Phone" then most likely you are on .621

    Finally, as cochiro said, careful with your batteries. If you don't have an external charger it can't charge in the phone while in bootloader, so make sure you're pulling it when not in use.
  19. Problem has been solved. Many thanks to those who worked with me on this issue!

    Resolution: Tried again to flash to 602 with Gooses SBF and still failed. Tried to flash to 621 and it worked on the first try. Evidentally I had been upgraded to that 621 and was not aware of it.

    Lessons learned from this:
    WRITE DOWN EVERYTHING FIRST!!!!! Old minds dont remember like they should!

    Internet forums are full of people who have been there and done that already and are willing to help you through it too!


    Thanks again everyone for all the help restoring my phone!
  20. colchiro

    colchiro Well-Known Member

    Glad you got it figured out. I almost got a blister. :D
  21. Goose306

    Goose306 Active Member

    Glad you got it fixed. Now we just need to find a way to root .621 :)
  22. JasonV8

    JasonV8 Member

    I as well am having the same problem, I have original usb cable and correct rsd lite. I have tried several sbf's and all do the same, when rsd lite finishes and says passed the phone restarts to bootloader and does not go any further.. not sure if it matters but this is a milestone x from alltel. any suggestions would be great!
  23. JasonV8

    JasonV8 Member

    I am having the same issue as well. I have followed all of your steps but the phone still just loads to bootloader with same error no matter what sbf i use. any suggestions would be great. by the way, not sure if it matters but it is a milestone x from alltel.
  24. JasonV8

    JasonV8 Member

    also the .602 sbf is now giving bootloader error of A5,70,70,00,00
  25. ylexot

    ylexot Well-Known Member

    I'm pretty sure that Milestone X and Droid X SBF files will be different and incompatible with each other. You'll have to try to find a Milestone X SBF file.

    Try this forum:
    http://androidforums.com/motorola-milestone-x/

Share This Page