1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

cannot reinstall stock messaging app


  1. tomd182

    tomd182 New Member

    Hello!

    After rooting my phone I uninstalled the stock Messaging app with Root Uninstaller. I made a backup of the Mms.apk file. A few days later I tried to reinstall it, but when I run it, it only says "Application not installed".

    I've been searching around for hours, tried copying the backed up apk to the /system/app folder, changing permissions, rebooting, flashing various zip packages, wiping the delvik cache, etc, but still it says "Application not installed".

    When I go to the /system/app folder with Super Manager, the copied apk file is displayed as Messaging(No install) ?! screenshot: hxxp://i49.tinypic.com/33zd1jb.png

    I also tried with some other apks I found online but it doesn't work either.

    I know I could flash the ROM, but I'd like to use that as a last resort.

    Any ideas/suggestion would be greatly appreciated.

    Advertisement
    :
  2. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums tomd182! :)

    Did you make a nandroid backup before making those changes?

    If so, you could use that to restore your phone.

    Failing that, you could just re-flash the firmware again.

    Personally, I use Titanium Backup to, "freeze", my Messaging app, ( [SMS/MMS PREF...ing 4.0.3 XWLPI] ). Perhaps you also uninstalled an ancillary service as well, such as, [SMS/MMS
    /APN...age 4.0.3-XWLPI].

    For details of how to freeze/remove app's in rooted phones, see here.
  3. Shotgun84

    Shotgun84 Well-Known Member

    Welcome to the forum tomd182 and thanks for joining.

    I'll move this to our all things root forum:)
    ironass likes this.
Loading...

Share This Page