Can't buy paid apps all of a sudden


Last Updated: 2012-10-10 10:50:26
  1. pk1209

    pk1209 Well-Known Member

    Hi all,

    Probably like most of you here, I've been going a bit crazy buying up

    Advertisement
  2. Adauth

    Adauth Well-Known Member

    Had that happen once. Just had to update my card info, but seems you've done that so that's not it.
    Try clearing play store cache and data maybe?
  3. pk1209

    pk1209 Well-Known Member

    Yeah, tried clearing cache and data on my SGS2 and no joy. And as you say, a brand new card has been added.
  4. fredworxz

    fredworxz Active Member

    I had this happen once ...it turned out that what I was trying to get was linked to an original app
    Example trying to get street view without google maps....so maybe you need something else first ????
  5. pk1209

    pk1209 Well-Known Member

    Don't think so Fred, have tried a few apps now, and it's always the same. I'm just going to leave it 24 hours and see if it fixes itself I think...
  6. Adauth

    Adauth Well-Known Member

    Try contacting Google support.
  7. pk1209

    pk1209 Well-Known Member

    Yeah did that too - my hopes are currently pinned on 24 hours of not buying any apps and it magically fixing itself. Just need to hope I don't miss any great
  8. pk1209

    pk1209 Well-Known Member

    Still having this issue :(

    Google support not much help so far...

    Google Wallet is fine, purchased through it no problem outside of app store.

    Any other ideas peeps?
  9. eaiello1086

    eaiello1086 Member

    This is happening to me today, too. It's a real bummer because I want to buy the Thumb Keyboard for 50% off. I love Swiftkey but I'm tired of their lack of support for those of us who bought their app for use on the GNote. It's been missing split keyboard functionality since ICS came out.

    I was going to try loading a different card and seeing if that worked. I hope it starts working soon!
  10. pk1209

    pk1209 Well-Known Member

    Different card didn't work for me. Let me know ow how you get on!
  11. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Maybe they're having trouble with all the people taking advantage of this and all.
  12. pk1209

    pk1209 Well-Known Member

    Who knows could be something to do with that. I tried removing my google account from my Nexus and re-adding it - I then tried to buy an app which I previously hadn't attempted to buy, and that worked, but then going back to a different app that had failed before, no joy!

    However, I've not just bought another app (spending a small fortune here!!) through the Online store, and that has worked.

    I think it may be one particular app that is causing the problems - screenslider by REDFLY...

    Going to stop testing app purchases, as I've now spent about
  13. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    If it's a particular app then have you tried contacting the app developer about it?
  14. Primevyl

    Primevyl Active Member

    Most developers are responsive when comes to the yen
  15. pk1209

    pk1209 Well-Known Member

    Sorry - that wasn't very clear, I've had the issue with numerous apps, but I'm wondering if the problem is kicked off when I try to buy a specific app, and app purchases after that (for a period of time) are being blocked by Google for some kind of security reason...

    So, I'm going to ingore the app I was trying to buy, and go about my normal business - I shouldn't be buying any apps for a few days at least now. Then maybe next week, I'll go back to the problem app and see what happens...
  16. jack612

    jack612 New Member

    I've been having this exact problem for the last two days when trying to buy the full version unlocker for PowerAmp. I've managed to buy other apps successfully but this one fails every time. I've tried contacting Google support about it twice now and both times they've sent me the same form letter (which contains no useful information) and then don't respond to any subsequent emails. Please Google, let me give you my money.
  17. Adauth

    Adauth Well-Known Member

    Hmmm weird.
    Just bought 3 app 2 mins ago. No issues.
  18. Harry2

    Harry2 Well-Known Member

    Are there any changes?

    I'd this issue for a few days, every day I'd been trying to buy the same two apps, without success ... but yesterday I'd success :)

    Harry
  19. pk1209

    pk1209 Well-Known Member

    It seems to have slowly sorted itself for me - have now been able to buy everything that had previously been failing. I think the trick might be to avoid trying to buy anything for a couple of days, and maybe avoiding the app which first failed for longer.

    All a bit random though...

Share This Page