Can't get the magic to Sync with windows 7Support


Last Updated:

  1. TriC

    TriC Well-Known Member This Topic's Starter

    Joined:
    Jun 13, 2009
    Messages:
    175
    Likes Received:
    2
    Can't get the rogers magic to Sync with windows 7. all the drivers installed but when I hit Sync on the phone I get a message saying the phone cannot detect HTC Sync at you PC. then tells me where I can download it. Now windows 7 comes with Windows Mobile Device Center. has anyone been able to get their Magic to Sync with windows 7?
     

    Advertisement
  2. maedox

    maedox New Member

    Joined:
    Jun 15, 2009
    Messages:
    1
    Likes Received:
    0
    I am experiencing the exact same thing on a Windows XP computer at work. I have Windows 7 myself, so I will check it out and see how it goes.

    Hope someone can give some input on this. HTC have to deliver sync software that works!
     
  3. srs87

    srs87 Member

    Joined:
    Jun 8, 2009
    Messages:
    12
    Likes Received:
    0
    It's hit and miss with regards to sync. The first time I tried it on my laptop running both Windows 7 and Vista, the device wasn't recognized. However, when you have it working you don't have worry about the device not being discovered. Here is what I did to get it working:

    1) Settings: Unmount SD Card
    2) Plug in Magic to computer
    3) Windows will start looking for drivers...takes a long time
    4) After it is done searching through driver database, it will either tell you the device cannot be installed (in which case you should reboot your computer or factory restore the phone) or will tell you that there is a component missing (most likely ADB driver). In the second scenario, your phone will you give you a notification to mount the sd on your computer (first time this happens phone will tell Windows where to find the driver).
    5) If step 4 worked, you should see the SD Directory in Windows Explorer. When done MAKE SURE you safely remove the sd from your computer (just like a usb drive) before ending the USB transfer on your phone, otherwise any data you have stored may become corrupted.

    I haven't tried this on XP, but from my experience Windows 7 in its beta builds struggles greatly when trying to sync to a multimedia device. My iPod touch always freezes my entire desktop or iTunes times out when establishing a data transfer. I would try it on Vista, or if your can't, take the microsd out of your phone and use an sd adapter to read from your computer. Message me if you have any questions :)
     
  4. TriC

    TriC Well-Known Member This Topic's Starter

    Joined:
    Jun 13, 2009
    Messages:
    175
    Likes Received:
    2
    ya the SD card has always mounted to windows 7 fine.. I have moved music over and what not. The problem is getting it to Sync with my windows contacts.. still will not work.. I even used the drivers that come with the SDK software.. but its no big deal now since I uploaded all my contact to Gmail so there on my phone now..

    Just didn't want to type in over 100 contacts to my phone... works great with my gmail account.
     
  5. vjkuok

    vjkuok New Member

    Joined:
    Mar 6, 2010
    Messages:
    2
    Likes Received:
    0
    same problem here, how come still no solution..., wanna sync~~ not SD mount...
     
  6. jimf42

    jimf42 Member

    Joined:
    Mar 17, 2010
    Messages:
    17
    Likes Received:
    0
    I had sync issues with my magic and XP...HTC help told me to put the USB into debug mode...that solved the problem.
     
  7. dehtrim

    dehtrim New Member

    Joined:
    Mar 23, 2010
    Messages:
    1
    Likes Received:
    0
    When you download the HTCSYNC installer file, right click on the file, go to properties. Click on Compatibility tab make sure you click the box for Run this program in compatibility mode for: and choose from the drop down box "windows XP service pack3" and make sure Privilege level box is checked to run as administrator. NO OTHER SETTINGS ON THIS TAB SHOULD BE CHECKED.

    RECAP

    INSTALLFILE>>RIGHTCLICK>>PROPERTIES>>COMPATIBILITY TAB>> CheckBoxes for Run this in Compatibility mode, and Run this as an administrator are all that is checked.>> The drop down box for Compatibility mode displays "WINDOWS XP (SERVICE PACK 3)">> CLICK APPLY >>OK and then run the installer again.


    Worked perfect first try.

    I find that anything that is not expressly made for windows 7 needs to be run under compatibility mode. For my tests, XP Service pack 3 hasn't failed me yet.
     
  8. jasonjkd

    jasonjkd New Member

    Joined:
    Jul 8, 2010
    Messages:
    1
    Likes Received:
    0

Share This Page

Loading...