Root Can't root 2.2.3 with SuperOneClick?

Discussion in 'Android Devices' started by Ticklethis275, Nov 22, 2011.

  1. Ticklethis275

    Ticklethis275 Active Member
    25

    Jul 10, 2011
    25
    0
    25
    Indianapolis
    Did anyone else who got their update 2.2.3 upgrade (got mine this morning) now have problems rooting using 2.2.3
     

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian
    VIP Member
    333

    Oct 28, 2009
    9,416
    1,920
    333
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    I was just about to test this - I've recently reverted my OG DROID to stock for getting a file to someone and am about to apply the new update - I was wondering if it breaks root or not....

    I'm going to check now myself on my phone.
     
  3. johnlgalt

    johnlgalt Antidisestablishmentarian
    VIP Member
    333

    Oct 28, 2009
    9,416
    1,920
    333
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    No dice - took phone back to pure stock and no update available. I wonder if the phone needs to be activated - I think it does, now that I think about it....

    Tough decision - do I take my BIONIC off the networks for a while to find out if this is breaking root, or just 'fuhgedaboudit?"
     
  4. PhilosoRaptor

    PhilosoRaptor Well-Known Member
    93

    Jan 26, 2010
    722
    108
    93
    US Army - 25B (I.T. Specialist)
    Ft. Knox, KY
    Yeah, I'm sure that the phone has to receive the update OTA from the carrier. But you should be able to find the .zip hosted somewhere and apply it manually, which would require you to restore the stock bootloader (no SPRecovery or ClockworkMod) to apply the update.
     
    johnlgalt likes this.
  5. icecold

    icecold Well-Known Member
    88

    Dec 31, 2009
    667
    75
    88
    WI
    Um, looking for this?
     

    Attached Files:

    teddyearp likes this.
  6. dbosell

    dbosell New Member
    5

    Nov 15, 2011
    1
    0
    5
    I am new to this. Do you use this file to take the phone back to 2.2.2 or earlier? I have 2.2.3 and want to root the phone, but can't find anything on it. Is you use this file to revert back, how do I do it? Thanks.
     
  7. whelderwheels613

    15

    Sep 9, 2010
    24
    0
    15
  8. sabdullah

    sabdullah New Member
    6

    Nov 25, 2011
    2
    2
    6
    Confirming that SuperOneClick 1.7 (with rageagainstthemachine option) works to root Froyo 2.2.3 on Original Droid.
     
  9. sabdullah

    sabdullah New Member
    6

    Nov 25, 2011
    2
    2
    6
    johnlgalt and teddyearp like this.
  10. teddyearp

    teddyearp Well-Known Member
    223

    May 19, 2010
    2,406
    831
    223
    Store Manager
    Pinetop, AZ
    Well, I guess I have to go back and edit a few posts I made tonight.

    I am sure that MotoCache1's method will still work as well. Or the manual RATG method.

    Thanks icecold for the link to the pure file. Thanks to sabdullah for a new link to Pete's download section.

    p.s. I guess I can't say this enough about anyone who posts and uses "one click rooting" files. You are immensely better off knowing the manual way to root your phone as most every official OTA update will break those files (better named as scripts). And on another note about those script/files, usually the 'author' of those scripts are actually using someone else's root exploit, then packaging it into an easily made script and calling it their own; without giving credit to the original author of the exploit.

    just saying. . . . . .
     
    johnlgalt likes this.
  11. zandroidx

    zandroidx Well-Known Member
    16

    Jul 16, 2010
    93
    9
    16
    Confirmed. I just had to do it for one of my friends who accidentally took the update.
     
  12. JRMHS168

    JRMHS168 Member
    5

    Nov 27, 2011
    6
    0
    5
    Florida
    Can You post a link for the SuperOneClick 1.7 with Rageagainstthemachine option. I see 1.7 links but no (RageAgainstTheMachine). Did you use SuperOneClick for the original root as I see that 1.9 is available also. I used gingerbreak to root and lost it with 2.2.3 OTA verizon update on OG Droid
     
  13. zandroidx

    zandroidx Well-Known Member
    16

    Jul 16, 2010
    93
    9
    16
    I used 1.7 when I originally rooted and used the same for the current rooting. Judging by other posts in the forums, I did not expect it to work until I saw sabdullah's post. I uploaded it to 4shared for you. It contains both the psneuter and rageagainst the machine options. I used the default, which is psneuter, and it worked very quickly, and after only one try.

    Let us know how it worked for you. Here's the link:

    SuperOneClickv1.7-ShortFuse.zip - 4shared.com - online file sharing and storage - download
     
    Phat12 and gasgzlr like this.
  14. JRMHS168

    JRMHS168 Member
    5

    Nov 27, 2011
    6
    0
    5
    Florida
    Thanks Zandroidx, the link worked great and I am back to root. I used psneuter first and didnt work. was working got stuck in loop connection and i disabled usb bugging on second try in the middle of process when it got stuck. completed process but no root. I next tried the rage against the cage link. This worked great if you get stuck on a command after it starts keep the usb debugging box open and checked to start and uncheck the box if needed during root if same commands keep showing on screen saying no access. I had to extract the files to start and used the superoneclick icon and the rageagainstcage exploit on the right side on the app. All goes well.
    Thanks again.........
     
  15. johnlgalt

    johnlgalt Antidisestablishmentarian
    VIP Member
    333

    Oct 28, 2009
    9,416
    1,920
    333
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    I cannot emphasize that enough either.
     
    teddyearp likes this.
  16. az_r2d1

    az_r2d1 Well-Known Member
    16

    Nov 18, 2009
    63
    9
    16
    perhaps a link tot he latest and greatest way to do it manually ? I've run into some but they always seem to use older versions of software needed....
     
  17. johnlgalt

    johnlgalt Antidisestablishmentarian
    VIP Member
    333

    Oct 28, 2009
    9,416
    1,920
    333
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
  18. az_r2d1

    az_r2d1 Well-Known Member
    16

    Nov 18, 2009
    63
    9
    16
  19. gasgzlr

    gasgzlr New Member
    5

    Dec 1, 2011
    4
    0
    5
    confirming that 1.7 works. thanks!
     
  20. Jack Rude

    Jack Rude New Member
    5

    Feb 11, 2010
    2
    0
    5
    Apparently I am not as smart as I think I am. I don't think I am an idiot though. I tried following the link to the superclick 1.7 that was shared and I can not get it to download. I tried doing it in several browsers and no luck. It says it is downloaded but when I try to find the file on my cpu no luck. I joined the site it took me to and still no luck. So being the adventurous type that I am, I decided to try the manual way. I don't seem to be able to download rage in the cage on Mediafire. BTW I did join that site too. Ok so I know my problem is not with the Droid phone but it is keeping me from doing what I want with the droid phone. Since several of you have had some success with these downloads could someone please tell me what I am doing wrong?
    I mean besides the usual PEBCAK and ID10t errors.....LOL!:D

    [​IMG]
     
  21. johnlgalt

    johnlgalt Antidisestablishmentarian
    VIP Member
    333

    Oct 28, 2009
    9,416
    1,920
    333
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Check your antivirus program.

    I just DLd Superoneclick 1.7 and MSSE immediately popped up stating that it was infected with Unix/Lotoor virus. Knowing damn well that I wanted this exploit on my computer I ignored it - but your AV may be silently hiding it from you so that you cannot accidentally access it.
     
  22. JRMHS168

    JRMHS168 Member
    5

    Nov 27, 2011
    6
    0
    5
    Florida
    try the link I used above at 4share. I had to click on it twice after rerouted. after second try click on it. After site opens click on blue download now.
    will reroute to another page click on slow download button. took awhile. if downloading still takes awhile. maybe wants you to upgrade or pay? then mine started to download Microsoft essential stopped it because of severe risk. had to accept download then close and restart download. After finishing
    I had to click on download and extract. after opening the root options are on the right of the screen using rage or psneuter or something I tried both only the rage option worked. Hint: make sure your the drivers are installed to communicate to the program. I found mine on another root post cant remember which. anyway connect phone to pc check usb debugging and unknown sources in applications. do not mount the sd card only charge mode. after opening extracted file youll see superoneclick. open it and click the option on right (whether rage or psneuter) Id try rage first. the process will read on you computer screen. after it starts and if it get stuck on a process( same command not access or completing) i unchecked debugging on phone. will tell you rooted and reboot on its own. I hope this helps I am describing it from memory.
     
  23. industrialight

    industrialight New Member
    5

    Nov 21, 2009
    3
    0
    5
    Studio Lighting Specialist
    Springfield MA

    Good day, accidentally let the OTA FRK76 update slip through several weeks back, and am now having issues manually rooting with the 'Rooting the Droid without rsd lite up to and including FRG83D' method. I get so far as step 13 and my prompt is still $ & not #.

    Can you offer any advice / assistance? I would prefer not use any one-click method, besides, i'm running Ubuntu linux.

    Thanks in advance!
     
  24. teddyearp

    teddyearp Well-Known Member
    223

    May 19, 2010
    2,406
    831
    223
    Store Manager
    Pinetop, AZ
    Have you made sure that USB debugging is enabled on your phone?

    menu -> settings -> applications -> developement -> usb debugging -> checked

    Otherwise there is this method:

    [HACKS] Root Droid 1 - regardless of OS version

    which is pretty much the sure fire method, however you will need the sbf_flash binary to use on Linux instead of RSD Lite 4.6 for windows.

    good luck
     
    industrialight likes this.
  25. industrialight

    industrialight New Member
    5

    Nov 21, 2009
    3
    0
    5
    Studio Lighting Specialist
    Springfield MA
    Thanks so much for the assistance! Reading through everything now, I'll let you know either way

    =}


     

Share This Page

Loading...