Root Can't Uninstall Swype

Discussion in 'Android Devices' started by tsaunders, Mar 8, 2010.

  1. tsaunders

    tsaunders Well-Known Member
    43

    Nov 12, 2009
    419
    25
    43
    I have version 0.35.3989 installed for Swype. Every time I try to uninstall it says "Uninstall not successful"

    I am using Astro to uninstall this version of Swype.

    I can install the beta one that they just released, but it then tells me a version of Swype is already installed.

    Any idea how to uninstall this app?
     

    Advertisement

  2. -=Jeff=-

    -=Jeff=- Well-Known Member
    98

    Jan 2, 2010
    986
    31
    98
    Male
    Test engineer
    Bartlett, IL
    I had a problem where it would not populate info in Astro when you selected 'open App Manager' for the file. wonder if it is an issue within Astro
     
  3. ssantan2

    ssantan2 Well-Known Member
    38

    Nov 24, 2009
    352
    20
    38
    did you try uninstalling from settings->applications->manage apps?
     
  4. tsaunders

    tsaunders Well-Known Member
    43

    Nov 12, 2009
    419
    25
    43
    Yeah I tried that. I get the same issue.
     
  5. dasilvetz

    dasilvetz Member
    35

    Nov 12, 2009
    14
    0
    35
    I had the exact same problem, I am running SG 5.0.1 (which came with the leaked Swype beta) and the past couple of days i was getting the "trial expired" message, and trying to uninstall/install the legit beta was not working.

    Here is what I did to get it to work:

    1. Use the Applications manager to uninstall Swype Installer and anything Swype related.

    2. Reboot

    3. Open ASTRO File manager, and search for "swype" in "/"

    you should see two main files ( i dont have them anymore so i don't remember their exact names/path) one was called Swype.apk i believe, and the other was libSwypecore or something similar. *write down the path to both of those file* (watch for caps)

    4. Open Terminal Emulator and type "su" then your password

    5. Type in rm -r /pathtothefilementioneabove

    6. repeat for the 2nd file

    7. Reboot

    8. Re-download and install the Swype beta file from the confirmation email.

    That should work.
     
  6. noseguy

    noseguy New Member
    5

    Mar 9, 2010
    2
    0
    5
    Thanks for trying to help, but what the hell is terminal emulator?
    And do I type "su" then no space, then my password to what? swype?
    I love step by step instructions, but they are usually ineffective when a step is left out.
     
  7. johnlgalt

    johnlgalt Antidisestablishmentarian
    443

    Oct 28, 2009
    9,416
    1,923
    443
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    terminal emulator is an app in the market - download it and install.

    His use of the command
    Code (Text):
    1. su
    suggest that you need a rooted phone to make those commands work....
     
  8. shrink57

    shrink57 Well-Known Member
    143

    Dec 19, 2009
    1,529
    149
    143
    South Florida
    Another program that makes removing system apps easy (maybe too easy) is Root Manager. It provides menu driven access to programs that have been installed as system applications (be careful).
     
  9. Razor1973

    Razor1973 Member
    5

    Nov 4, 2008
    8
    0
    5
    Miami, Florida, U.S.
    Not only do you need root, you also need to mount /system as R/W. I recommend the following steps, assuming you are already rooted:

    1) Uninstall "Swype Installer" (optional; I did not have to).

    2) Search for "mount /system (rw /ro)" in the Market and install it (free).

    3) Search for "Terminal Emulator" in the Market and install it (free).

    4) Open the mount app and click "Mount r/w". I do not recommend you check the box to mount as r/w at boot.

    5) Open the terminal app and type the following ([Enter] represents the Enter key, so don't type it):

    su [Enter]
    rm -r /system/lib/libSwypeCore.so [Enter]
    rm -r /system/app/Swype.apk [Enter]
    exit [Enter]
    exit [Enter]

    6) Reboot the phone (optional; I didn't have to).

    7) Download Swype Installer (if you have it already; you don't have to redownload it) from https://beta.swype.com/android/get directly on your phone browser.

    8) Run Swype Installer and follow the prompts.

    9) Go into settings, enable and configure your Swype keyboard.

    Best of luck!

    Those of you who switch between 2 languages often, you do not have to press and hold the Q letter anymore. Just swype your finger from the Swype key up to the Q key. The first time, you will need to select your second language. After that, every swype will toggle between the two.
     
  10. smcquay

    smcquay New Member
    6

    Jun 20, 2011
    3
    3
    6
    I simply used Titanium Back-up to uninstall it (go to the Uninstall System Apps batch). Very easy, worked like a charm. Now running Swype 3.0 Beta - it's great!
     
    bobomatic, phoneturf and alyssa323 like this.
  11. phoneturf

    phoneturf Member
    15

    Jul 23, 2010
    10
    0
    15
    Thanks for this - I tried all the other methods for uninstalling swype including deleting every file in the system (using root explorer) that had swype in the title, and it still would not uninstall fully. Using titanium backup did it, though. It should be mentioned that when using the TiBu batch system uninstall, be sure to first choose DEselect All, then select the swype files, so you don't inadvertently delete all system apps.
     

Share This Page

Loading...