Contacts won't sync with Gmail? Problem?Support


  1. ytrebil

    ytrebil Well-Known Member

    Hi guys, not sure what

    Advertisement
    :
  2. ironass

    ironass Well-Known Member

    ytrebil likes this.
  3. ytrebil

    ytrebil Well-Known Member

    Thanks for the reply, but that article doesn
  4. ironass

    ironass Well-Known Member

  5. ytrebil

    ytrebil Well-Known Member

    Woohoo! Fixed it.

    Mods, this should be a sticky as I've seen a few people with Android have this problem and here is the fix:

    Gmail Contacts Won’t Sync on Android Phone

    Go to “Settings”. Select “Applications”.
    Select “Manage Applications”.
    Scroll down to “Contacts Storage”
    Click on “Clear Data”
    Go back to to “Settings” again and in “Data Synchronization”
    Resync by pressing “Synchronize Now”

    Although that's for the Desire, it's still the same for the Galaxy S2, although where it says 'Data Synchronization' it should be 'Accounts and sync'.

    This just worked for me so I hope it helps others.

    p.s. Make sure you back up the contacts on your phone maybe to your SD card. I didn't follow this step and didn't lose my contacts but it could well delete them all. Just a warning.
    sidbaxter, tomkidron, Dan1942 and 2 others like this.
  6. Dan1942

    Dan1942 Active Member

    Clearing Contacts Storage was the key for me. I kept clearing the "people" app, to get rid of multiple duplications of entries (like 15,000 dups of one entry) and trying to resync, but it went from bad to worse until I also cleared the Contacts Storage.
  7. jathemon

    jathemon New Member

    I took the above steps to resolve the problem. In order to clear my "Contacts Storage" under All Applications, I had to root the phone and install titanium backup (Atrix). However, the root issue was the fact that one of my contacts the day before had begun to duplicate itself (was essentially a spam email address) and made 30,000 copies! After manually deleting the entries from Gmail->Contacts->Other contacts, performing the clearing of the contacts storage, and then performing a factory reset (I couldn't get my contacts list to show up anymore...shrug....wasn't the first time that day I did the reset), everything was back to normal.

    The [android recovery] factory reset for the Atrix is also different than what many sites advertise. The proper sequence is "Volume Down + Power" until the boot menu appears, then press "Volume Down" until the Android Recovery menu option appears, press "Volume Up" to select, once the droid with the exclamation point appears, press both volume buttons at the same time for the recovery menu at the top, select either "Factory Reset" or "Wipe Cache" as desired, then select "Reboot Phone"
  8. shoaibanis

    shoaibanis New Member

    Hi!
    I am facing the same problem that I can not sync my contacts with my gmail account.
    I followed the above process but can not find useful for me.
    In addition whenever I sync with PC or gmail account I lost some of my contacts mostly recently saved.
    Please Help
  9. nath7153

    nath7153 New Member

    The warning is definitely worth consideration. I wish I had found this thread first, rather than the one I found earlier which had the same "fix" but without the warning, causing me to lose most of my contacts when gmail did a one-way sync to my HTC Wildfire.
  10. ShermCraig

    ShermCraig Member

    None of these suggestions helped. I have even gone as far as doing a complete wipe of phone. The contact reappear, and I've determined that syncing from google to my device works flawlessly. It's when I create a contact in my phone that it won't sync to google. In fact, I get an error on the contact sync settings page after creating a contact on the device. I have posted about this problem before on other forums, and nobody has offered a solution that works. So, anyone think they are smart enough to solve this problem? :smokingsomb:

    Looking forward to hearing about a fix!

    Attached Files:

  11. eibenstr3

    eibenstr3 New Member

    I have the same problem. After updating to Jelly Bean, any new contacts created in my Samsung S3 phone does not sync to Google! Syncs perfectly from Google to my phone though! :confused:

    I would love to hear any fix for this. Or I have to wait for next update??
  12. eldebarge

    eldebarge New Member

    I recently reset my phone and it only synced the first day. Everything else but contacts would sync, even though it wouldn't show an error message. Finally I backed up my Online gmail contacts, then deleted them, then my android phone started syncing properly, and it populated my online contacts with my contacts from my phone. :) whew!
  13. kirkers

    kirkers New Member

    None of the suggestions here or elsewhere have helped with the failure of my contacts to sync. :confused:

    In fact, my contacts have NEVER synced to my Google Play Store gmail account on my HTC Droid Incredible (DINC) with a rooted Verizon stock (deodexed) ROM: vsn 4.06.605.3 -- Android 2.3.4 Gingerbread. This ROM was very close to the original ROM, but it did implement the internal memory fix that lifted the 128MB cap and raised it to the 748MB maximum. There are ways of doing this manually with any ROM, but I did not need to do it with the ROM I am using.

    From the start, my phone contacts NEVER synced. I am betting the lifting of the 128MB memory cap had something to do with that.

    Recently (22 Dec), I began receiving low disk space (LDS) warnings, even though my sdcard reports nearly 4GB free out of 16 GB, and my internal memory stands at nearly 350MB free according to the "Manage Applications" page in phone Settings and Titanium Backup Pro's status page. Since the LDS warning began appearing, the HTC DINC has exhibited all sorts of problems, particularly disappearing or inaccessible apps, particularly those listed on a home screen. I went into phone Settings --> Applications and unchecked the Fast Boot option, which seemed to cure the apps problems MOST of the time. When the problem occasionally popped up, restarting the phone did the trick. The Fast Boot OFF tweak and phone restart had no effect on sync failure, however.

    Finally, yesterday (29 Dec) I received another LDS warning saying that I needed to free at least 512KB of space to permit mail to sync. Once that appeared, gmail stopped syncing my email. However, the native HTC/Android Mail app continued to sync email. :confused:

    After this last bit started happening, I had to take action. :mad:

    Here is what worked for me:

    1. Exported phone contacts to phone's SD card (sdcard) using HTC/Android Froyo 2.2.3 Contacts aka People app. (in app, Menu -> Import/Export)

    2. Used Titanium Backup Pro to uninstall enough apps to get rid of the LDS warnings. (I uninstalled Twitter, Facebook, a barcode scanner and a photo editing app -- that did the trick!) :D

    3. Ran the native Sync through Home screen -> Menu -> Settings. It worked, BUT ONLY THE VERY FEW CONTACTS IN MY GMAIL ACCOUNT WERE LEFT ON MY PHONE. (You MUST back up the phone contacts!) :eek:

    4. Imported contacts from sdcard back into the phone using Contacts/People app. (similar to step 1 above, but import.) IMPORTANT: Be careful to have only a single .vcf file in the root of your sdcard -- it ought to be the one People created in Step 1. The app automatically scans and loads EVERY vcard file it finds, which can create a load of duplicates. :rolleyes:

    5. Put the phone online (I used WiFi). Sync should automatically. However, I STILL found that the contacts did not sync! :mad: Went into Home screen --> Menu --> Settings --> Accounts & Sync (aka "Syncronization" in some Android versions), verified that auto-sync was checked (selected), touched on my Google account listing, and found the "Sync Contacts" unchecked (I KNOW it was checked before, because I saw that it was so! Go figure...). Checked the "Sync Contacts" box, selected my gmail account from the popup box that appeared (the other option was "Phone"), and contacts sync began automatically.

    ----

    It took a few minutes for my 250 contacts to load into gmail (I watched it happen on a PC linked to my gmail account), but now all seems well. :)

    What happens if and when I get another LDS warning is anybody's guess ...
    And why am I getting them anyway, since I have nearly 350MB of internal memory free?

    It seems increasingly clear that the "fix" lifting the 128MB cap is not glitch-free, at least as it was implemented in my deodexed rooted VZW stock ROM

    If anyone knows anything about how to lift the phone memory cap without any glitches (or at least not the sync failure and disappearing apps), please provide info or links here!
  14. kirkers

    kirkers New Member

    Now that my HTC Droid Incredible (Gingerbread 2.3.4 rooted stock VZW) is at least working again (all installed apps accessible, gmail + contacts sync-ing, no LDS warnings after uninstalling a few apps), it's time to REALLY figure out what is going on with the internal memory.

    I've always wondered about the "dalvik cache", and a quick web search revealed lots of action around this and various strange phone behaviours. But what to do?

    Well, I did a full "nandroid" backup using ClockworkMod Recovery just to be safe (there goes another GB on the old sdcard...), and dove in.

    It turns out it is quite simple AND quite safe (at least no troubles after a couple of hours...)

    The secret is to head over to DINC.DOES-IT.net (DINC.DOES-IT.NET - HTC Incredible Files) and pick up the following three relatively small files. In fact, they are so small that I just went into my phone webbrowser and brought them directly into the downloads folder of the sdcard (/sdcard/download/).

    The files are in the "ext4 files" folder. Specifically:
    Convert2Ext4_no_data_limit_normal_dalvik.v2.0.zip
    Convert2Ext4_no_data_limit_dalvik_moved.v2.0.zip
    Convert2Ext4_no_data_limit_dalvik_moved_Revert.v2.0.zip

    These can actually be found elsewhere on the Internet, and they are NOT customised for HTC DINC phones. In fact, they work for just about any hardware or Android OS flavour that uses the dalvik cache.

    These are the sort of zip files that are not accessible archives; they are system installer files.

    The one to try first is the one at the top, the "normal dalvik" model that leaves the dalvik cache in the internal memory while restructuring the /datadata folder. If you have formatted an Ext4 partition on your sdcard using ROM Manger for instance, you will likely be comfortable with Convert2Ext4, which appears to do similar work with the internal memory partition.

    If you start getting LDS warnings or other odd behaviours arise, the next one to try is the "move dalvik cache". This puts it in the (nearly empty) /datadata folder, but this is likely a risky move because there is only 128MB to play with here, so you are likely to have to uninstall plenty of apps to get things working again. Still, given the alternative, it is likely worth a go. If you want to back out of this decision, run the third "move dalvik cache restore" file to do just what it says: restore your phone back to the "normal dalvik cache" location.

    So, that is the overall strategy. How to get it done tactically, so to speak?
    If you have any experience rooting your phone and using an unlocked (S-OFF) smartphone, then it could hardly be easier.

    1. Launch Recovery through ROM Manager, or manually. (If you do not know how to do it, check out what the specific buttons on your model do while entering and operating in Recovery by searching this or other Android smartphone support sites.)

    2. Choose "install zip from sdcard" and maneuver to the folder containing the zip files you took off the web. Be careful to choose the right file to achieve what you want to do.

    3. After clicking on the proper zip file, Recovery should run through the process completely by itself without need of user intervention. In about 5 minutes, it should all be done. When the screen shows this is the case, back out to the root of Recovery and select "reboot phone".

    4. I found things were pretty slow and sticky on the first reboot, so I cold rebooted it one more time. It seemed much more responsive after the second reboot. Don't bother waiting for something to go wonky -- just do the 2nd reboot right away.

    After the change, I noticed my internal storage was now reporting 771MB (up from 748MB). At the same time internal memory reported only 307MB free (down from nearly 350MB) and the ROM now reported 20MB free, whereas before it was at most 1MB free (total size remained 270MB).

    Now that I see these new numbers, it seems that my worst troubles with limited space (e.g. needing 512kb freed to download email) might have somehow been linked to the ROM -- but I NEVER moved apps into the ROM, and always did everything I could to move them OUT onto sdcard. Anyway, the space pressure definitely seems lifted, with multi-megabytes in all three main storage and/or processing components.

    I immediately reinstalled the apps I took off to get rid of the LDS warnings -- this is the acid test, of sorts. No warnings, slowdowns, disappearing apps, or any other odd behaviours -- at least for the first couple of hours!

    If anything further happens that is worth reporting, I will do it here on this thread.
  15. Nixolay

    Nixolay New Member

    I've created a free (ad based) app "Contacts Sync Fix". You can find it on Google Play. It fixes some issues with sync.
  16. xeonbuilder

    xeonbuilder New Member

    That worked like a charm. That error is friggin annoying. So glad that little app fixed it in a second..

    Thanks
  17. gspatel

    gspatel New Member

    This works on the SIII -- don't know if it holds good for the SII -- and on Jelly Bean.

    When you enter a contact on the phone, you have the option of adding it to the phone contacts OR to the google contacts. When you add a contact on the phone, next to the green phone receiver icon it says "Phone" and then there's an arrow/drop down that lets you choose which contact book/list you want to add to. I chose google, and then added a contact, and it synced right up to the gmail contacts.

    I also set the "view contacts" option to google contacts only.

    This way both the gmail and the phone contacts stay in sync.

    Hope this helps.
  18. salado

    salado New Member

    First log into you Gmail on a computer and organize and merge all duplicates contacts, place contacts in categories if you want (I highly recommend).

    Now on your phone - go to contacts and export a backup of your contacts on your phone

    Then go back to contacts and delete all contacts on your phone.

    Now on your phone Go to
    hfg likes this.
  19. hfg

    hfg New Member

    Thank you - finally something worked. Have had a contacts sync problem since Jan 13. It was your remark about the 'tab' to find the Contacts Storage that finally did it! I had not been able to find the Storage as I did not realise there were tabs along the bottom in Applications Manager. It is not very obvious to a newbie!

    So thanks again - this might help someone else too
  20. androidskisquash

    androidskisquash New Member

    This app only works for Android 4.3 and up. There needs to be an app fix for version 2.2 & 2.3.
  21. pinaar

    pinaar New Member

    I read all previous posts and Googled some, but I'm dead in the water now.
    I deleted all my gmail account on droid which had previously only synced up to 12/8/13 and now it just won't sync, so it's empty!

    I'm running Android v4.3 on a Samsung S3. BTW, There is no "Contacts Storage" in any settings I can find! I've purged all caches.

    Thx - Art
  22. pinaar

    pinaar New Member

    Factory reset resolved my issue. Thanks! - Art
Loading...

Share This Page