Dead Onda Vi40


  1. nomiracle

    nomiracle New Member

    Hi,
    I'm new to this forum but I hope that somebody can spare a few minutes to help.

    I recently bought an Onda Vi40 through Ebay uk which was new and unused. It was about two months old when I got it and I've had it a month, I've just returned from a caravan holiday where i was using it regularly but unfortunately the battery drained and I've been unable to turn it on since. I contacted the seller who bought it from gadgetfreakz.com and he told me the order number for the warranty which I then contacted the retailer with. They've replied and suggested using USB to try and charge it so as to eliminate charger problems which I tried to no avail and also tried different 5v mains chargers but still no luck. I'm currently still waiting for gadgetfreakz to get back to me but wondered if anyone had any suggestions or if anyone has had this problem themselves?

    Any advice would be gratefully received as I'm desperate to use my tablet again!

    Best regards;

    Mark. ​

    Advertisement
  2. T.M.M.L

    T.M.M.L Well-Known Member

    Greetings nomiracle,

    Welcome to the forums.

    You don't mention anything catastrophic happening to your phone, so I think that i might be battery related.

    When you plug in your device to charge it, does any light come on to say that it's charging?

    If so, you may just have a bad battery. Even though the device is only a few months old, it's not unheard of to get a bad battery from the start.

    Did you try to take the battery out and put it back in?

    Does your USB port seem loose or jiggly? If so, the battery may not be getting any juice to charge.

    If a replacement battery isn't too expensive, you might try getting a new one to see if that makes a difference.

    Hope this helps
  3. nomiracle

    nomiracle New Member

    Hi T.M.M.L
    Thanks for the welcome, Its actually a tablet and there was never a light that shows it's charging so I can't tell if it is or not. It charges via a 'jack plug' type connector similar to a Nokia charger and I've checked and it all seems fine. The mini usb port apparently can be used to charge too but I've tried and I still have no life in the tablet. I'm getting so frustrated with it!
    Regards;
    Mark.

Share This Page