Desire's 8gb microsd suddenly read only??Support

Last Updated:

  1. badblackram06

    badblackram06 Active Member

    I am running froyo 2.2 not rooted or anything. I have most of my apps on the original 8gb microsd that the phone came with. Earlier today i was searching things on the Ebay app and it all of a sudden forced closed. Didnt think nothing else about it. I later played a game that is paritally on my sd card. It would not open. Saying the link to this app is no longer available or something similar to that. So i took out my sd put it back in. Turned my phone back on and i get a notification saying sd is read only. I tried unmounting it, reformatting it on the phone, ps3, pc, digital camera, another phone, etc.. But everytime it says disc is locked or write protected.. I can actually view the files on my computer but it wont delete them. I belive the card is just fried. Someone was telling me I can get it replaced through my carrier because its still under warranty. I dont care that it want reformat i just want all my information off the card. Is there a software that will do a force format on the sd card so i can turn it in with nothing on it?? Thanks

  2. Howard Hopkinson

    Howard Hopkinson Well-Known Member

    First, I suggest you try and backup the contents of your SD card to your computer(if you haven't already).

    If it won't let you copy it's contents, then I fear you're a bit buggered.

    As for forcing a format, you could try deleting the partition via gparted or some other partitioning tool, then repartition and reformat as fat32. If that still doesn't work, then I don't think you have many options other than either sending the card in as it is, or simply purchasing another card.
  3. SUroot

    SUroot Well-Known Member Developer

Share This Page