Droid X Videos Won't Play on Phone


Last Updated:

  1. droid_freak

    droid_freak Well-Known Member This Topic's Starter

    Joined:
    Mar 31, 2010
    Messages:
    199
    Likes Received:
    23
    Video I shoot on my Droid X won't play back on the phone, "Error File cannot be displayed or played".

    I am running 2.2 rooted and deodexed ver 2.3.9

    Anyone else had this problem?? :confused:
     

    Advertisement
  2. aldo

    aldo Well-Known Member

    Joined:
    May 23, 2010
    Messages:
    122
    Likes Received:
    62
    buildprop file has the edits that made your phone look faster in that testing program. Change it back and it'll work.
     
  3. Mojorisen

    Mojorisen Well-Known Member

    Joined:
    Jan 6, 2010
    Messages:
    151
    Likes Received:
    12
    Edit your "build.prop" file, and change the Stagefright values to false. That should re-enable your video playback ability
     
    droid_freak likes this.
  4. droid_freak

    droid_freak Well-Known Member This Topic's Starter

    Joined:
    Mar 31, 2010
    Messages:
    199
    Likes Received:
    23
    Got it all modified and included all the other mods at the same time. Running sweet now.
     
  5. onesicktexan

    onesicktexan Well-Known Member

    Joined:
    Jun 28, 2010
    Messages:
    82
    Likes Received:
    5
    I'm having the same problem with the exact same setup. I understand you had to modify the build prop file, but how do you change the Stagefright values to false? what exactly did you type/move??? Srry... And thanks in advance for the help.
     
  6. sund0wn

    sund0wn Well-Known Member

    Joined:
    Aug 10, 2010
    Messages:
    775
    Likes Received:
    175
    use root explorer. if you dont have it, get it. it's a rooted phone must-have.

    go to the /system folder, and find build.prop. long press it, and select open with text editor.
    scroll about 3/4 down the page, and look for 4 lines that have stagefright in them. the all probably say =true. change them all to =false. save it and reboot the phone. that should do the trick.
     
    onesicktexan likes this.
  7. Darkfreak232

    Darkfreak232 Active Member

    Joined:
    Sep 2, 2010
    Messages:
    37
    Likes Received:
    1
    the above post is the method i used but here is exactly how i did it

    1. Download RootExplorer
    2. go into your /system folder and find build.prop
    3. copy build.prop to your SD card (you might have mount r/w this is located on the top right in root helper)
    4. long press the build.prop on your SD card and select text edit
    5. scroll down until you find
    media.starfright.enable----=true and change it to
    media.starfright.enable----=false (there are 4 lines that need to be false)
    6. Copy the edited build.prop to your /system it will say something like youd you like to replace this file say yes.
    7. Reboot your Droid X
    8.Enjoy your Video Playback! :D
     
    onesicktexan likes this.
  8. onesicktexan

    onesicktexan Well-Known Member

    Joined:
    Jun 28, 2010
    Messages:
    82
    Likes Received:
    5
    Hey thanks guys, late response on my end. But tyvm for your help, phone is rebooting now. Have a great day.
     
  9. Darkfreak232

    Darkfreak232 Active Member

    Joined:
    Sep 2, 2010
    Messages:
    37
    Likes Received:
    1
    any time =) if you have any other problems you know were to go ;)
     
  10. j_ryan

    j_ryan Well-Known Member

    Joined:
    Jun 10, 2010
    Messages:
    131
    Likes Received:
    10
    My phone has this same issue playing video (.avi). I knew about changing the media.stagefright values, but mine were already set to false. I also can't play any type of music due to "Sorry, the player does not support this type of audio file." I'm running the very first 2.2 leak and have root. I plan to keep searching for a solution, so I'll update my post if I can solve it.
     
  11. OchoDirko

    OchoDirko New Member

    Joined:
    Oct 21, 2010
    Messages:
    1
    Likes Received:
    0
    Hey. I downloaded Root Explorer. Did just as you said, but when i got down to the stagefright values, they were already "false".


    AVIs still wont play...
     
  12. karripo

    karripo New Member

    Joined:
    Dec 11, 2010
    Messages:
    1
    Likes Received:
    0
    Did all that, was already =false. Videos still will not play on Droid X. I've already returned one to Verizon Wireless who couldn't figure it out either. Only videos that will play are ones I record on the droid. All other .avi, mwv .wav divx or any mp4 files will not play. HELP! Anyone?
     
  13. Delkomatic

    Delkomatic New Member

    Joined:
    Dec 28, 2010
    Messages:
    1
    Likes Received:
    0
    I am having the same issue as the guy above me. Nothing I do fixes this. It makes no sense what soever does any one know of anything that can help. I tried the above suggestions to no avail. Please help! I miss playing music and youtube on my phone!
     

Share This Page

Loading...