Email sync upSupport


Last Updated: 2013-01-23 06:14:57
  1. SFBayArea

    SFBayArea Well-Known Member

    I have never had any issues with the email sync up on my other android phone, so I assume that something is not write with the settings on my new Verizon S3.
    Basically, my phone does not synchronizes back with the yahoo nor google mail servers. For instance, when I walk my dogs in the morning I check my emails, and at the end I always press sync button to ensure that it syncs up with the server. However, when I come to work 40 minutes later both, my yahoo and my gmail still showing all the emails that I deleted 40 min ago. Why is that?

    Advertisement
  2. alison03

    alison03 Well-Known Member

    I am guess you're using the stock email app and if so we might have similar problems. I have it synced with my Yahoo account and the same thing happens to me. If I delete messages on my phone, they will still show up on my desktop and visa versa - same if I "read" a message...it won't change from unread to read in either one.

    I can't seem to figure it out and at times it makes me crazy because I get such a high volume of emails that I am reading the same ones twice without realizing it.
  3. SFBayArea

    SFBayArea Well-Known Member

    Yep, I use "stock" email app on the phone for my Yahoo and my Gmail account and yes, you right, I have absolutely the same problem, all of the above that you described, including "read" message.

    So if it is a problem, anybody have a solution?
  4. _Aardvark

    _Aardvark Well-Known Member

    Sounds like it's using POP.
  5. my3sons

    my3sons Member

    I am having a different issue maybe someone can help me with. I have gmail and I am using the gmail app, but I am getting notified twice of incoming mail, once for gmail and once for the stock email app. any suggestions. I am new to android.
  6. scooz16

    scooz16 Well-Known Member

    Turn off notifications on the stock app. Open it and go into settings.

    The one thing to remember in android is that each app has its own settings
    my3sons likes this.
  7. my3sons

    my3sons Member

    awesome! thanks so much
  8. SFBayArea

    SFBayArea Well-Known Member

    Why is it using POP, and how do I change it? I never had this issue on any of my previous android systems.
  9. davidmanvell

    davidmanvell Well-Known Member

    I have multiple gmail, yahoo and hotmail accounts and use them on both my phones and my desktop. They all connect to the exact same email accounts.

    Things to remember, if I check email on phone # 1. That phone must first resync with the server to update the server with the changes I just did. Then phone #2 and my desktop must do a sync for the changes that server just saw to update them. It gets complicated.

    The stock email app I think only syncs once every 15 minutes or so. The gmail app will do once a minute. Unless you change the timing.

    So take a look at your sync times and shorten them or make sure they are not set to manual sync. What I typically do is tell them to sync constantly then if i want to disable it I can within the notification bar.

    I can assure you the stock email apps work fine as for syncing. I have run into a few instances with the email servers going off-line, and if that happens obviously there is nothing anyone can do but wait.
  10. SFBayArea

    SFBayArea Well-Known Member

    Yep, everything you are saying is absolutely correct. However, if you do manual sync, by pushing sync "ring" in your email app on the phone then it should push out all the updates you did to your mailbox and only few minutes after you did changes to the mailbox on the phone should be seen on the computer or any other devices. Same thing should happen if you are pulling new emails from the server to the phone.
    Just now I went to my Yahoo mailbox on the phone and pushed sync button and I still have all the emails from two - three hours ago, which I deleted or viewed on my computer :-(. Something is definitely not right here.
  11. pchain

    pchain Active Member

    I have both a Galaxy Nexus and a Galaxy S3 side by side both set up identically with stock email app using exchange and the same live.com (hotmail) email address. The Galaxy Nexus receives push emails immediately while the S3 has a delay of up to an hour about 30% of the time. Sometimes I have to open the email app before it will sync at all. Secondly, the Galaxy S3 strips out the outgoing name (as it would appear in others inboxes) and defaults it to a lowercase name.name format that looks unprofessional. The Galaxy Nexus displays the outgoing name correctly. Of course when I called Verizon and walked them through the issues they said it was either an issue with Samsung or the exchange server. Highly annoying!
  12. SFBayArea

    SFBayArea Well-Known Member

    Dam agree,,, it is highly annoying!
  13. _Aardvark

    _Aardvark Well-Known Member

    Why, I dunno? When a generic email client (on any device) adds an account you either have to tell it what type of syncing protocol you want to use or the email client can try to detect it. This is further complicate if your email service(s) supports multiple protocols.

    Also, it seems like every damn android handset manufacturer has there own email application - and they love to enhance it (aka break it) on every new handset. This could be why it worked on other phones in the past...

    POP is the oldest protocol and basically acts like the way you're describing (gets the email, but deletes/read states are not synced). I'm sure yahoo and gmail (and the S3 email app) support pop. So my *guess* is that somehow you're using POP vs the better imap or activesync. I'd either try to edit (is that possible?) or delete/re-add those accounts and see if you can manually configure it to not use pop. This may require googling yahoo's and gmail's activesync/imap server names.

    Or just use the yahoo and gmail dedicated apps. This kinda crap is exactly why these apps exist.
  14. copperstorm

    copperstorm New Member

    I had a similar issue. I actually ended up deleted both accounts from the stock email set-up. I re-added the accounts and, for some reason, the sync works now. Might want to this..
  15. 2horses

    2horses Well-Known Member

    I'm trying the dedicated AOL app and it sucks. No synching, will eventually pull down messages, but it's way behind when it does. Gmail does seem to be working better - but I don't have a lot of activity on that account so don't check it as often. I have Touchdown for my exchange account. Sure hope they fix the native email apps functionality (or lack thereof) with an update soon!
  16. 2horses

    2horses Well-Known Member

    I've done that twice now for my aol account, and even tried to create it manually - but it still sucks.
  17. alison03

    alison03 Well-Known Member

    Chiming in again but yeah, I also tried deleting and "re-installing" my Yahoo account to the stock email app but the problem persists. I use the dedicated gmail app for my 3 accounts and that one runs perfectly. Everything is pushed instantly and if my phone is blinking at me but I read the email on the computer, the phone marks it read and stops blinking within seconds. Fantastic.

    My old Incredible never had an issue syncing between phone and computer so this is really frustrating. Even manually, I cannot get my phone and email to sync up to have the "same" unified messages. It's like I have two separate accounts on two separate devices with the some of same messages (depending on what I delete and which device I use to do so). Last night alone I had to manually delete 100 emails from my computer and then go to my phone and delete them again there.

    I actually also noticed that sometimes my phone will randomly show my inbox has 2 or 3 of the same messages (all 'sent' in the same minute by the same sender) when in reality I only received 1 message (as confirmed on my computer). This is making me crazy.
    Shedroidd likes this.
  18. SFBayArea

    SFBayArea Well-Known Member

    You said it well! Samsung needs to put a fix for it, after all, this is their flagship phone and it screws up simple email function that was available from the dawn of the Android.
    Shedroidd likes this.
  19. _Aardvark

    _Aardvark Well-Known Member

    With an Exchange (activesync) email account w/ the default email application the phone continues to show email notification (and count on the icon, in the email widget, and the LED) even if that email was read/deleted on another device (my work PC usually).

    Here's what I mean:

    1. New email arrives.
    2. Phone correctly shows a notification.
    3. On my PC I read that email.
    4. The phone continues to show the notification even after a long period of time. (wrong)
    5. If i open the email app it'll briefly show that email unread, but will sync right then and it'll be read (or deleted if it was). This is correct but I should have to do this.

    My previous android phone (Moto Droid X) would have eventually removed the notification after I read the email on my desktop. Main in the Gmail app also does the right thing and removes the notification (just point this out to prove this isn't an off-the-wall feature).

    The end result of this behavior is that I constantly have an email notification on my phone that is basically worthless when I'm in the office or just left.

    I'm pretty sure i see the same thing via push or a periodic (5 mins) sync.

    Anyone else seeing this?
  20. AntimonyER

    AntimonyER AF Addict VIP Member

    SImilar threads merged. Thanks for understanding. :)
  21. _Aardvark

    _Aardvark Well-Known Member

    My issue isn't exactly the same thing as the original. My account will sync, just not automatically (w/o opening the email app) like it should. The original thread was about email not syncing at all (other then new mail delivery)l. Oh well...
  22. tkamil

    tkamil New Member

    I had the same issue with both my Droid X (previous phone) and now Galaxy S3. The issue is that the quick setup for Yahoo mail assumes POP as the protocol (as someone above already mentioned). The solution is to:

    1. remove the account (SETTINGS > ACCOUNTS AND SYNC).
    2. add account
    3. email
    4. choose Others (do not choose Yahoo Mail)
    5. enter your yahoo information
    6. choose imap
    7. accept the remainder of the default settings.

    Good to go.
    Mganut likes this.
  23. jkruer01

    jkruer01 Member


    I was having this exact problem and IT WAS DRIVING ME NUTS! I did what you recommended and it worked like a charm! Thanks so much! I really appreciate it!
  24. svensett

    svensett Well-Known Member

    I have a similar but not quite the same issue. I have an email account set up that sends and receives fine, but it doesn't notify me when new emails arrive. I have notifications turned on and set for the email account, but nothing.

    Any ideas?
  25. scubastevexj

    scubastevexj New Member


    this is my first android, (formally Blackberry) and my wife has had android for years and i have managed hers for her, but i have the same syncing problems and same 2nd email. blackberry would sometimes require a manual sync for yahoo, but it was always right. i wonder is this is verizon's attempt to sync. i went to vzw/sync and it shows a duplicate email there as well. ARG!!!

    also i tried the previously mentioned remove and add as other, but the sync options are only 15 minutes. there is not an push option that way :( whats even better is thatmy emails says there is 3 new messages, in the drop down email selection on the stock app, but when i go into my yahoo, it shows two new messages and only says there is 2 new messages "(2)".

    as much as i like the open source concept of android, my work ipad gets it right :(

Share This Page