Geniatech Enjoy TV


  1. gio965

    gio965 Well-Known Member

    Hi, both firmwares are similar but I prefer 20110804 release because I seem more stable, no flash player inbuilt and it don't give any problem to play, smoothly, videos from youtube.
    sku|| likes this.
  2. sku||

    sku|| Well-Known Member

    Thanks :D About the games , do you know any games that using remote ???
  3. stasik

    stasik Well-Known Member

    any info/feedback for update20111104.zip ?? did any one install this? is it working fine?
  4. gio965

    gio965 Well-Known Member

    I'm sorry...:( but regarding to games, I don't know to give you any help
  5. enviro8

    enviro8 Well-Known Member

    Thank you for that, but I did that previously.

    I since noted that the white wand that came with the GTV 220 has a sticker with 0031 on it and the TV box has a matching sticker. The black wand that came with the My Gico ATV 1000 has a sticker with 0013 on it and the TV box has a matching sticker.

    It appears that they are different.

    Addendum

    The TV boxes have an internal USB port, some apparantly have/had two, and there is a wireless receiver plugged into it with a code number the same as that of the wand.
  6. enviro8

    enviro8 Well-Known Member

    The My Gica web site Geniatech MyGica Enjoy TV productos para Television Digital | Android TV states for the 20111104 download:

    "Version 1104 (4-11-11) upgrade Android 2.3 Gingerbread, no work youtube, full apk"

    Apparently their version does not support YouTubebut the site reports their 20111102 fixes the YouTube problem.

    I assume that other sources of these two updates are the same, however I can confirm the the 20111102 version plays YouTube very well.
  7. stasik

    stasik Well-Known Member

    i did install, but didnt mess much around. still problem with some youtube videos via youtube applet. the rest seems to work fine. waiting for next version..(
  8. enviro8

    enviro8 Well-Known Member

    As I posted above, I bricked my GTV 220 during an upgrade. Actually I don't think it is fully bricked as it partially starts but freezes before boot completes.

    I suspect that the bootloader program is faulty.

    I have tried a variety methods to get it to the point where it will boot to the point where it reads an update on a SD, but it simply freezes before it can.

    I have tried all combinations of the reset switch/power plug/power switch. Nothing!

    I opened the unit and found an internal reset switch. I tried every combination, no luck.

    I saw an internal USB port with a WiFi receiver for the wand. I removed and plugged in a USB cable and connected it to my PC hoping that I could access the onboard system areas or bootloader program or something so that I could reflash it or something. All it did was to power the box up but it still froze during the boot.

    The PC did not even recognise that the box had been connected. It was similar with the two external USB ports. I also tried it with my operating ATV 1000, same thing. (Note: If your power supply dies, then the box could be run from one of its USB ports with a mains power/USB adapter - what about in the car with a car TV/Video/DVD and USB car charger??

    Having a look around inside the unit, I note one free 2 pin, one 3 pin and one 4 pin sockets. Could these be used to reflash the box, if so, how?
  9. ATV2000

    ATV2000 Member

  10. Yocee

    Yocee Well-Known Member


    Hi!

    in this post: http://androidforums.com/3362449-post144.html szemo77 wrote from the ttl cable, and uboot programing. You nee a pc with rs 232 serial port, or usb to serial converter, need a ttl programer cable : Simple TTL to RS232 adapter | Scientific, embedded, biomedical, electronics contents. and software for this operation.

    this thing is same for router unbricking:
    DD-WRT Forum :: View topic - How to unbrick WNR834B v1 (JTAG HELP)
  11. szemo77

    szemo77 Well-Known Member

    I think to that only bootloader freez at debug mode. First time I brick my ATV300 with wrong SPI and I use ttl cable to connect serial goldpins. There is Uboot. Some log from my unbrick action :) You must take some Uboot commands to load first only SPI and then base firmware.
    Code:
     
    Firmware start at: 0x0000999c
    lane00 Success05
    lane01 Success05
    lane02 Success05
    lane03 Success05
    RSLR0=00000249 RDGR0=00000249
    Stage 00 Result 00000000
    Stage 01 Result 88000000Enter Debugrom mode at /home/steven/source/u-boot/board/amlogic/stv_mbx_m3_512/firmware/lowlevel_init.c:0x00000039
    >
    >q
    
    Firmware started, now starting u-boot...ucl decompress
    5Rţdy
    U-Boot Version: 2010.06-V1.3.4(20110621.175140)
    DRAM:  512 MiB
    NAND:  Amlogic nand flash uboot driver for m1, Version 1.0 (c) 2010 Amlogic Inc.
    NAND device id: ad d7 94 9a xx xx
    NAND device: Manufacturer ID: 0xad, Chip ID: 0xad (Hynix B revision NAND 4GiB H27UBG8T2A)
    1 NAND chips detected
    nand0 initialized ok
    SF: Got idcode c2 20 16
    SF: Detected M25X32 with sector size 4096, total 4194304 bytes
    
    SPI NOR Flash have write protect!!!
    In:    serial
    Out:   serial
    Err:   serial
    KGDB:  ready
    MMC:   SDIO Port A: 0
    Net:   select eth clk-1,source=400000000,out=50000000
    Apollo EMAC
    Dcache status 1
    Icache status 1
    ENTER U-BOOT SWITCH MODE !!!!
    SF: Got idcode c2 20 16
    SF: Detected M25X32 with sector size 4096, total 4194304 bytes
    
    SPI NOR Flash have write protect!!!
    4096 KiB M25X32 at 0:0 is now current device
    efuse mac is : 00:xx:xx:xx:xx:xx
    Saving Environment to SPI Flash...
    Erasing SPI flash...Erase:0
    Erase:1000
    SF: MXIC: Successfully erased 8192 bytes @ 0x3e000
    Writing to SPI flash...done
    get_adc_sample(4): 0x3ff
    get_adc_sample(4): 0x3ff
    get_adc_sample(4): 0x3ff
    get_key(): 0
    Normal Start...
    Hit any key to stop autoboot:  0
    STV #
    STV #
    STV #[B] mmcinfo;fatload mmc 0:1 82000000 spi_M3_256.bin;[/B]
    
    Partition Map for UNKNOWN device 0  --   Partition Type: DOS
    
    Partition     Start Sector     Num Sectors     Type
        1                  247         3991433       6
    Device: SDIO Port A
    Manufacturer ID: 0
    OEM: 0
    Name: ATran Speed: 40000000
    Rd Block Len: 512
    SD version 1.10
    High Capacity: No
    Capacity: 2044723200
    Bus Width: 4-bit
    
    Partition Map for UNKNOWN device 0  --   Partition Type: DOS
    
    Partition     Start Sector     Num Sectors     Type
        1                  247         3991433       6
    reading spi_M3_256.bin
    
    1975596 bytes read
    STV # [B]sf probe 2;sf erase 0 200000;sf write 82000000 0 200000[/B]
    SF: Got idcode c2 20 16
    SF: Detected M25X32 with sector size 4096, total 4194304 bytes
    
    SPI NOR Flash have write protect!!!
    4096 KiB M25X32 at 0:2 is now current device
    Erase:0
    Erase:1000
    Erase:2000
    Erase:3000
    Erase:4000
    .....
  12. szemo77

    szemo77 Well-Known Member

    There is one more rebranded Geniatech ATV1000 in market. Now in EU
    Hmm datasheet and manual is from 10.2011. Box is shipped with Android 2.3
    http://media-tech.eu/products/media-droid

    Manual:
    http://media-tech.eu/download.php?id=5224&lang_code=en&type=instruction
    Marketing datasheet:
    http://media-tech.eu/download.php?id=5278&lang_code=en&type=promotion

    Mediatech relese firmware on website only for Rockchip android box; :/ for ATV1000 not. Pity, because according to the manual firmware for their ATV1000 looks very good and stable version.
  13. enviro8

    enviro8 Well-Known Member

  14. enviro8

    enviro8 Well-Known Member

    Thank you for your assistance.

    I will get all the bits and pieces and give it a go.
  15. enviro8

    enviro8 Well-Known Member

    Thank you

    I will give it a go.

    It has been many years since I got into the electronics of a machine.
  16. cupi1234

    cupi1234 Active Member

    Hi!
    enviro8!
    At a moment I have the same problem with my "Lifeview Not Only Tv" when I first try to upgrade to 2.3 .
    Just power up the unit and it stay at the android logo.This was after the SPI update.My first reaction was the same , that I bricked my unit.
    After some tries I renamed a 2.2 update package to .img and the unit revive...
    The SD card was in the machine before I press the reset button and plug in the power plug.
    Before all these ,pull out the AC adapter and press the power button.(for fully discharge the adapter)
  17. szemo77

    szemo77 Well-Known Member

    stasik and Surcouf35 like this.
  18. fcatrin

    fcatrin Member

    Hi!

    Anybody knows why this devices sets 720p = 1200x690 and 1080p = 1800x1040 instead of the standard 1280x720 and 1920x1080?

    Is that a problem with my tv/monitor? or there is an historic/good reason to set that resolutions?
  19. enviro8

    enviro8 Well-Known Member

    Thank you for the advice. I tried it to no avail.

    When I boot/start up I do not get to the logo stage but I am frozen out part way through an update stage.
  20. stasik

    stasik Well-Known Member

    yep, no market. i tried to install applications from web browser, but it says i already installed (installed on previeous update). but the good news, youtube application now is working fine! finally..flash 10.2 installed. also stereo sound is working fine. a note to make that the network by default is off. the rest to be tested, but so far so good. i dont worry much about market, as i have all aplications on sd card anyways.

    fcatrin, u can sellect 720i, 720p, 1080i, 1080p, but dont know the pixels exactly. i presume 720 is 1280x720, and 1080 is 1920x1080, well that is the standard anyway. but u also can move the 4 edges of the screen in or out separately, so that is handy in case ur tv is of odd pixels and ur picture wont be left out
  21. szemo77

    szemo77 Well-Known Member

  22. fcatrin

    fcatrin Member

    Those are the resolutions I've expected but no, it uses some non-standard resolution.

    I think that this is to avoid loosing part of the content in some TV's, althought that's not my case.

    I finally found that setting some properties on uboot you can switch to the standard resolutions. I haven't rebooted yet, and I hope those changes persists upon reboot.
  23. enviro8

    enviro8 Well-Known Member

    What No Market with 20111117Update.zip?

    Get it here!!

    What you will need is:

    DownloadProvider.apk (already installed with the 20111117update)
    Gmail.apk
    GoogleServicesFramework.apk
    Vending.apk
    RootExplorer.apk

    Where do you get them?

    1. Download
    josjator and Dual_HD like this.
  24. Dual_HD

    Dual_HD Well-Known Member

  25. enviro8

    enviro8 Well-Known Member

    Sorry my error I think, it is probably a gmail account but really cannot recall what I did. All I know is that I login with a gmail address and enter my password and away it goes.

    Someone else may be able to enlighten us.

Share This Page