GPS seems like its taking forever :(Support


Last Updated:

  1. Raptor5150

    Raptor5150 Well-Known Member This Topic's Starter

    Joined:
    Jul 10, 2011
    Messages:
    254
    Likes Received:
    34
    Sitting here for the last seems like 5 minutes with my brand new Triumph on MIUI latest to get a lock.. and even when i do (After flashing that ags patch thing) i still have a big circle around my dot.. and it kinda expands sometimes.. i also started jumping between 3g and 1x for some reason o.o maybe ill try it outside tomorrow..


    just thought i share
     

    Advertisement
  2. agentc13

    agentc13 Daleks Über Alles VIP Member

    Joined:
    Aug 31, 2011
    Messages:
    7,916
    Likes Received:
    5,482
    It's not going to work well indoors. Go outside, it's much faster.
     
  3. Raptor5150

    Raptor5150 Well-Known Member This Topic's Starter

    Joined:
    Jul 10, 2011
    Messages:
    254
    Likes Received:
    34

    ok i just sat outside for 3 minutes and got 6/6 Satellites but no lock.. i did the GPS.conf mod..

    what does the 6/6 mean anyway ? if i connected to those satellites why didnt i get a lock?

    got some progress with gpsfix..

    kk GPSFIX locked in seconds... :D and works with navigation.. im happpy :3
     
  4. iSnow

    iSnow Banned

    Joined:
    Nov 29, 2011
    Messages:
    238
    Likes Received:
    74
    Just got mine today....locks instant....light bleeding around the bottom...no big deal. Loving it!!! Typing from it now
     
  5. agentc13

    agentc13 Daleks Über Alles VIP Member

    Joined:
    Aug 31, 2011
    Messages:
    7,916
    Likes Received:
    5,482
    Here is what the dev for our CM7 ROM said about GPS.

    This would hold true for MIUI as well, since it is based off the CM7 code.

    I think in another post he stated that AGPS was shut off in the stock ROM as well. It may take way longer on stock since it doesn't have the GPS fixes that he did in there.
     
  6. tqlla

    tqlla Well-Known Member

    Joined:
    Jul 10, 2010
    Messages:
    218
    Likes Received:
    22
    I got mine yesterday from Virgin mobile.

    It is a Rev A, made in July. When was your phone made? You can find the info underneath your battery.

    I cant believe they still have the original batch at VM. Terrible.
     
  7. elricbillman

    elricbillman Member

    Joined:
    Dec 6, 2011
    Messages:
    11
    Likes Received:
    1

    I am also experiencing the drop to 1x.
     
  8. ecarlson

    ecarlson Well-Known Member

    Joined:
    Aug 18, 2011
    Messages:
    184
    Likes Received:
    34
    Are you sure it was an actual GPS lock? At first my Triumph appeared to lock quickly when using something like Maps, but it was not actually getting a GPS lock, it was using WiFi assisted positioning.

    Once I turned off WiFi, it took forever to lock (many minutes to never). And even with WiFi on, using either "GPS Status" or "GPS Test" apps, you could clearly see that GPS was not getting a lock. You could also very easily tell because the GPS icon up top was still flashing.

    What method did you use to confirm you were getting an actual GPS lock? Did you turn off WiFi, and/or did you use one of the GPS info apps like the ones mentioned above, and/or did you see the GPS icon stop flashing?
     
  9. HamDog

    HamDog Member

    Joined:
    Oct 11, 2010
    Messages:
    14
    Likes Received:
    3
    The GPS problem is a known issue. I've owned my Triumph since the day it was released. Got my sister one too. Never worked properly. Sometimes you get lucky. I've gone back to looking up maps on my computer and printing out directions than relying on the GPS on this phone.

    Motorola isn't gonna do anything about it. Virgin Mobile isn't gonna do anything about it. For us, it's the trade off for getting a cheap phone with a cheap service. I don't travel much, so the GPS problem isn't really an issue for me. I'll deal with all the issues at $25/month.
     
  10. Whyzor

    Whyzor Well-Known Member

    Joined:
    Jul 7, 2011
    Messages:
    1,108
    Likes Received:
    966
    I think CM7 (& MIUI) has some improvements, but I don't depend on it too much. A trick I use is to load up google maps in a browser and find the destination, then save the map screen (so i can look at it later in case data connection is finicky). Or even have the direction steps pre-loaded. I find depending on GPS too much is bad for my sense of direction anyway.
     
  11. magohn

    magohn Well-Known Member

    Joined:
    Dec 15, 2010
    Messages:
    519
    Likes Received:
    42
    Im using MIUI and though the GPS can take up to 5 mins (never less than 2 mins), it does eventualy connect.
     
  12. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Joined:
    Oct 5, 2011
    Messages:
    5,533
    Likes Received:
    4,293
    Anyone having trouble with GPS lock on cm7, try this
    Thanks to one of or developers over on the prevail thread. Made a world of difference on my prevail AND my roommate's triumph. Hope this helps you as well

    here is a link to the entire thread if your interested: http://androidforums.com/galaxy-pre...ark-s-cm7-gps-fix-tracker-booster-update.html
     
    Kreatur3 and Alpha06 like this.
  13. TriumphLance

    TriumphLance Well-Known Member

    Joined:
    Dec 6, 2011
    Messages:
    331
    Likes Received:
    24
  14. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Joined:
    Oct 5, 2011
    Messages:
    5,533
    Likes Received:
    4,293
    It should. He claims to use it on EVERY ROM he installs.. If I'm not mistaken it tells your phone to exclusively use the US satellite pool. read the thread. Many other suggestions there too.
    Just make sure to make a back up first (or at least copy your original GPS.Conf so you can replace it if it us worse)
     
    TriumphLance likes this.
  15. Whyzor

    Whyzor Well-Known Member

    Joined:
    Jul 7, 2011
    Messages:
    1,108
    Likes Received:
    966
    Has anyone noticed an improvement in CM7? I thought TG mentioned that aGPS doesn't work on our phones and he disabled it.
     
  16. agentc13

    agentc13 Daleks Über Alles VIP Member

    Joined:
    Aug 31, 2011
    Messages:
    7,916
    Likes Received:
    5,482

    Correct, it is also disabled on stock and MIUI.
     
  17. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Joined:
    Oct 5, 2011
    Messages:
    5,533
    Likes Received:
    4,293
    Doesn't agps have to do with network based location? (correct me if I'm wrong)This improved lock time with nbl off...(on prevail) I was mostly referring to the config file and/or use of faster fix. Sorry for any confusion
     
  18. TriumphLance

    TriumphLance Well-Known Member

    Joined:
    Dec 6, 2011
    Messages:
    331
    Likes Received:
    24
    I just got an instant GPS lock when I started GPS tracker and then went into Google maps on my Triumph. Before it kept thinking I was about a half mile down the road. I then turned off track booster and my location stayed locked in Google.maps
     
    Lordvincent 90 likes this.
  19. iSnow

    iSnow Banned

    Joined:
    Nov 29, 2011
    Messages:
    238
    Likes Received:
    74
    using 3g and it was accurate to 0 feet.
     
  20. Alpha06

    Alpha06 Active Member

    Joined:
    Dec 9, 2011
    Messages:
    32
    Likes Received:
    6
    DUDE.

    I was one minute away from returning my Triumph when I tried this.

    BAM. from 2-3 sat locks to 6-8, and a decent location accuracy

    THANKS

    :D

    The software is all screwy, the hardware is fine I guess!
     
  21. piper_

    piper_ Well-Known Member

    Joined:
    Oct 13, 2011
    Messages:
    237
    Likes Received:
    45
    I use GPS all day long disable wifi and it works well
    I use it as a truck driver and it works well for me
     
  22. Alpha06

    Alpha06 Active Member

    Joined:
    Dec 9, 2011
    Messages:
    32
    Likes Received:
    6
    Bah. For some reason GPS is totally dead for me in Manhattan.

    I travelled 9 miles away and tested in Brooklyn yesterday. Lock on was 1-2 mins.

    Today...Manhattan...5-6 minutes.

    Ridiculous.

    Time for a replacement. This SUCKS.
     
  23. Tellerve

    Tellerve Member

    Joined:
    Dec 26, 2011
    Messages:
    8
    Likes Received:
    0

    So, I'm quite new to messing with my phone but switching to CM7 was quite painless, and I'm happy with that. However, I can't seem to get this to work, I keep getting invalid permissions when I try and back up the old gps.conf file and when I try and bring the new file in it says its a read only file system so it won't let me copy in. I'm assuming I need root access, but I obviously misunderstood and thought that CM7 would give me that. What's the best way to get that, as I'd love to get the gps working better.

    Thanks, and Merry Christmas, Happy Holidays and all that jazz.

    Tellerve
     
  24. ziggy46

    ziggy46 Well-Known Member Developer

    Joined:
    Aug 14, 2011
    Messages:
    1,688
    Likes Received:
    612
    are you using root explorer or some other app?

    if your using root explorer, make sure at the top right of the screen you see "r/o". if thats showing it means that the system is mounted as read and write, so you can modify the files in your phone :D
     
  25. Tellerve

    Tellerve Member

    Joined:
    Dec 26, 2011
    Messages:
    8
    Likes Received:
    0
    Yep, figured it out...good old user error :)


    Thanks,

    tellerve
     

Share This Page

Loading...