Guide to backup and restore apps with Titanium Backup


  1. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    Do you have anything in that folder on your external_sd card? You need to verify where TiBu is actually backing up to. You could do this two ways:

    1) back-up an app (don't do them all...one is fine). Then go to the "mnt/sdcard" directory and see if there is a newly made "TitaniumBackup" folder.

    2) Copy your "TitaniumBackup" folder from your "external_sd" directory to the "mnt/sdcard" directory. Go back into TiBu and see if your restore data is accessible.

    I don't think TiBu can be set to save outside of that "mnt/sdcard" directory...I think that is the default location.
  2. looksbetterinred

    looksbetterinred Well-Known Member

    I backed up something that was new so I could find it. It looks like it backed up to mnt/sdcard.TitaniumBackup I think this is the internal sdcard. I looked on the external, nothing new is there. The backup files I made before I flashed are all there.

    Maybe when I get home I can try moving them the the internal sdcard and see what happens. Loving Serendipity, just need to figure this out lol.
  3. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    Sounds like you found the problem. Your TitaniumBackup directory needs to be moved to where your backup file was added. This is the one and only place TiBu is looking for save data.
    looksbetterinred likes this.
  4. looksbetterinred

    looksbetterinred Well-Known Member


    As always, a wise sage! Thanks BU for the help!!!!
  5. looksbetterinred

    looksbetterinred Well-Known Member

    I used "move" in "my files" and just copied over the existing folder... worked like a charm!!
  6. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member

    Very cool! Isn't it great when things work like they are supposed to? :D
  7. Rhonda1964

    Rhonda1964 Active Member

    Ok, so I rooted and dl'd titanium backup (pro) and did the first big backup of everything. I saved everything to a file on my pc for safe keeping. Having done that I decided to 'freeze' some of the bloatware and the first thing I saw to freeze was Documents to Go. It's been "freezing" Documents to go for exactly 10 minutes now. Is this normal? Does it really take this long? The green circle is active. You can see it's making it's little circle indicating it's working. Ok it's been 11 minutes. This can't be right.
  8. nuttmeg

    nuttmeg Well-Known Member


    before using the app did you click the PROBLEM button first and let it install the latest busybox? Also you can close and retry it again.
  9. Rhonda1964

    Rhonda1964 Active Member

    Ok, 19 minutes later. Titanium Backup Pro is stuck "freezing" Documents to go. I've closed out of TiBu but when I open it back up, the "freezing Documents to Go" screen is still active. I went into Settings, Applications, Manage Applications, Tibu to see if I could forcer close it but I don't see an option to force close. Any suggestions. I guess I may have to reboot.
    Anyone else have this issue? I'm not too worried 'cause I have everything backed up but I think I've read every page on the Ascend forums and I don't recall seeing anyone mention this.
  10. Rhonda1964

    Rhonda1964 Active Member

    Hi Nuttmeg, yes, I did click on "problems" got the latest busybox. I did spring for the pro version of Tibu. The backup went fine.
    I tried closing the app and starting up again. When I opened the app back up, it went right to the same screen where it is attempting to "freeze" the app.
    I resorted to rebooting the phone.
  11. Rhonda1964

    Rhonda1964 Active Member

    Reboot did the trick. I think I figured out what happened. I had turned off USB debugging. When I went back in to Tibu after reboot, it popped up a message that I had USB debugging off so I enabled USB debugging again went back into Tibu to try to freeze Documents to Go and it gave me the option to 'defrost' so I guess that means it worked.

    But that brings up a question. Do I have to leave the USB debugging enabled all the time now, or only when working with Tibu?
  12. nuttmeg

    nuttmeg Well-Known Member

    Yes leave usb debug on...i do and no problems...
  13. Rhonda1964

    Rhonda1964 Active Member

    Thanks so much. Now on to setcpu and Icarus. I think. Maybe CM6. Not sure yet. Can't make up my mind. Might get brave and start w/ Icarus and later try CM6. Too many decisions. My head hurts. Maybe I'll go play in the garden for a while first.
  14. nuttmeg

    nuttmeg Well-Known Member

    setcpu is not needed on icarus,cm6,or cm7. icarus is set at 600mhz, while cm6 and m7is set at 710...i would recommend a cm6/7 version.
  15. Dr8k3

    Dr8k3 New Member

    Okay So today I decided to root my new huawei ascend metro pcs tapout edition. Once I completed the process I backed up Messaging 2.2.1 then unistalled it after I downloaded GO SMS Pro, For some odd reason my phone will not allow me to send or receive mms messages. I stil have the backup of Mesaging 2.2.1 and I tried to Reinstall it by going to batch>restore missing apps with data. I then ran the batch operation only to find out that the app was still not reinstalled is there any possible way that I can fix this issue so that I can send and receive mms messages?
  16. hakujin

    hakujin Well-Known Member

    anyone seen this as of late? '1 backup. None on chosen platform'

    what the heck does this even mean? I've been doing full backups for awhile, but never after doing batch backups did my apps still show the exclamation icon and this verbiage before. Running GB 2.3.

    I reckon they will still restore ok, but aggravating as the it's harder to discern w/ everything having this exclamation icon (despite filtering)... could not find a damn thing about it on TB wiki either.

    edit: nevermind. 3.8 resolved. something funky going on w/ 3.7.7
  17. adriana27

    adriana27 Member

    What would happen if this was done after I backup but not restore yet?

    I did it:eek: and now I have this little window that says "Done! Click to restart Titanium Backup..." But I dont know if I should do that without restoring first...

    I was able to backup, but as I said I can't restore cuz I don't have anything in the "restore missing app with data" option...

    Please any help :(

  18. MoneyHoarder87

    MoneyHoarder87 Well-Known Member

    Have you removed any apps yet or have you just backed up and thats it? You can just restart it.
  19. akajr22

    akajr22 New Member

    i just got 2.2 on my ascend and everything is working fine.... my question is should i format my sd?? someone please answer me
  20. akajr22

    akajr22 New Member

    how do i restore apps after upgrading to 2.2?? someone please answer
  21. tygsociety

    tygsociety New Member

    z4rooted then did the titanium back up then deleted canvas, now freezes at metro screen but i can recieve text n calls please help
  22. bladesman

    bladesman Active Member

    @ UBR,

    Thanx for this ex guide, ive just installed Darky's 10.1 E_E on my SGS and was a little unsure how to go about with the Restore but with your guide managed to successfully Restore all my missing apps - I upgraded from Stock froyo 2.2 (Branded 3UK).

    The only problem I had was after the Restore began it seemed to stall at 0% on the very 1st app - after maybe 10 mins when it was clearly not moving I selected 'Undo/back' not sure what it is on the Huawei but just cancelled the operation basically. No harm was done and despite the 0% it had installed the very 1st app.

    The solution was easy as described on the wiki but i wont go into it as its a Samsung related problem and dont wanna hi-jack your thread.

    Once again many thanx.
  23. UBRocked

    UBRocked VZW Nexus Please!!! VIP Member


    NP! TiBu is a great app and I'm using it right now on my Thunderbolt :)

    Just glad to be able and save some people the trial and error some of us had to go through when this first came out.
  24. scary alien

    scary alien not really so scary Moderator

    tygsociety,

    I've moved your thread to the all-things-root sub-forum. Hopefully, you'll get a few responses in there.

    Cheers!
  25. BigScoob25

    BigScoob25 New Member

    I have a Huawei ascend which came with the 2.1 version of android and was rooted and i could uninstall any program factory or not,and now the phone is updated to 2.2.2 which is great and it is rooted with gingerbreak but titanium backup keeps coming back with an error saying apk file can not be located when trying to uninstall apps i uninstalled a few weeks ago before the update...any help please =)
Loading...

Share This Page