1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

Hello Android stops running on Eclipse . can not display App on Emulator.

Last Updated:

  1. shodhanshah

    shodhanshah New Member


    I setup Hello Android sample app on my Eclipse ( Windows XP). ADT got installed correctly. All post installation config also looks good. I setup HelloAndroid project.

    I run first time . It was successfully run and connected to emulator , produced desied message on emulator.

    What happened , when i tried to run same program again it stopped working at console trace ( see below console trace). I tried to reset Adb from debug view. Also tried to kill Adb from command line. I completely exited from Eclipse and restarted. At last completely rebooted PC but no luck.
    I never changed my code a bit after running successfully first time.

    Hello Android stops at following message.

    Any help is highly appreciated.


    [2010-07-08 16:08:59 - HelloAndroid] Starting activity com.example.helloandroid.HelloAndroid on device
    [2010-07-08 16:09:02 - HelloAndroid] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=com.example.helloandroid/.HelloAndroid }

  2. cp1

    cp1 Well-Known Member

    What happened on the emulator when you ran it? Was it already booted and unlocked?
  3. shodhanshah

    shodhanshah New Member

    I found what happened. Everything was fine however emulator was on home screen and application was running in background . I switched to application screen and found that app was running fine. I spent 2 days on this silly issue. I found on net that lots of people complain about same issue. Seems like most of them are good but donot realize that they have to switch to application mode on emulator.
  4. mayur2684

    mayur2684 New Member

    @shodhanshah - Now everytime u run in eclipse, its display result? Application screen, you have mentioned, is eclipse or something else?

  5. ankita

    ankita New Member


    I am new to android and I am getting this same problem as u had got.

    Can u please help me on resolving it?

    How did u switch to app mode on emulator?

    thanks in advance.
  6. iammilind

    iammilind New Member

    There is one work around way to achieve this.
    if you want to see the application,
    --> When the phone is locked then, simply press the "Menu" button on the phone keyboard.
    --> When the phone is unlocked then, press "Home" button and look at one triangle slider in the bottom of the screen. Pressing that will launch all the applications, your application also will be residing in the bottom. Just double click your application and it will run the program !! :)
    jktittalom likes this.
  7. kevin_n

    kevin_n New Member

    Hi, I am new to Developing.
    I had the same issue as you and my emulator just stays stuck on the ANDROID screen. Restarting Eclipse and the emulator did not help.

    During this issue, the console will read:

    [2010-11-14 20:23:02 - HelloAndroid] Starting activity com.example.helloandroid.HelloAndroid on device emulator-5554
    [2010-11-14 20:23:03 - HelloAndroid] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=com.example.helloandroid/.HelloAndroid }
    [2010-11-14 20:23:03 - HelloAndroid] ActivityManager: java.lang.NullPointerException

    Other times this issue is present, the console reads the same above except without the NullPointerException line.

    Any help is greatly appreciated, thanks!
  8. yogu2912

    yogu2912 New Member

    I am new to android .
    i got stuck near

    2011-04-19 16:33:35 - secondandroid] Android Launch!
    [2011-04-19 16:33:35 - secondandroid] adb is running normally.
    [2011-04-19 16:33:35 - secondandroid] Performing org.android.samples.secondapp activity launch
    [2011-04-19 16:33:35 - secondandroid] Automatic Target Mode: using existing emulator 'emulator-5554' running compatible AVD 'AVD2.31'
    [2011-04-19 16:33:35 - secondandroid] Uploading secondandroid.apk onto device 'emulator-5554'
    [2011-04-19 16:33:35 - secondandroid] Installing secondandroid.apk...
    [2011-04-19 16:33:40 - secondandroid] Success!
    [2011-04-19 16:33:40 - secondandroid] Starting activity org.android.samples.secondapp on device emulator-5554

    it is stuck here
    and i think activity manager is not displayed
    and application not displayed on emulator.It shows home screen.

    Can any one help????
  9. joelteply

    joelteply New Member

    For example on samsung epic you had to slide the lock button over.

    May I be not the first to state that this is one of the many many annoyances I have with android, as a veteran programmer with three years experience developing for iPhone. It's dumb problems like these which prevent people from wanting to develop for the thing. There shouldn't be research involved in starting a simple project. Lengthy Hello World tutorial, give me a break. :mad:
  10. sanjuandroid20

    sanjuandroid20 New Member

    Did you get this resolved? I just started on Android and facing this issue.
  11. benjos

    benjos New Member

    I'm having the same problem where the "Hello Android" message never shows up. I had the locked screen issue and when I pressed Menu, it only unlocked the phone emulator and the message still did not display. I also tried sliding the unlock button but it had the same effect. I tried clearing user data and then running it again but it only fixed the locked screen issue and the "Hello Android" message never showed up. I tried the tutorial using the programming method and then the XML method for displaying the text but both have the same result where it never shows up.
  12. vagosmar

    vagosmar New Member

    In order to get into application mode (so that you see the app running) simple press F2 (or PageUp) which is the Menu button for the emulator. (for other buttons look in: Android Emulator | Android Developers)

  13. benjos

    benjos New Member

    I already tried clicking the Menu button that but it doesn't fix the problem.

    The only time the program runs is when I had my Android phone plugged into the computer with the USB and ran the program in Eclipse.

    I think there is a bug with the developer programs in 64-bit. I'm using Windows 7 64-bit and Java 64-bit.
  14. darshana

    darshana New Member


    I got the same problem as everybody else; Tried the F2 button when the emulator stops responding.

    I get a pop up message saying that the process has stopped responding and whether I want to wait or force quit. Meanwhile, the background of emulator is no longer the HOME display rather it has changed to show the "hello world" message.

    Problem is that even if i choose "wait" as reply to the popup, the pop up message still remains as is..

    Can someone help me out? I got a final year project based on android apps and with all this, I am being thoroughly tempted to just drop it all
  15. foton

    foton New Member

    Using my Samsung Galaxy Note 2 with Eclipse I was able to get the button and text field running. The last console message was ...

    ActivityManager: Starting: Intent ... etc

    and when the Android screen appeared I pressed F2 and the rest of the elements appeared as they should. I am also running 64 bit. So it seems to work properly. I even saw the settings open on the screen when I opened Settings on my phone.

    I did turn on Developer options in Settings on the phone.

    I was also able to run this in an AVD.

Share This Page