How can I see my Droid as a drive on my PC?


Last Updated:

  1. Vance

    Vance Well-Known Member This Topic's Starter

    Joined:
    Oct 28, 2009
    Messages:
    562
    Likes Received:
    55
    I would like to copy some of pictures onto my PC, and I have the Droid mounted as a drive (checked and it is still set that way, asking if I want to "unmount"), but when I plug it in, it does not show up in my list of drives. What do I need to do?
     

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,416
    Likes Received:
    1,919
    3 things that might be affecting:

    1) Your SD card should be mounted after you connect to the PC - IOW - you don't want it mounted in DROID but on the PC. To achieve this, after connecting, go to notifications and select mount USB.

    2) If you are performing the procedure correctly, make sure you don't have any USB mounting firewalls (yes, they do exist) to prevent mounting of unknown devices.

    3) If neither of the above 2 applies, then I'd try a different cable, just in case (and a different port as well).

    I am betting on #1 b/c you're saying the SD card is mounted before connecting....which means it is mounted in the DROID (Android OS) subsystem.
     
  3. PittCaleb

    PittCaleb Well-Known Member

    Joined:
    Nov 6, 2009
    Messages:
    129
    Likes Received:
    3
    Plug the Droid into your PC with the USB cable.

    Once connected, slide down the notification window. Select USB Connection; Click "mount" - that should do it.

    PittCaleb
     
  4. Vance

    Vance Well-Known Member This Topic's Starter

    Joined:
    Oct 28, 2009
    Messages:
    562
    Likes Received:
    55
    I checked the status regarding mounting after it was connected, and it asked if I wanted to unmount it. But there was no notification regarding mounting to my PC this time. The first time I connected it (when I bought it), it asked if I wanted to mount it, and I said yes, but I don't see it as a drive now (I didn't check the first time to see whether it was showing up as a drive on the PC). The cord is charging it fine, FWIW.

    I just tried unplugging it and plugging it back in and there is no notification at all on the Droid.
     
  5. WJ1023

    WJ1023 Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    52
    Likes Received:
    0
    It's that simple... The notification window is at the top of the screen. Just drag it down and follow PittCaleb's instruction. Then go to My Computer and you should see the drive...
     
  6. Vance

    Vance Well-Known Member This Topic's Starter

    Joined:
    Oct 28, 2009
    Messages:
    562
    Likes Received:
    55
    But there is nothing in the notification window.
     
  7. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,416
    Likes Received:
    1,919
    You need to go to the Notification section - IOW, use the Settings button --> Notifications --> USB Connected - touch that and it will ask you to mount in a pop up dialog box. If you then go back to Notifications, you'll now see it saying Turn off USB storage

    Also, check to see you have not disabled drive letters in your OS (on PCs, in Windows OSs, you were able to 'hide unused drive letters' using a variety of tweaking methods - if this is done, then the device will be mounted but you will not see it).

    You should see it as a Removable Disk in your computer once it is mounted.
     
  8. Vance

    Vance Well-Known Member This Topic's Starter

    Joined:
    Oct 28, 2009
    Messages:
    562
    Likes Received:
    55
    But there is no "Notification" section in the Settings. Does that only exist when there is a Notification to view?

    Edit, hold on, I think I have it now. I tried unplugging the USB cord in the computer and plugging it back in. Let's see . . .
     
  9. Vance

    Vance Well-Known Member This Topic's Starter

    Joined:
    Oct 28, 2009
    Messages:
    562
    Likes Received:
    55
    OK, that did it. The problem was with the USB plug on my computer. Thanks guys!
     
  10. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,416
    Likes Received:
    1,919
    the task bar at the very top of the phone is the Notification section. The fastest way to get it is to hold a finger on it, and a drag bar appears - drag it down, and voila! you Notifications section.

    The other way is to use the button at the bottom of the phone (there are 4 of them) that has all the lines - this is the context menu button - and it brings up the context menu items, one of which is Notifications.

    Added the following

    Apparently you were typing while I was - glad you got it working.
     
  11. Unstable User

    Unstable User New Member

    Joined:
    Feb 21, 2010
    Messages:
    1
    Likes Received:
    0
    Touch Menu-Settings-Applications-Development-USB Debugging-OK.
    Connect USB to PC and Droid.
    In Drop Down Menu From Top Of Droid select USB Connected.
    Select Mount.
    That worked for me, I am Running Windows 7
     

Share This Page

Loading...