How to delete recent email history from yahoo account (NOT GMAIL)Support


Last Updated:

  1. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50
    Hello,

    Does anyone know how to clear historical contacts from the Email application. I'm using yahoo, I dont have Gmail set up on this phone because yahoo is my primary email.

    I've sent emails to 3 wrong emails. For example

    JoeSmith@aol.com, JSmith@aol.com, JoeS@aol.com

    but really his email is JoeSmith@yahoo.com

    Now everytime i go to send this person an email, all 4 emails come up, the 3 in history, and the 1 in his contact information.

    When i type in J in the email recipient, all 4 come up, 3 say "history" next to the line of the email. I tried to add those emails into the contact, and then delete the emails, but that doesnt work.

    I've went to yahoo to see if those contacts are showing up in history and they are not, so i know the historical email history is on the phone only.

    I havent found a way to remove these items in history, but it's starting to cause problems because if i dont pay attention, i'm choosing one of the wrong emails.

    Same thing is happening when i hit reply to ALL, 1 time about 2 months ago, and now i have about 40 emails in history and I dont even know who these people are, they are not in my contacts, and the phone is holding them hostage because i sent an email once.

    Does anyone know of a sure way to remove these historical emails?

    If you dont know what i mean, give it a try, send an email to JOE@yahoo.com, and when you get it kicked back, the next time you try to send an email and hit "J", that JOE@yahoo.com will show up every single time, without fail.

    I've checked all historical settings on the phone, and even removed and re-added the yahoo account, but it does no good, the historical emails still stay in history.

    It's getting very annoying to have 45+ emails that you dont even know show up everytime you try to email someone something.

    Someone must have an answer for this, i can't be the only one that has sent the wrong email to someone.

    Any ideas ? :):D:(:mad::eek::cool:
     

    Advertisement
  2. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50
    wow,really ? no one made a mistake and emailed the wrong person and is seeing the wrong email show up in history? come on. I'm bumping just for the fact to prove I'm not the only idiot.
     
  3. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50
    Yes, i'm bumping again. cmon guys, help a brother out.
     
  4. bisbers

    bisbers Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    108
    Likes Received:
    13
    Don't want the wife to know you've been sending emails to the mistress, huh? (j slash k, guy)

    Anyway,
    Are you using the built-in email account tools or the Yahoo! Mail App?

    The only thing that comes to mind is that if you ARE using the Yahoo! Mail App, you could clear the application cache, which is likely where that is being stored. You would need to go to Menu - Settings - Applications - Manager Applications - Yahoo! Mail - Clear Cache. Of course, other stored data would likely be wiped out too, but at least the undesired entries will be erased.

    If you aren't using yahoo mail app, you might need to try to clear the cache from whatever it is you are using.
     
  5. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50
    thanks for answering, finally someone is giving it some thought, lol.
    And no, it wasnt to the mistress, it was to the wife and i dont want the mistress to find out ! lol. JK.

    I'm using the default mail app, with Yahoo settings. Nothing special or fancy, and no i'm not using the new yahoo mail app.

    Not only is it showing the wrong addresses i put in for a friend, but it's showing about 20 emails when i did a reply to all once, and those people arent in my contact list, so when i go to send an email, i get 20 email addresses come up first (since they are in history) that i dont even need. I've tried clearing out everything, i can't figure out a way to get rid of the email history.
     
  6. bisbers

    bisbers Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    108
    Likes Received:
    13
    Do you have a gmail account setup up at all?
    Even though you are using your yahoo, perhaps the contact info got pushed to the gmail account somehow. I feel like the info is possibly in a synced account, or more likely in cache, which you should be able to purge.

    How much effort are you willing to put into this? I'm sure if you root and connect with the shell, you could find it on the file system somewhere.
     
  7. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50
    Well i'm willing to do some research and maybe do a factory reset, but i'm not willing to root and find the historical data somewhere. I will end up regretting it when I have a bricked phone :)

    Yes, i do have a gmail account setup in the phone, and I use the default MAIL app for both gmail and yahoo accounts. In other words, i never use the "gmail" icon w to see conversations, i normally click on the mail app, click on the yahoo mail area, and choose the gmail account when I want to check gmail.

    When i go to send an email email through gmail, or yahoo, i get those 20-25 historical emails so i don't think it's related to an actual account, but more related to phone's cache.

    Whether I use a new account, or delete both gmail and yahoo and add them back, it always shows those 25 emails in "First" in the list of emails, but it says history next to those emails and that's whats driving me nuts.

    I'm more amazed that more people arent complaining about this, than I am amazed that we don't know how to remove email history.

    I'm surprised no one has emailed the wrong person by mistake, by adding an extra letter or number to the email...because once you do that, it goes in your history forever. So it will show

    JoeeSmith@yahoo.com
    JoeSmith@yahoo.com

    and i guess I'm just surprised no one has had this issue before, or maybe they have, but don't care enough to make a point about it. :eek::rolleyes::);):mad::D
     
  8. nyjets53

    nyjets53 New Member

    Joined:
    Jun 20, 2010
    Messages:
    4
    Likes Received:
    0
    Lets help him and me out...

    I am having the same problem and it is annoying...
     
  9. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50
    Thanks bro. Its very annoying and i'm surprised more people haven't said anything
     
  10. kirbtheman

    kirbtheman New Member

    Joined:
    Jul 12, 2010
    Messages:
    4
    Likes Received:
    0
    Same problem here for my hotmail. I sent a view emails to myself to do some tests when I first got the phone and realised that you can save the email address with/without caps. Had a play with different caps and now have about 6 different history entries for the same email address!

    Very annoying, any one figured this one out yet?
     
  11. manicguitarist

    manicguitarist Active Member

    Joined:
    Aug 10, 2010
    Messages:
    31
    Likes Received:
    1
    I am having the same problem - although mine is via an Exchange account not yahoo or gmail (this is the only email account on the phone).

    I am using an HTC Desire, and I typed an email address incorrectly a while back - and now whenever I enter this person's name the old (historical and wrong) address is prompted - in front of the address that is now in my address book - which leads me to send to the wrong email address time and again.

    There must be a way of clearing this data.

    Anyone?
     
  12. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50
    Hey bro. Im glad more of us are realizing this but still no answers. I'll email htc support and see what they have to say (if anything at all)
     
  13. Tmart

    Tmart Well-Known Member

    Joined:
    Jun 30, 2010
    Messages:
    52
    Likes Received:
    6
    I wasn't having this issue but I read your thread and felt bad and decided to take a couple minutes to figure it out. I'm not positive that this will work since I don't use yahoo email but it works for my godaddy email, my exchange email and my gmail account. It appears that one of the replies above was correct - these contacts are being saved to a place called "auto Gmail contacts" even though you haven't been emailing from your gmail account, it's probably doing this because you have your phone set up to sync with your google account. Anyhow you can delete these contacts and I will tell you how.


    1. go to the "people" app
    2.hit menu button and select "view"
    3.check the radio button next to "show auto gmail contacts" and hit "done"
    4. delete any email addresses you don't want
    5.go on your yahoo account through a PC and delete any messages to/from these contacts from your inbox/sent/outbox and maybe even deleted folders
    5. enjoy the rest of your day satisfied


    As long as there is an email to/from that person in any yahoo mail folder than syncs with your phone it will keep adding that contact back to your list so make sure you get them all.
     
  14. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50
    Tmart, thanks for the help. Unfortunately, the news is bad. No luck with your suggestion. I don't have Gmail sync'd at all with my phone, or email ( I only setup gmail for pictures and to save settings) No mail setup. Just yahoo mail is setup.

    I went to people, i checked off Gmail auto contacts, and also checked off Gmail contacts, which are 0 anyway. And then i made sure the "phone" option was checked which had 225 contacts next to it .

    Now remember, these emails in history are not "contacts", i've never attached those incorrect emails to anyone in my contact list, they are just emails that show up first when i go to send a message when i open my yahoo mail using the default messaging app.

    so JoeSSmith@aol.com is not attached to a contact, so when i went to check off Gmail Auto Contacts, I looked at the top of the contact list and i didnt see any emails up top there (which would have been the incorrect ones), and i also went under J for JoeSmith@aol.com, maybe it put them in alpha order, but it did not. I went into my yahoo, and the historical email is not there, and not in gmail as historical email, or auto-added contacts .

    These are just email addresses lingering around on the phone. They are not setup in yahoo, or not there in historical emails in yahoo....just on the phone.

    When i go to accounts/sync, i dont have gmail/facebook/weather setup to sync at all. No syncing ever, and I also have auto-sync disabled. I tried to sync contacts, I thought maybe it would bring the historical emails over to yahoo or gmail by syncing, but still no good .I truly think they are emails on the phone. If i add another yahoo email on the phone, i still get those same historical emails, regardless of what email account i use, it seems like it's more attached to the email app, than to the account.
     
  15. Tmart

    Tmart Well-Known Member

    Joined:
    Jun 30, 2010
    Messages:
    52
    Likes Received:
    6
    Darn, sorry that didn't work. My phone was also storing any email address that I have ever written to or been written from on any email account to my contacts as well but I was able to find them all in my "auto gmail" contacts and delete them no matter what email address I originally emailed them from. So when you were in your "people" app were you able to find any of these email addresses that keep popping up on you? If they aren't in there whatsoever then they must be coming from an app somehow, maybe an app that handles email or messaging or maybe they are coming from syncing with facebook or some other service. If they aren't in "people" then they aren't coming from your phone's original address database.
     
  16. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50
    When I go to contacts I unchecked phone contacts to only view the auto added gmail contacts I was xlearly able to see the added ones , but they weren't the 30 that are in history . Actually none of them were . I don't have FB set to sync at all, nothing is syncing . The historical contacts are from when I first got the phone and did a reply to all on fantasy football email I got so I think the history is coming from the mail app history somehow. But clearing cache on mail default app did nothing . :(
     
  17. manicguitarist

    manicguitarist Active Member

    Joined:
    Aug 10, 2010
    Messages:
    31
    Likes Received:
    1
    That solution didn't work for me either.

    Went into people, the only address book selected was exchange with 214 entries. Google listed zero. Selecting Google, even with auto entries on, listed no extra entries.

    Another scenario has just arisen, a friend had changed her email address - which I saved to her contact. But still, when I type her name into the "to" box, it lists her previous address as history then lists her address as per contact card.

    Under history it details *all* addresses that I've ever emailed via my Android.

    I've removed all email accounts and readded, but to no avail. They are cached somewhere on the phone. The history items are not synced outside of the phone - I control our exchange server and spent some time checking this out - even creating myself a new dummy account, but the old addresses are still there in the history.

    Suggestions please. As folks change their email addresses this will become an ever larger problem.
     
  18. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50
    I agree completely, when people DO change their email address, you still get their historical email on the phone. for example, my mother changed her email address 2 times, plus i typed it wrong 2 times, so when i go to email her, i have 4 EMAIL addresses to choose from. the 3 historical and the 1 active. That makes me really have to pay attention to what i'm choosing otherwise i'll get the address kicked back to me. i don't know if this is a glitch or an issue that was not found during testing, but this is getting very annoying. I have about 80 emails in history now ,and if I go to email someone that starts with a G, i get about 15 results with people who i barely know from when i did a "reply to all" once friggin time. I even tried adding those address to contacts then deleting the contact, but that wont work either bc it's in history. I think the only way is to do a factory reset, and reset all settings which will probably erase email history cache.
     
  19. fusaro

    fusaro New Member

    Joined:
    Dec 2, 2010
    Messages:
    1
    Likes Received:
    0
    Its in your contacts section,

    Go to contacts
    Display options
    Make sure that Only contact with phones is not checked if so uncheck
    Then make sure u select all of the contacts to display ie google, facebook, or any email u use.

    Once u have done that the emails should show up in the contact list and you can delete them there
     
  20. JuniorNA

    JuniorNA Well-Known Member This Topic's Starter

    Joined:
    May 3, 2010
    Messages:
    288
    Likes Received:
    50

    Thanks for the help. Unfortunately this has been tried before. It still does not have anything to do with the yahoo mail recent contacts. It might work for google, but not for yahoo or any other mail account. We haev reason to believe the recent history is stored in the mail app, and not the actual google application, but in the HTC application.
     
  21. manicguitarist

    manicguitarist Active Member

    Joined:
    Aug 10, 2010
    Messages:
    31
    Likes Received:
    1

    ^^^ what he said.
     
  22. black05x5

    black05x5 Member

    Joined:
    Feb 5, 2011
    Messages:
    6
    Likes Received:
    0
    Anyone figure out how to erase the email address history yet? I use the stock mail app for non gmail acct.
     
  23. technoklutz

    technoklutz New Member

    Joined:
    Feb 12, 2011
    Messages:
    1
    Likes Received:
    0
    Hi, I'm new to the group and have lived through 1.5 confusing days with my new Droid Incredible. I have called tech support (at both my phone company and cell phone company) so many times today, I've honestly lost count. I am going to call them again about this problem with a typo in the e-mail address getting stuck in the phone history, but I'm exhausted and I think they're closed in the middle of the night. I stumbled into this website and was so excited when I saw JuniorNA's post. The more I read, the more I knew I was having the exact same problem. I tried every suggestion with the same no luck. I was so glad when others started coming forth with the same experience. black05/5's post last week was the 1st in several months, so did someone come up with a solution? I discovered the problem when I somehow sent dozens of emails from my computer's in-box to my new phone. I was trying to send some of them back, by forwarding them to "me." After a few were rejected, I realized I had typed my email with ".nte" instead of ".net" So now when I start typing "m" for the email address, it brings up two "me's" from history. I didn't want to delay joining in, so I didn't take time to set up all my information. This is very new to me, so please bear with me. (couldn't find an icon that represents how I feel right now!) Thank you for all your past posts, even if you have nothing new to add.
     
  24. black05x5

    black05x5 Member

    Joined:
    Feb 5, 2011
    Messages:
    6
    Likes Received:
    0
    I went into settings/applications/manage applications. I went into the mail app and hit clear data. It deleted the acct but when I reinstalled the acct the old email history was gone. Not ideal but it works.
     
  25. seesaw

    seesaw Member

    Joined:
    Nov 24, 2010
    Messages:
    22
    Likes Received:
    3
    I have just replied to another thread on the same topic (different phone, but so is mine) - it appears this is a common problem. There should be an easier way of deleting the history of recipients (OR, don't store non-contacts in the history in the first place).

    Very annoying!
     

Share This Page

Loading...