[How To] Update, Unbrick/Go back to stock on LT7033


  1. mavrikmeercat

    mavrikmeercat Well-Known Member

    I created this thread because I think every device forum needs a thread based on bootloader because it is nessessary for develpoment to grow. Developers need a failsafe way to flash back the stock firmware to their device incase testing something they did goes wrong. And, since the bootloader is also how Curtis international chooses to output updates to firmaware for all their Android devices, this will be the place for that as well for all updates on the LT7033 Tablet. This thread will be geared towards "going back" to stock incase you did something wrong or you partially bricked your device.


    See second Post for listing of all firmwares for this device and how to make your own backup.imgs

    What is a Bootloader?
    A bootloader is a program that runs on your computer while your android device is connected to it through the USB cable. The android device is booted into a certain mode often refered to as "download mode" or "flash mode" and the bootloader program can then flash a complete firmware image to your device. It is also specific to manufacturers/devices. This does NOT require ROOT in order to perform..

    Our bootloader is called RKbatchtool because it is designed to work with the certain type of CPU or processor that is in our tablets called RockChip.

    So How Does it Work?

    First thing you need in order for you computer to be able to communicate with your tablet when it's connected is the windows drivers.

    Any android device actually has several different drivers that need to be installed for a few different modules inside it:

    connected as MTP Storage = MTP driver
    connected as USB Mass Storage = Mass storage driver
    ADB command line for SDK = ADB Composit driver
    Download Mode = Android Bootloader driver

    [Step One] Gettin What You Need
    You need a few things in order to do this:

    1. The latest firmware for your model:
    I will confirm that this is an update to android 4.1.1 JellyBean and works much nicer than ICS

    LT7033 Tablet

    LT7033D Tablet

    LT7033E is posted as discontinued

    Here is the page where you can get official firmware and manuals

    2. Windows Drivers
    the firmware does come with a drivers folder but i've never had much luck with them. Here are the drivers that have been confirmed by many people as working..
    ADB_RK29_Drivers.zip

    [Step Two] Getting Set Up

    First you want to extract the firmware.zip you downloaded for your device. Now open it and inside you will see Firmware.img, power point instructions, and another .zip named RK2918_update_Eng.zip. extract that to inside this folder as well. now open the extracted and this is where you will find the RKBatchtool.exe.
    Disreguard the instructions about how to get you tablet into download mode because they are completely wrong.
    Also disreguard the drivers inside that folder because i fought with them quite a bit before giving up and using the drivers I posted above. So just let me save you some time.

    Next you want to install the bootloader drivers so extract the drivers.zip you got from above and now you need to put your tablet into download mode now.

    From powered off:
    While holding Volume+ or up
    Plug-in your USB cable to the computer
    (only use the port on the back of your computer. the one attatched to the motherboard. Mine would not flash AT ALL when using the front usb ports even though it connected and seemed to work fine RKbatchtool would not flash it. it would fail.)
    You will here windows make the connected sound and will try to install the drivers but will fail.
    Open the device manager and look for unknown device.
    Right Click it an select update driver
    select Browse my computer for drivers
    then Click Have Disk
    in the pop-up click browse
    go to the drivers folder you just extracted and look for winusb.inf and click Open
    ignore any warning about the drivers being signed and install anyway
    you should see three drivers to choose from:
    ADB driver
    Bootloader driver
    ADB Composite

    The bootloader one is the one you want so select it and click next and install

    When it's done installing the driver, you're ready to go.

    [Step Three] Flashing your firmware, Update, or recovery.img that you made

    Now that your tablet is in download mode and ready to go, go back to the firmware folder from before and drill down to RKBatchtool.exe and right click it. select "Run as Administrator" and hit yes.

    In the bottom, Left corner, you should see a square box lit in green. this means it sees your tablet and is ready.
    On the top right, you need to select the path to your firmware.img inside the folder you Got from above or from Curtis Int. and it will load the firmware up and say finished in the text box.

    Once you achived this, hit the UPDATE button at the bottom and let the magic happen. it will take about 5 min and will reboot your device. then your device will take another 3 - 5 min to boot fully as it's like booting for the first time after you took it out of the box.

    Enjoy all the updated goodness and I hope this helped you. If it has please hit the thanks button...

    Advertisement
    :
  2. mavrikmeercat

    mavrikmeercat Well-Known Member

    Go get the stock firmware from Curtis website. Extract it, open it and extract the zip inside.

    The instructions for getting it into download mode are wrong. You have to do like this
    From powered off...
    Hold volume up or +
    Plugin the USB cable while holding vol up.
    It will boot into download mode but screen will stay black.
    Windows will make the connected sound
    The drivers given will not work(they didn't for me) go get the ones supernoober suggest.
    Make sure you install the driver for "android bootloader" ( different from the other drivers but use the same winusb.INI you used for your adb driver)
    Once that is installed, you should be able to use the rkbatch tool to flash the stock firmware back to your tab bro..

    If you can't. Then you need to call Curtis and claim warranty. Its warranted for a year with manufacturer. DO NOT SAY ANYTHING ABOUT ROOTING!! Good luck man...
    casperischinky likes this.
  3. SuperNoober

    SuperNoober Well-Known Member

    Mavrikmeercat:
    Wow, that procedure is almost too easy, thanks bunches! Now all we need is a recipe for jelly bean dip and we can have a party!


    Casperischinky:
    Sorry to hear of your misfortune, all Curtis tablet manuals and firmware downloads are here...
    Manuals -- CURTIS INTERNATIONAL
    The ADB driver is here...
    ADB Driver RK29.zip
    casperischinky and cabiggs152 like this.
  4. casperischinky

    casperischinky Well-Known Member

    I for the life of me can I get these drivers to install either I am NOT doing someIthing correct have a 60 dollar paperweight or I'm not placing them in the right folder. could 1 of you possibly guide me through the steps to install these drivers correctly? if I can't figure this out I guess I'm screwed and I have of 60 dollar paperweight.
  5. SuperNoober

    SuperNoober Well-Known Member

    Casperischinky:


    Vulcanize gives an excellent description of the process for a Proscan (still Curtis) PLT7035 in post 3 here...
    http://forum.xda-developers.com/showthread.php?t=2112562


    The only thing about his description I found confusing is where he says to load the appropriate drivers. Trying to answer my own question, I found that when you unzip the firmware update for the LT7033...
    LT7033 Firmware
    You will find another zipped file in the 1st unzipped folder. This is labeled...
    RK2918_update_1.5_Eng.zip
    When you unzip this file & open the resulting folder you will find a folder labeled RockusbDriver.
    I believe this is the correct drivers to point to at this stage, not the ADB driver listed above. The one above is the one to use when it's time to root it.


    You are swimming in uncharted waters for me so I can only hope this helps. Let us all know about your results, because if this is successful, I need to correct some other bogus advice I gave elsewhere. LOL

    What, whose, version of CM10 did you try to load? So the rest of us can avoid it like the plague.
    casperischinky likes this.
  6. mavrikmeercat

    mavrikmeercat Well-Known Member

    No the drivers you posted adb drivers are the right ones..

    The drivers that came from Curtis didnt work at all for me

    How to
    Put your tablet in download mode like I described above
    Open device manager
    Right click unknown device
    Click update driver
    Click browse for drivers on my computer
    Click let me pick from a list of devices
    Make sure "all devices" is highlighted in the menu and click "have disk"
    In the pop-up, click browse
    Go to the adbdrivers folder SuperNoober posted and find winusb.ini and double click it
    Select OK in the pop-up
    Ignore the warning and hit OK
    It will have a list of three drivers adb, bootloader, and adb composite
    Select the bootloader one
    Ignore the warnings about drivers not being signed and hit OK
    It should say successfully installed at some point
    Now you can run the rkbatchtool.exe and load the stock firmware
    SuperNoober and casperischinky like this.
  7. casperischinky

    casperischinky Well-Known Member

    TY Mav & Supernoober between the both of u & all the stuff u posted I got my tab back to life!Its updated to jellybean now and I must say its way more responsive to my touch now and way less lag as ics.My. only issue now is that I'm trying to root this damn thing again,when I rooted it the 1st time I had vista & had no issues rooting.Now I got win 7 and when trying to root this lil tab again it says I must "enable usb debugging",when I do this my laptop don't recognize the tab anymore lol ahhh faq!How do I root this thing to get my cwm back on here if my laptop won't recognize the tab?I'm sorry if I'm being a pain in the Arse,I'm just stuck @ this point.
  8. mavrikmeercat

    mavrikmeercat Well-Known Member

    You gotta install the drivers for all the different modules on the device

    Mass storage = Linux gadget USB device
    Mtp media device= Linux gadget USB device
    Adb driver = android adb driver <-- the one you really need for rooting. It appears as lt7033 in device manager before the driver is installed
    Download mode= android bootloader driver
    And so on. You have to install all those drivers manually. The exact same way you did the bootloader one. Point to the same file too, winusb.ini.
  9. mavrikmeercat

    mavrikmeercat Well-Known Member

    Reserved for future use
  10. casperischinky

    casperischinky Well-Known Member

    Long story short here is be careful what u do to your tabs/phones period!LOL MAV u my friend are the man haha,I thank u again for the help,I finally got the drivers installed & working,tab rooted,cwm back on it(I was determined imma taurus haha),& about to install my market from when this lil tab got started and I'm back in biz!
    mavrikmeercat likes this.
  11. casperischinky

    casperischinky Well-Known Member

    Since I got cwm installed I figured I would google some roms if any @ all for RK29,I came across a post on xda for cm10,it flashed fine til I reboot now it will not go past the klu screen and then the screen goes black & no way to boot into recovery.MAV u got any ideas how I can bring this thing back to life.Itried to hook it up to RKbatchtool but it won't seem to connect maaaaan I fugged up,if anyone has any clue how to help me please don't be shy and speak up lol.
  12. mavrikmeercat

    mavrikmeercat Well-Known Member

    Reserved for future use
  13. mavrikmeercat

    mavrikmeercat Well-Known Member

    Casper could you comfirm your results by posting the steps you did for flashing the firmwareback to your tablet? It would surely help someone in the same situation as you later on and also give them a second reference to the op.
  14. vulcanize

    vulcanize Member

    That was with regards to the PC - meaning whether 32 bit or the 64 bit version :)

    @OP - Nice work mate.
    Will keep checking thread for any new suitable roms you may have come across for the RK2906
    mavrikmeercat likes this.
  15. vulcanize

    vulcanize Member

    I also want to add a small bit from my end.
    ALWAYS take a back up (can't emphasize that enough) using ClockWorkMod aka CWM if things go wrong while experimenting.

    Rule number one:
    DO NOT PANIC!!!!
    Turn off the tablet PC and unplug the USB connection to PC.
    Try to get back in to recovery by pressing the Volume UP (+) button and power button at same time.
    Holding down the volume UP button and simultaneously plugging in the USB cable achieves same result too because the tablet powers itself in this method and goes in to recovery - remember to hold down the volume button down all the while.

    Also helps to Backup your device to Cloud in one click using Orange Backup.

    To know more about Orange Backup - readup at following link:

    http://www.addictivetips.com/androi...ocal-cloud-nandroid-backups-without-recovery/

    If you are curious and want to learn more - another way of doing it is very nicely explained in the link below.

    How To Backup Your Android Phone&#8217;s Boot, Recovery And System Partition Images

    Romdump is a very simple program that dumps the BOOT, RECOVERY and SYSTEM partitions to your SDCARD, this will allow a technically minded individual to create a recovery image.
    Source: Index of /romdump

    Have fun :)
    casperischinky and mavrikmeercat like this.
  16. mavrikmeercat

    mavrikmeercat Well-Known Member

    vulcanize likes this.
  17. vulcanize

    vulcanize Member

    Thanks. I actually edited out that line of pressing down the Volume UP (+) achieved it for me on the Proscan PLT7035-B before hitting submit post since I did not want to confuse others with different makes/models.
  18. casperischinky

    casperischinky Well-Known Member

    Mav awesome guide my friend,I followed everything you & supernoober threw @ me (pain in the ass part was drivers lol) & got my tab updated to JB and I actually enjoy playing on it now since its more responsive to my touch.I am looking forward to some new goodies to throw on it lol, I'm totally willing to test anything ya got lol JS haha.
  19. SuperNoober

    SuperNoober Well-Known Member

    If anybody knows where the mythical android bootloader driver for the LT7033 is, would you please post a copy of it, by itself to end all this confusion? I can't find it anywhere. Trying to do the software update with the ADB drivers only results in an improper driver error message, and trying the Curtis provided RockusbDrivers has left my unit without any touchscreen response. I can see the unit has the new operating system loaded, but I can't interact with it in any way.:confused:

    If Rockchip can't provide drivers for it's devices then they need to be boycotted on a worldwide basis.:mad:
  20. mavrikmeercat

    mavrikmeercat Well-Known Member

    Dude, its the same exact file. There is no individual bootloader driver by itself. IT IS THE SAME winusb.ini in the adbdrivers.zip.

    Uninstall whatever it says in the device manager first untill it says UNKNOWN DEVICE then point to the SAME winusb.ini as all the rest of the drivers came from. Thats it ..

    Are you doing this from a laptop or a desktop? Make sure you plug in you usb cable to the back usb port. The one attatched to the motherboard. Not one on the front of the case which is connected by a cable to the motherboard inside the case
  21. mavrikmeercat

    mavrikmeercat Well-Known Member

    Yeah im liking the update way better too. It's so much more quick and way less lag. Also, I had converted all my daughter's disney shows and put em on her sdcard and I in ics I had to find another video player because it would just freeze or glitch out. Got to be quite anoying in the car.. now it works perfectly. No problems..

    Just to let everyone know, angrybirds works just fine on the update too!!!!!!
  22. vulcanize

    vulcanize Member

    Not to take this thread off tangent - but here is a bit of experimenting fun with a caveat but interesting nevertheless:

    [GUIDE]How To Port Different ROMS to Your Device (Simplest and Fastest)

    So may be you all can get together and try making a custom rom for your LT7033 (just like Oma7144 from XDA has done) .
    He was very kind enough to provide me with the needed kernel for my Proscan PLT7035-B and I am loving it. Next stop is CM10.
    ;)

    By the way, first of all, please do check if your CWM backup is working fine because I found out the hard way that it was not. :D

    Some tools from Play store that I have been using for a long time and always come in handy:

    Quick Boot , All-In-One Toolbox(17 Tools) , Dr.Web Antivirus and of course Titanium Backup.

    Cheers :)

    --------------------------------

    Edit:
    I needed to edit my post because the essence of what I wanted to convey got lost somewhere in it I guess. mavrikmeercat pointed out correctly to probable misleading aspect which was truly not intentional from my end. My apologies in case anyone felt it that way..
    Please take very seriously his advice of not flashing the wrong rom because my post was NOT about flashing wrong roms to the Curtis tablets but rather about finding compatible mtd ones and tweaking it to make a custom rom for it as a collective effort since not many devs are doing it on these devices currently.
    The lift off what I tried to do was from Slim Bean 3.1 for mtd's since I have it on one of my Nexus 7 and wife's Samsung Exhibit 4g phone - really cool.
    :)
  23. mavrikmeercat

    mavrikmeercat Well-Known Member

    Some crucial advice so everyone please take it.

    Never, and I mean never , try to flash a rom for another device.
    @ vilcanize, the nexus 7 is and has a completely different format (emmc) ours being (mtd)
    and also has a completely different kernel, boot, recovery, and system than any version of the curtis tablets. Flashing something from the nexus 7 would certainly result in a dead tablet. You should be thankful that the dev of that rom was smart enough to add a check in the updater-script(the script that tells cwm how to install the rom) to check the name and the device model #. In your case, that check failed and the install was aborted. That's what status 0 means. Otherwise you would have a paperweight.

    A rom, kernel, boot.img, recovery, system, and even userdata is device specific and must be designed on and for that device only. No exceptions on that.

    Rom Manager is made from the developers of Clockworkmod and is designed to only be used with supported devices and devices that have official AOSP or AOKP ports. These chineeze tablets probably will never see oficial support from cwm or rom manager unless one of those devs over in xda makes it so but don't hold your breath. Rom Manager is designed for the big named devices like the SGS2 and the SG TAB, the google nexus 7 and other popular devices like such.

    ROM MANAGER CAN BRICK YOUR CURTIS DEVICE!!!!!

    Can't stress that enough........
    vulcanize likes this.
  24. ydss

    ydss Member

    I have met the same problem as SuperNoober,how to solve it?
    I think If we have used a wrong firmware???
    I have tried many times,but the touchscreen didn't work yet....
    when install the bootloader drives,I used the drivers in firmware zip,not the "ADB_Driver_RK29",because the ADB_Driver_RK29 cannot work.
  25. ydss

    ydss Member

    should I try firmwares by other mids with rk2906?
    I have no ideal,I am downloading the firmwares now
    ps:I have tried the 7033d's firmware ,but it was a wrong information in the RKBatchTool.
Loading...

Share This Page