HTC Hero and Pioneer Car Units


Last Updated:

  1. s3alvl3

    s3alvl3 Member This Topic's Starter

    Joined:
    Jan 13, 2010
    Messages:
    6
    Likes Received:
    0
    I just got a Pioneer AVH-P4100DVD unit to replace my DEH-P700BT unit. The P700BT had no issues playing music off my Hero through the USB cable attached to the receiver (just have to mount USB). The P4100DVD however when connected just says "format read" and will stay there. Just trying to figure out if there is a work around to get the USB cable to work with the P4100DVD?? I miss being able to control the music on my phone from the receiver. That is why I am not using the AUX jack. I have also tried turning the USB debugging on and off on my Hero. I know the USB works. I plugged in a thumb drive and it read the music fine.

    Any help would be greatly appreciated. Thanks!!
     

    Advertisement
  2. astrobill

    astrobill Well-Known Member

    Joined:
    Dec 15, 2009
    Messages:
    219
    Likes Received:
    24
    Try asking the guys over at AVIC411.com I know you don't have a Pioneer AVIC nav unit, but the folks at that forum seem to know quite a bit about Pioneer head units...?
     
  3. AmericanHero

    AmericanHero Well-Known Member

    Joined:
    Nov 3, 2009
    Messages:
    181
    Likes Received:
    18
    How big is your memory card? Some decks have problems with usb devices over 2 gigs in size.
     
  4. Shouse

    Shouse Well-Known Member

    Joined:
    Oct 28, 2009
    Messages:
    81
    Likes Received:
    1
    I have a new Kenwood excelon deck and am forced to use the Aux output.
     
  5. s3alvl3

    s3alvl3 Member This Topic's Starter

    Joined:
    Jan 13, 2010
    Messages:
    6
    Likes Received:
    0
    I am using a 8GB micro sd. I will try a smaller card and see what it does. I will also check out AVIC411.com.. I will let you know what happends. Thanks guys.
     
  6. s3alvl3

    s3alvl3 Member This Topic's Starter

    Joined:
    Jan 13, 2010
    Messages:
    6
    Likes Received:
    0
    ok.. so I tried using a 2gb micro sd on the phone and no luck. Same thing just says "format read". I know the micro sd cards work because I plugged them into the receiver with a USB adapter for micro sd cards and it play the music that way. So the issue is with the receiver just reading the phone.
     
  7. s3alvl3

    s3alvl3 Member This Topic's Starter

    Joined:
    Jan 13, 2010
    Messages:
    6
    Likes Received:
    0
    Today I tried getting it to work with other phones. I tried the Samsung Moment and the Palm Pre. Still no luck so it must be something with the unit..
     
  8. twospirits

    twospirits AF's janitor Moderator

    Joined:
    Oct 4, 2009
    Messages:
    6,182
    Likes Received:
    5,028
    Please do. That unit is one that I have been meaning to get for my car and this issue if solvable would be good to know.

    TS out
     
  9. s3alvl3

    s3alvl3 Member This Topic's Starter

    Joined:
    Jan 13, 2010
    Messages:
    6
    Likes Received:
    0
    I contacted Pioneer about this issue and there is nothing they can do. I also went on other forums like AVIC411 and didnt hear anything. I am 50/50 about this unit. I am thinking about returning it but I like the extra features I get now compared to my old unit... I guess we will see.
     
  10. Shouse

    Shouse Well-Known Member

    Joined:
    Oct 28, 2009
    Messages:
    81
    Likes Received:
    1
    Like I said above, some decks just weren't designed to be compatible with our phones. Of course it's compatible with the holy icrap though....:mad:
    I use a 16gb usb drive regularly on my Kenwood deck and it works just fine. Attach the Hero and it won't recognize a playing device.

    I had to buy a 3.5mm male to 3.5mm male cord and run it from the back of my deck to my hero. I ran it the same way I ran my USB cord so everything sits in my spare din slot.
     
  11. cooolone2

    cooolone2 Well-Known Member

    Joined:
    Nov 5, 2009
    Messages:
    737
    Likes Received:
    65
    I have to check but I think I have the same unit i recently installed to my car. The USB works fine, but not straight from the plug-in.

    1st you have to enable the usb cable in the head unit, but the unit will recognize the USB hook-up when connected. Then after connecting the phone don't forget to mount the card thru the phone.

    Then you will have full access to the music.

    Hope that helps...
    :cool:

    Update: No, I have the DEH-410UB... and not a glitch at all. Sorry but try the same, make sure you mount the USB once connected via the phone.
     

Share This Page

Loading...