Incredible, APN, Quick Settings Bug, and Mobile Data Switch IssueSupport


  1. INTREPID-NY

    INTREPID-NY Well-Known Member

    If you have an original unedited APN for the Incredible, please post it.

    BUG WITH QUICK SETTINGS APP AND DROID INCREDIBLE

    I believe the app Quick Settings added the [disabled] to the APN file when I attempted to use the Mobile Data Switch. See below. Now Quick Settings Says "No APN Configured". I've emailed the dev. If so, I will remove the [disabled] to restore the file to its original state. Everything seemed to be working fine despite the [disabled] setting though, but I didn't test MMS.

    Current (modified by Quick Settings?) APN File from my Verizon HTC Droid Incredible:

    -----------------------

    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns>
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="1[disabled]" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.vtext.com/servlets/mms" type="mms[disabled]" />
    </apns>

    ------------------------

    If anyone has the original unedited APN from the Verizon Droid Incredible, PLEASE DO POST IT !!!!

    Note: I used APN Backup & Restore to save the file to the SDCard so I could view and edit the file using a text editor (such as notepad) in windows. You can get APN Backup & Restore on the market for free.

    Advertisement
    :
    alando and UHF3 like this.
  2. hodgie

    hodgie New Member

    I have the same issue - used quick settings to turn off mobile data last night - and MMS does not appear to be working now.

    This is on the app's page on appbrain - I didn't notice it before:
    "HTC Incredible users, please don't use Mobile Data switch for now. Sorry for inconvenience"
  3. INTREPID-NY

    INTREPID-NY Well-Known Member

    Instructions to repair MMS damage caused by Quick Settings. I don't know why the Dev has not stepped forward with this information. The new Quick Settings version no longer causes this damage. But you still should not / can not use Mobile Data Switch in Quick Settings on the Incredible. Everything else in Quick Settings works fine on the Incredible.

    Instructions:

    Before you Begin: You must have a MicroSD card installed. You MUST have Windows configured to show extensions of known file types! Do not proceed until you're sure you can see extensions of files. See here for simple instructions on how to show extensions in Windows: http://www.tacktech.com/display.cfm?ttid=193

    1) Install APN Backup and Restore from the Market (free)
    2) Run the App and select Backup. Name the file: apns-broken.xml
    3) Plug Incredible into USB (or remove card) and copy the file on your phone's sdcard from folder called APNBackupRestore to your pc.
    4) Open the file on your pc in a text editor such as notepad.
    5) Remove the 2 occurrences of [disabled] - see below for example.
    6) Save the edited file as: apns-fixed.xml
    7) Verify your can see the file extension of the file as .xml
    8) Copy the file back to your sdcard into the same folder called APNBackupRestore.
    9) Run APN Backup again and click Restore. Select the file to restore: apns-fixed.xml - When prompted to search for all instances, answer: NO
    10) Unplug your phone from USB and reboot your phone.

    NOTE: In some instances, you will not see [disabled]. You may see a dash before the 1
    (e.g., -1). You should remove the dash. Or, instead of editing the file, you may wish to just delete the contents of the file and copy and paste the text below marked "APN After Editing" so you're sure you have the text of file exactly correct. [Thanks to Zenman for this tip]



    To Verify the repair, check your MMS. Also, you can open Quick Settings and check that Mobile Data shows as "enabled" and not ""No APN Configured". DO NOT click on the Mobile Data switch or you'll break it again! Now hide the Mobile Data Switch in Quick Settings by using Customize so you don't hit it by accident. You can also verify the repair by backing up / saving the apn again to another file name, like apns-verify.xml and checking it in a text editor. It should look like the apn at the bottom of this post: APN After Editing.

    APN Before Editing
    bolded entries will be removed
    ==============

    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns>
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="1[disabled]" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.vtext.com/servlets/mms" type="mms[disabled]" />
    </apns>

    APN After Editing
    ==============

    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns>
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="1" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.vtext.com/servlets/mms" type="mms" />
    </apns>

    =============
    Note: If the word "null" is missing after your restore and check the apn again, that is ok. For example: password="null" and Password="" are both acceptable. Sometimes Android will remove the word "null" when restoring.

    See related thread:
    http://androidforums.com/support-tr...ure-texts-mms-culprit-quick-settings-app.html

    ALSO SEE POST #19 and #20 below for a possible easier solution.
  4. BlueScrote

    BlueScrote New Member

    Thanks for the directions. Had this issue also, and was very confused since regular data did work.

    As an addendum, This can be done on any computer, you just need to open the xml file in a text editor (Notepad, TextEdit, Gedit for windows/osx/linux respectively)
  5. INTREPID-NY

    INTREPID-NY Well-Known Member

    duplicate post removed
  6. hodgie

    hodgie New Member

    Thanks very much for the instructions! That was pretty simple to do but I would not have had a clue how to fix it without your instructions.
  7. INTREPID-NY

    INTREPID-NY Well-Known Member

    If you are unable to SEND an SMS Text Message and they get stuck in Unsent Messages, here is the solution:

    Remove Call Back # Dashes: Messages, Menu, Settings, Call Back Number. Your Call back number can NOT contain dashes (or brackets). If you put in, for example 212-555-1212 it will break outgoing SMS Text Messaging. Remove the dashes to fix! The call back number must contain digits only: e.g.: 2125551212

    SMS Only Settings Reset: If that doesn't work, you can also just reset the SMS Settings: Open Messages app, click on Menu, select Settings, click on Menu again, and finally select "Restore Default Settings" This will restore the default SMS / MMS settings only.
  8. dmb_droid41

    dmb_droid41 Active Member

    Thank you so much for this! I wasnt getting an answer from the dev.
  9. 06jeepguy

    06jeepguy Member

    kinda new to this driod stuff the problem I have is that it says generic failure but does send it incoming i must manually download and doing the above fix there are no disables to delete my apn looks like the fixed version but QS still says APN not configured so except for the stupid message everything works any ideas on whats causing the message thanks
  10. aarondalin

    aarondalin New Member

    I have the same issue of quick settings with the mobile data disabled issue. However, I followed the instructions in this thread, and it does not say "disabled" when I copied the text into notepad. Does that mean everything is actually working fine?

    I am not very technical so any help would be appreciated.
  11. vide infra

    vide infra Well-Known Member

    i checked my APN settings and everything is fine, also, last night for about an hour or so i was able to send MMS messages (just not pictures taken with the incredibles camera) but this afternoon it wont send anything. I'm not getting a generic network failure message it acts like it goes through all fine and dandy but the other phone never receives the message
  12. zenman

    zenman Well-Known Member

    Me too. This fix didn't work for me. I really don't want to do a hard reset. Damn this app, I never even used it.
  13. zenman

    zenman Well-Known Member

    Ok, I was able to make this work. If this fix isn't working for you, try substituting the following Step 5 for the Step 5 above:
    New Step 5: Erase everything you see in the file and then cut & paste the "APN After Editing" sequence. (Click on File and then Save, not sure if this makes a difference but I did it.)
    alando likes this.
  14. mikeman84

    mikeman84 Active Member

    I use Quick Settings and the Mobile Network Switch from HTC (is this the "Mobile Data Switch" you are referencing?"). I have been able to send / receive MMS as well as post to Facebook.

    Just wondering what exactly the issue was with the people having it as I would like to know if it was affecting me. I love the Quick Settings application, its probably the most convenient / used of all the ones I have.
  15. bknab

    bknab New Member

    Yeah that's what I ended up doing too... After further inspection though I did find the problem. Instead of having Disabled tag there was a negative sign in front of two values as seen in bold below.

    ==================================================

    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns>
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="-1" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.vtext.com/servlets/mms" type="-mms" />
    </apns>

    ==================================================

    With the negatives removed from those two values it will work. It's probably more simple to just copy/paste as you said, but for those stubbornly curious people like me, this is what was creating the problem.
  16. and70

    and70 New Member

    I did almost what INTREPID-NY explains and I am working now.

    My apns-broken.xml file was like this:

    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns count="1">
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="1apndroid" user="null" server="null" password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0" mmsc="http://mms.vtext.com/servlets/mms" type="mmsapndroid" />
    </apns>

    And here the apns-fixed.xml like INTREPID-NY:

    <?xml version='1.0' encoding='UTF-8' standalone='yes' ?>
    <apns count="1">
    <apn name="Production" numeric="00000" mcc="000" mnc="00" apn="1" user="null" server="null"

    password="null" proxy="null" port="null" mmsproxy="null" mmsport="null" mmsprotocol="2.0"

    mmsc="http://mms.vtext.com/servlets/mms" type="mms" />
    </apns>
    nimbuscrenel likes this.
  17. and70

    and70 New Member

    Thank you.
  18. Amon Darthir

    Amon Darthir Active Member

    I have been having the same trouble with my Droid Eris. I finally decided to do a factory reset and now it works. Hopefully I can reload all my apps without the problem happening again.
  19. nighlwing

    nighlwing New Member

    same thing happened on my droid incredible here is what i did.

    1. put my curve fish apn widget back on my phone and pushed it

    2. looked for the button that says reset to original settings and pushed it

    3. went back to screen with widget on it removed widget from phone didn't uninstall it just removed it so as not to push it by mistake.

    4. phone fixed

    Hope this helps
  20. INTREPID-NY

    INTREPID-NY Well-Known Member

    CurveFish APN OnOff mentioned above by nighlwing : http://www.appbrain.com/app/com.curvefish.widgets.apnonoff

    I have not tested this but if it works it's easier than editing files for sure.
    I also think the new version of Quick Settings will fix it too (again, I have not tested).

    However, I would at least look at your APN first to see if anything is amiss as described above in post #3 before running this app that may break something that doesn't need "fixing".
  21. stemcel

    stemcel New Member

    I tried the solution outlined above with APN Backup/Restore, both editing the file and a wholesale replacement. Neither worked. But then I tried:

    1. Install CurveFish APN On/Off widget.
    2. Load widget
    3. Press the menu button
    4. Choose 'Restore Defaults'

    Success! From now on I'll just use the power button hold to turn off mobile data o_O. QuickSettings is great, but not for this :)
  22. axle123

    axle123 New Member

    Thank you very much. I had this problem on my EVO and your instructions helped me fix it.
  23. andrewpm

    andrewpm Member

    Having same issue on my wife's EVO but not on mine.
    Did you use the pc/edit xml or copy/paste or Curvefish widget method?

    My wife's EVO has been acting up since day 1 with several different issues... go figure bc she didn't want to switch from her BlackBerry so all issues are my fault, naturally...
  24. baudac

    baudac New Member

    I also have an EVO and tried the curvefish with no success. I haven't change my APN via an xml edit yet because I didn't see any reoccurance of the word "disable" or a negative integer "-" in the xml string. Plus the above method is for verizon and not sprint. But clearly all of the google search points to this thread.
    Initially I thought it was a 3rd party messaging app, but that got thrown out after I uninstalled it.

    So what's next?? Nationwide failure?
  25. andrewpm

    andrewpm Member

    Man, I just don't get it...

    I sent two pic msgs to my wife's EVO from my EVO (pic w/ text and pic w/out text) about 10-15 seconds apart. Lo and behold, the usual "Generic Network Failure" "Message Not Downloaded" error in task bar, but the time stamp on the error messages were 2:23pm and 9:00am. WTF? 9:00am? What's even more screwed up is that she receives the pics msgs w/ AND w/out text just fine. I used ChompSMS w/ text and stock Messaging w/out text, so yeah, it's not a thrid party app problem. It has to be a hardware issue. Again, my EVO works fine... Totally screwed up!?!?!

    Don't want to hard reset bc I have to pay for ChompSMS again (4th time and still waiting for refund from 2nd and 3rd time)
Loading...

Share This Page