1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[International / GSM] [HOW TO] Root the GSM/HSPA+ Samsung Galaxy Nexus

Last Updated:

  1. Gyannea

    Gyannea Member

    Sorry about the errors in my original post. I caught some of the original misses but missed the others. Also I need to do a change mod on the hcidump files and friends. I am a total noob with this web site; my edits didn't turn nice and red and I don't know how to get email notifications of posts I am participating in.
    I will try and get the urls to those web sites for the drivers, but it would be easier to just make them available here if I knew how.

  2. scary alien

    scary alien not really so scary Moderator


    Are you using the Samsung_USB_Driver_for_Moblie_Phones_v1_4_6_0.exe drivers?

    I, of course, do not have my GNex yet (jealous that you have yours and I'm here in central Indiana, too :p), so I can't recreate things at this point...

    I wasn't going to reference any other USB drivers given that the one above is the one referenced by the root packages linked to and referenced in the first post and was probably deemed to the best one.

    There is a USB driver (http://dl.dropbox.com/u/4174784/usb_driver.zip) mentioned in this thread Unlock Galaxy Nexus Bootloader [How-To] | The Android Soul that some folks have found to be helpful in getting fastboot to talk to their devices.

    Check it out and let us know.

  3. scary alien

    scary alien not really so scary Moderator


    I believe so...your syntax for soft-booting the recovery image is spot-on.

    I'm guessing that unlocking the bootloader gives us the equivalent of S-OFF (i.e., in HTC devices) that allows you access to additional fastboot commands and functionality (too many to list here), including using the soft-booting option you referenced above.

    I've been keeping my eye on the XDA thread [RECOVERY] ClockworkMod Recovery *GSM Edition* - xda-developers regarding the ins and outs of installing ClockworkMod for our device. I've been busy with other things like ironing-out the basic rooting post #1 above, so I don't know all of the details yet (and of course haven't had the privilege of doing this yet...soon, I hope :)), but you might want to check out that thread for questions for the time being.

    John Markley likes this.
  4. Gyannea

    Gyannea Member

    Here is the download URL for the driver

    SAMSUNG USB Driver for Mobile Phones Driver for Windows XP / Windows Vista / Windows XP X64 / Windows Vista64 / Windows 7 / Windows 7 x64 Free Download - Softpedia

    Now let me state that this site is a PAIN IN THE @$$ to work with since there are so many download arrows all full of ads. In the url I have given look at the "Software Secure Download (US) [EXE]" button just under the

    for SAMSUNG USB Driver for Mobile Phones

    caption. Mousing over it will show the actual file to download.

    Once you do this WAIT a few seconds. It takes a bit to start. Boy I hate working with this site; its so easy to press the wrong buttons.

    Now this file is only for adb. You need a separate driver to run fastboot.
    It can be found here

    Download Galaxy usb driver.zip from megaupload.com - FilesTube.com - download everything

    You have to wait 45 seconds before you can download it.

    Hope this helps someone.
    scary alien likes this.
  5. scary alien

    scary alien not really so scary Moderator


    That is awesome! :)

    Thank you very much! :)
  6. Gyannea

    Gyannea Member

    Looks like I just lost tow posts with all the download info
    Man I am having a hard time working this forum!

  7. John Markley

    John Markley Member

    Thanks, I will keep watching the CWM thread.

  8. scary alien

    scary alien not really so scary Moderator

    Hmmm...I've not been having any recent trouble...

    LOL, I hope you don't mind, I've been trying to incorporate the USB driver links you provided and a few others at the bottom of the first post, so they are squirreled-away there for safekeeping, too ;) :).

    Cheers and thanks again for those!
  9. Wolfedude88

    Wolfedude88 Well-Known Member

    It wasn't but I tried it anyways and same thing
  10. Buckeye Boy

    Buckeye Boy Well-Known Member

    just wondering if anyone would like to do this? i have my Droid X rooted, but after viewing the many posts about unlocking the bootloader on the Nexus i am getting more and more confused and afraid i am going to brick this phone before i even get it...:eek:
  11. scary alien

    scary alien not really so scary Moderator


    I posted some additional fastboot USB drivers at the bottom of the first post (including the ones that Gyannea provided).

    Give 'em a try if you want.
  12. scary alien

    scary alien not really so scary Moderator

    I know that a lot of this seems confusing and probably will until you actually do it. I remember being totally confused when I first rooted my Eris...things just didn't really click for a while. There were so many new terms to learn, files to download, and instructions to read and re-read. But you'll get there.

    This thread and the members here will be here to help you. The notes I wrote-up in the first post try to cover as many bases as possible to accommodate those that are both familiar and comfortable and those that are still learning.

    If you let us know what you find confusing or give us an idea about which method you'd like to try, we'll try to help fill in the gaps and add that information back to the instructions so that others many benefit from your questions.

  13. iowabowtech

    iowabowtech root@android:/ #

    I've never seen a Samsung bootloader but are you just running adb devices in charge mode, then trying fastboot devices directly after? If so, I'd assume you have to first select fastboot from the bootloader, then run the latter command. Again though, I speak without having seen one yet, I've been an HTC guy up to now and our hboot may be greatly different.
    scary alien likes this.
  14. scary alien

    scary alien not really so scary Moderator

    Great point! Never thought to ask if Wolfdude was in fastboot mode...not having a device yet makes this virtual debugging just a smidge harder, eh? ;) :)

    Good catch, iowabowtech, hope that was/is the key...
    iowabowtech likes this.
  15. iowabowtech

    iowabowtech root@android:/ #

    For sure. All wil be revealed soon though by the sound of it. Can't wait to get my hands on this thing and become familiar with Samsung. It's amazing the nuances between these devices and I'm one that struggles to pick up on everything by reading alone. I need to see the darn thing before the light bulb in my brain will turn all the way on. I think they called that limited comprehension. :D

    You know the coolest thing is that we are going to have one of the most tech savvy forums in the history of AF with this phone. All the hackers are following this one lol.
  16. Wolfedude88

    Wolfedude88 Well-Known Member

    Diffently in fastboot mode, I got there by hitting the volume up and down button then power button. I will try new drivers here in a few and see if they work.
    iowabowtech likes this.
  17. Wolfedude88

    Wolfedude88 Well-Known Member

    Well I think it figured my problem out, I think I had an old driver still installed, I unistalled it then installed the drivers again, finally was able to see it in fastboot mode, man made that harder than it should have been. lol
    scary alien likes this.
  18. scary alien

    scary alien not really so scary Moderator


    Great news...thank you for letting us know.

    Can you tell us which specific drivers worked best for you?

  19. iowabowtech

    iowabowtech root@android:/ #

  20. Wolfedude88

    Wolfedude88 Well-Known Member

    I ended up using fastboot (courtesy of jocke.anell): usb_driver.zip

    It worked for me
    iowabowtech and scary alien like this.
  21. iowabowtech

    iowabowtech root@android:/ #

    Ok thanks. That fasboot driver file is about twice the size as the one posted earlier on this page. I downloaded them both for now and saved on desktop in case I have problems. :confused:
  22. scary alien

    scary alien not really so scary Moderator

    I'm adding list of the various adb and fastboot drivers to a list at the bottom of the first post.

    I also added a note to the fastboot one that Wolfedude88 reported success with to let folks know about its success rate.

    Wolfedude88 likes this.
  23. teddyearp

    teddyearp A guide with guides

    I would be leary of using the CWRecovery designed for the GSM model of the phone. The LTE version has been released, just gotta know where to look.
    John Markley likes this.
  24. John Markley

    John Markley Member


    Never mind. I see. Thanks!
  25. ChanceStad

    ChanceStad New Member

    when I type
    adb push Superuser.apk /system/app (then hit enter)
    the curser moves to the next line, but nothing happens. What am I doing wrong?
    After pushing su, it returned with the speed at which it performed the taskt( I assume that's what it was saying) and then got ready for the next line of input,
    but now (when pushing superuser), nothing . What gives? Please help asap?

    Also, I tried just pushing su to /system/bin, and then doing the adb shell chmod for the su bin, and I got the "error: closed"

Share This Page