Mac Support


  1. GrantHughes

    GrantHughes New Member

    So, in all of my searches I have found poor (if any) Mac support for rooting in general and especially for the Bionic. So, despite my ignorance, could anybody assist me in my efforts? Hopefully others could also benefit.

    First of all, I am not very familiar with Terminal (I have practically no knowledge of its use). However, I do know that Terminal returned messages saying that files and directories don't exist every time I theoretically correctly ran Motofail.

    If there are any questions I need to answer in order to be assisted, I would be happy to.

    Thanks.

    Advertisement
    :
  2. doogald

    doogald Guides Guide

    I've not used this method on a Mac, but, generally, with a Mac running a tool like this you need to make sure that the Terminal window is running in the same folder (or directory) as where the shell script is installed.

    So, the easiest way to do this:

    - start Terminal on your Mac

    - type cd followed by a space (do not hit enter)

    - start the Finder and get yourself in the same place where you have unzipped the motofail_linux_osx.zip file. So, it's probably in your Downloads folder, in a folder called "motofail_linux_osx". Make sure that the Finder is in that folder

    - if you look carefully, at the top of the Finder window, there is a small blue folder icon next to the name of the folder.

    - Manipulate your windows so that you can see at least part of the Terminal window and the Finder window that has this folder icon

    - using your mouse/trackpad, drag that blue folder icon that I mentioned above and drop it inside the terminal window

    - this will have added the full folder path to the "cd " that your type before, so now the terminal window bottom line will say something like:

    cd /users/yourname/downloads/motofail_linux_osx

    - with the terminal window active, hit enter. It should change the prompt to:

    yourcoumptername:motofail_linux_os yourname $

    - at this point, you can type the command:

    ./run.sh

    and it should run fine.
    GrantHughes likes this.
  3. GrantHughes

    GrantHughes New Member

    Thank you. Although I'm sure that was relatively obvious, no one could provide answers previously.
  4. doogald

    doogald Guides Guide

    You're very welcome. I hope that solved it for you. And, no, it's not all that obvious - it's one of those things that you either know or you learn somewhere...
  5. GrantHughes

    GrantHughes New Member

    Since this forum has been useful in the past, and other forums are not being useful, I'll return with copypasta from my other forum.

    "I would like to apologize of there is already a better thread for this, but a problem that I am having more than anything is unrooting.

    I have downloaded the recent OTA for ICS, however I can't install it (presumably because of some nonsense regarding rooting). I had rooted my Bionic, then the June OTA occurred. I think I lost root access during that OTA, and now I'm left with Superuser. I don't want any of it, because it is all just causing me pain. I'd love to just be able to update to ICS, but not if it requires some difficult procedure just to keep my "root."

    So, the plot thickens with: I can't complete anything on a computer (mostly because mine is a Mac, and almost none of the software is compatible, plus I no longer have a USB cable.

    Any Ideas?"

    Luckily, development in the plot furthered.

    "Although it should be do-able without, I got a USB chord.
    I have put the ICS update onto my SD card and tried to install through recover, however that didn't work. The install was aborted. I think that not having superuser would probably help. Or really anything. I don't know what to do at this point."

    And, soon, potential solutions to short-term problems.

    "So, I just re-rooted my phone so that I could uninstall superuser. I then used Ginger Un-root which took maybe two seconds. To my knowledge, I am no longer rooted, seeing as how superuser is gone. However, upon booting in recovery and attempting to apply an update from SD, I got the following:
    assert failed: apply_patch_check ("/system/bin/logwrapper". "4a63fec78956def045b442910a754fa640db8f5a". "16sec 244c44c8e2a73a969cb49834d6f6fe229d7")
    E:Error in /tmp/sideload/package.zip
    Status 7
    Installation aborted."

    But like any story that hasn't ended yet, there is no resolution yet.
  6. OutOfPhase

    OutOfPhase Premium Member Guide

    I don't think that it was the superuser app that was causing issues. Have you ever installed safestrap or have you deleted bloatware? Did you do the forever root method from the past? All of these can cause issues installing the update.
Loading...

Share This Page