Manual Programming LG SpectrumSupport


Last Updated:

  1. BlasterMaster5

    BlasterMaster5 Well-Known Member

    Hello users. I recently got an LG Spectrum used for a good price, and like many people coming down after me, I would like to manually program this phone to work on a prepaid provider, in this case, Page Plus Cellular.

    I downloaded the demo of CDMA Workshop (which allows programming the basic stuff but not 3G or advanced features), and I have QPST, both of which I have attempted to program this phone with.

    My problem is both programs can read the phone memory, but neither can write to the phone memory, as the phone fails with read-only messages.

    It's running stock ICS right now, and I have rooted it.

    The phone has USB Debugging enabled, and is connected via Internet Connection - Ethernet mode, as required.

    Someone had mentioned enabling a kernel option under USB Init, but the details of such are completely in the air and a mystery. I have literally spent a whole day doing Google-Fu to find an answer to this dillema, and no one is talking. So, if you have done this before, and know how to enable the option in USB Init, let me know. Otherwise, I have to attempt downgrading the phone to its original GB firmware in hopes that it will be programmable that way.

    Advertisement
    ddas8888 likes this.
  2. blsmitty

    blsmitty Well-Known Member

    Brother, I was in the same boat. I'm actually in the midst of this process now but just haven't put any money on my P+ account yet b/c I'm waiting for my other prepaid acct to expire (over the wknd).

    Anyway, to answer at least a portion of your question (I hope), I believe when you connect the phone to your PC, you have 2 COM ports: one that says diagnostic & the other, serial. I was informed from various sources online that I needed to connect to CDMA WS & QPST via the diagnostic port but yeah, ran into the same prob you're having.

    Anyway, long story short, use the serial port. I was able to write to the phone that way. Now, I have 611 connecting me to P+'s support line, which I assume, means I have talk & text. I just have to put $ on my acct to test/troubleshoot data & MMS. Let me know how that works out for you & if/how you get data/mms working.

    Thanks & Godspeed, my friend!
  3. BlasterMaster5

    BlasterMaster5 Well-Known Member

    Interestingly, I got it to take settings. I set the USB mode to Internet Connection - Modem, opposite what I was told would work, and I used CWM and a debloated stock ICS, since I could not get Debug Mode to work in CM10.

    Now, to flash CM10...
  4. blsmitty

    blsmitty Well-Known Member

    Sounds good! Let me know how data works for you.
  5. BlasterMaster5

    BlasterMaster5 Well-Known Member

    So far, I am still finding a ROM that has working Bluetooth and Debugging Mode. It seems I can have Debugging on stock based roms, but with CWM that breaks bluetooth on them. Neither of the Quattrimus JB ROMs (CM10, AOKP) have a working debug mode, which leaves limited options.

    You MUST be able to access Andriod Debugging in order to program these phones manually, or it does not work!
  6. blsmitty

    blsmitty Well-Known Member

    You mean diagnostic mode, right? All those ROMs have USB debugging.

    Per Neph on this thread, seems it's a minor fix though, sadly, I'm not knowledgeable enough to fix it myself.
  7. BlasterMaster5

    BlasterMaster5 Well-Known Member

    So far, no good. Got the ESN switched over, but the phone didn't. It has all the settings, verified by everything, but the phone doesn't want to recognize them in teh software, despite being there in the hardware. If I read settings, they are all correct, but About Phone still shows a dummy number (000000BLAH).
  8. blsmitty

    blsmitty Well-Known Member

    Did you try the serial port com I mentioned before? If you're not sure, check your device manager to see where it's at.

    If that's not it, in CDMA WS, try sending the SPC & then writing the SPC before writing the prl. If that doesn't work, then do that as well as setting the R-UIM to "NV only" (under the "Main" tab in the drop-down box under CDMA-2) & then try writing the prl file.

    Let me know how it goes.
  9. BlasterMaster5

    BlasterMaster5 Well-Known Member

    Only thing I have not tried doing is Writing the SPC. Will work on it in the morning.

    EDIT: Nope, Write SPC changed nothing, but the two COM ports seem to have different results. COM10 appears to write information overridden by the SIM card, whereas COM11 writes information for the CDMA side. However, QPST does not recognize the phone on COM11, it recognizes there's a phone on COM11, but it can't get what kind, and won't allow reading or writing, so I probably will not have 3G until that is settled.

    Also, it seems this information is preserved through software updates. Now, I just have to figure out how to get back to Stock ROM.
  10. death2all110

    death2all110 VIP Member VIP Member

    Its an issue with CM10, for some reason the NV can't be read.
  11. blsmitty

    blsmitty Well-Known Member

    I've had the EXACT same problem except I was on the stock V6 ROM (so I don't think it's just a CM10 issue). I thought I'd start w/ that ROM since I heard ICS didn't do full 3G & since CM10 doesn't do diagnostic mode. But again, as of yet, I haven't put money on my acct. to try it myself (long story).

    Anyway, I'll be signing on w/ the $30 plan tomorrow so I'll update you on my progress (if any). Keep plugging away. I think this is worth it, both for us & the community as well as the future of the Spec.
    ddas8888 likes this.
  12. ddas8888

    ddas8888 Member

    Suffering with same disease. Waiting for the right medicines. Keep it up.
    Thanks
  13. BlasterMaster5

    BlasterMaster5 Well-Known Member

    The answer is to use CDMA Workshop and to spend the $100 to get the registered version, but because I'm super poor, that will not happen anytime soon. Unless somehow QPST can be fixed.
  14. BlasterMaster5

    BlasterMaster5 Well-Known Member

    So I got CDMA Workshop, and I got it programmed for 3G. Did it work? Nope. No 3G. So I flipped the MEID back and forth from a Moto Barrage I have, and went on its mobile browser after programming. Nope. Still no work. I copypasta'ed the settings from the Barrage to the Spectrum. Nope.

    I'm using the 53022 PRL, as downloaded from the Barrage, which was programmed OTA for Page Plus.
  15. blsmitty

    blsmitty Well-Known Member

    Did you actually fork over the $100? Hopefully not because I think the DFS CDMA Tool does the same things w/ their demo version (though the UI is really "busy"-looking).

    Either way, I'm stuck also. Talk/text/1x data were a snap! Basically just push the prl. But 3G is a total NO-GO! :mad:
  16. blsmitty

    blsmitty Well-Known Member

    So here's an interesting phenomenon: With wifi on, I actually get a 3G signal (screenshot--sorry, should've downsized that file haha!). But once I turn it off to connect via cellular signal, I lose the 3G connection. Anyone knowledgeable able to comment? (Btw, I was on the 52711 prl)

    [​IMG]
  17. ddas8888

    ddas8888 Member

    I want to use Reliance cdma in INDIA with my spectrum. configured with ws v 2.7 in serial port with following
    MIN-entered the min of activated reliance sim that's hold the mdn, am using in another handset
    MCC-404
    MNC-00
    DIRECTORY-0000000000

    After these , phone has rebooted and reliance signal came and hearing ivr of cc after dialing *222 but I could not able to dial *228
    and when trying this a message appears that tells to insert sim in the slot but the phone is already in NV mode . Contacted with customer care but they have no knowledge to solve this.
    Waiting for your kind help to solve this with *228 enable.
    THANKS FOR BIG HEARTS.......
  18. blsmitty

    blsmitty Well-Known Member

    Unfortunately, ddas8888, that's a bit hard to comment on since none of us have our Spec's fully operational (incl. 3G) here in the U.S. My guess is that you simply need the MDN (your phone #) & your MIN (or equivalent--see your carrier) as well as the proper prl file. Then, program your phone using those via DFS or similar.

    By the way, CDMA workshop 2.7 I believe is not adequate for flashing our phones.

    Godspeed man
  19. BlasterMaster5

    BlasterMaster5 Well-Known Member

    Tried the DFS Demo, still no good. CDMAW works fine, but I have a feeling neither app is pushing the password for 3G...
  20. ddas8888

    ddas8888 Member

    blsmitty
    Sorry to say your guess did not helpful. Anyway keep this up. m waiting......
  21. blsmitty

    blsmitty Well-Known Member

    Sorry man. Let us know if you figure something out. Best wishes to you.
  22. BlasterMaster5

    BlasterMaster5 Well-Known Member

    This phone was obviously designed with only being activated on 4G networks in mind. The phone does not have *228 provisioning, as this has to be available in software, so you have to provision it manually using DFS Tool (the Demo will let you program the NV memory and EVDO) or CDMA Workshop (requires full version to unlock EVDO programming).

    It is unknown if the phone works properly in 3G only mode, since there is a bug in the Verizon system that causes problems with 4G phones provisioned in 3G only mode to fail authentication.
  23. blsmitty

    blsmitty Well-Known Member

    Update (sorry, not progress but just something new): I have been on CM10 for the last week-ish & prior to that the stock ICS OTA (rooted w/ CWM). As has been noted, in ICS, *228 or equivalent does not work. However, on CM10, *228 actually does go through & programs the phone, at least as far as I can tell (the prl was updated from 52797 to 53000; the latter was actually already available to download online).

    But, as I suggested already, this doesn't give me anything that I don't already have: talk, text & 1x data. Bleh. :confused:
  24. ddas8888

    ddas8888 Member

    Thanks for the info and what about CM 10.1 or AOKP 43?

Share This Page