No Option To Sync Gmail CalendarSupport


Last Updated:

  1. dosparks

    dosparks New Member This Topic's Starter

    Joined:
    Oct 11, 2010
    Messages:
    3
    Likes Received:
    3
    Hi everyone, I just switched from the blackberry over to an Incredible and so far am loving it other than this one issue. My brother and I got our Dinc's a couple of days ago from the Verizon store.

    My problem is that when I go to Accounts & Sync > google > I have no option to sync my calendar. I have logged into it on the computer to check for any settings that might not allow it and don't see any. The gmail account was a new one which the person at Verizon had me set up for the phone. She also got my brother set up the same way and his phone does have the option to sync with the calendar.

    Also when I go to my calendar application > calendars > there is no option for the gmail calendar there either. Also no calendars are listed under add calendars.

    I talked to the mobile guys at work (Best Buy) today and they had never seen this before on an Android phone. When searching the forums I came across a somewhat similar problem that someone had but they actually had the incorrect calendar selected.

    Thanks for any help or advice. Let me know if I can provide any other info.
     

    Advertisement
    cewatson likes this.
  2. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,067
    Likes Received:
    8,534
    Your Google calendar is always syncing if you have a Google account set up on your phone. When you go to Accounts & Sync, press on your Google account and see if the calendar checkbox is selected. If not, check it.

    Then you should be able to add a widget for the native calendar or another calendar app from the market. For the native app, press menu > More > Calendars, then Menu > Add Calendar. If it doesn't work for some reason with the native app, try another like Smooth Calendar from the market.
     
    cewatson likes this.
  3. dosparks

    dosparks New Member This Topic's Starter

    Joined:
    Oct 11, 2010
    Messages:
    3
    Likes Received:
    3
    Maybe I wasn't clear enough, under accounts and sync, then google account there isn't even an option for google calendar. It only has the two option of sync contacts (which also isn't working even though its selected) and sync Gmail.

    In the calendar under menu > More > Calendars, then Menu > Add Calendar there is not option for the gmail calendar. No calendars are listed. The calendars I have selected are facebook and pc sync and the gmail account does not appear like it does on the other android phones I have seen.
     
    cewatson likes this.
  4. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,067
    Likes Received:
    8,534
    Wow, that is interesting. Have you tried to add an event to your online Google calendar? Maybe if it's viewing the calendar as empty, it doesn't bring it up as an available item to sync? That said though, I've never heard of this before and I don't think I had any Google calendar events prior to owning this phone. Just a random idea to try.

    Couple other thoughts:
    Go to Settings > Applications > Manage Applications > All

    In addition to the Calendar app, do you have 2 apps called "Calendar Storage" and "Calendar Sync Adapter"?

    And finally, can you post your phone's software info from Settings > About Phone > Software Information?
     
    cewatson likes this.
  5. dosparks

    dosparks New Member This Topic's Starter

    Joined:
    Oct 11, 2010
    Messages:
    3
    Likes Received:
    3
    Yeah it was pretty strange. This has now been resolved with a factory reset. I went to Verizon today and we tried a couple of things like removing some applications to see if they were causing interference but had no luck so just did a restore. Thanks for the advice though.
     
    cewatson likes this.
  6. birdoffire7

    birdoffire7 Member

    Joined:
    Jul 24, 2010
    Messages:
    10
    Likes Received:
    2
    I know that this is an older post and the OP has already had the opportunity resolved, but after experiencing the same issue on my wife's DInc and finding this post useful I thought I'd list another option to correct to help others searching this topic.

    The simple answer that worked for me was to add another gmail account to the phone. I added an existing account (or you can create another) to Settings -> Accounts & sync -> Add Account -> Google. When the phone pulls the info from the second account during this process by checking the Google servers, it also reviews and recognizes the fact that the primary account has Calendars and adds it to the phone. Double check this after adding the second account then delete the second account (unless, of course, you do want multiple accounts on your phone which is supported). No factory reset needed.

    FYI - I've had my DInc since release date and had no issue with this. My wife's was purchased a week ago and did. Strange.
     
    isaidself likes this.
  7. verticalorbit

    verticalorbit New Member

    Joined:
    Dec 29, 2010
    Messages:
    1
    Likes Received:
    1
    I'm having this problem, too. I had to do a factory reset for other reasons, and when I added my google account, it will no longer give me the option to sync my calendar. However, it gives me the option to do so with my second gmail calendar.

    I'm probably going to take it by a Verizon store today, but if someone can help me with it I'd appreciate it. Thanks!
     
    cewatson likes this.
  8. Otuama

    Otuama Member

    Joined:
    Apr 20, 2010
    Messages:
    10
    Likes Received:
    1
    Hi,

    I have the exact same problem.

    I just read a thread about it.

    The user who was having the problem said that he added another gmail account, deleted it and the sync calendar option was then on his account.

    Sean

    edit. ah, it didn't work
     
    cewatson likes this.
  9. SimpleMobDev

    SimpleMobDev Member

    Joined:
    Apr 9, 2011
    Messages:
    10
    Likes Received:
    6
    adding new account and then removing it worked for me. the first account shows calendar now.
     
  10. wardwes

    wardwes New Member

    Joined:
    Jun 18, 2011
    Messages:
    1
    Likes Received:
    0
    WOW, Worked like a charm! I had the EXACT same problem with my brand new Moto Atrix 4G...

    Very frustrating as I spent two hours with the geniuses at AT&T and Motorola tech support and got nowhere. This forum discussion saved my day. Thank you.
     
  11. sparkles1066

    sparkles1066 New Member

    Joined:
    Jul 6, 2011
    Messages:
    1
    Likes Received:
    0
    It worked for me also - Samsung Galaxy tab 10.1.

    thanks!
     
  12. niekvalk

    niekvalk New Member

    Joined:
    Jul 31, 2011
    Messages:
    1
    Likes Received:
    0
    works like a charm htc desire s. Tx a million:):)
     
  13. revoluciona

    revoluciona New Member

    Joined:
    Aug 25, 2011
    Messages:
    1
    Likes Received:
    0
    I have added a second gmail account and any app calendar .. jorte, business Calendar, Calendar doesn't works.


    On the other hand. I cannot install simples calendars (Installation Error).

    I have Sony Ericsson xperia with android 2.3.3


    Thanks.

    Revoluciona.
     
  14. jediknight411

    jediknight411 New Member

    Joined:
    Dec 30, 2011
    Messages:
    1
    Likes Received:
    0
    It took me two hours to find your help. I greatly appreciate to lead me in the right direction. My calendar was not syncing and did not show up in the account and data sync section with "google calendar" as a sync option. At first I tried your solution to add the secondary account (gmail) but it didn't work so I removed it. I didn't want to reset my phone, so what happen was when I add the secondary account I was using my "wifi" connection to add it. So last try I did was turn off wifi and connect to a 4g signal and then add the second account which (worked like charm) the new account force the primary account to have the "google calendar" sync options now. Finally I removed secondary account and my wife is finally able to use this phone now with her calendar. Happy New Years!
     
  15. mrboombastic

    mrboombastic Member

    Joined:
    Aug 7, 2010
    Messages:
    5
    Likes Received:
    0
    Hi,

    Just to confirm what you are saying. I too have android 2.3.3 "Gingerbread". And It seems the default Calendar Management Module is broken!

    With the default Android Calendar I cannot create a Calendar, I cannot sync to a Google calendar, or even add an entry to the calendar when I open the app (because none are created)

    I tried using Fliq calendar. Which seems to be an exact copy of the Default Android Calendar. That program allows me to create local Calendars on the android device. But still no options to sync with Google calendar!

    I'm running an unoffical Eximus 7" Android 2.33 Gingerbread Tablet. And I'm not sure if either there is no Calendar Sync Management provided or its simply broken!

    Its probably missing the GoogleCalendar Sync apk.
    If anyone has any ideas as how to fix this please reply!

    Regards
    Aubrey
     

Share This Page

Loading...