Please help me bring my Hero back to life


  1. littlewhiteowl

    littlewhiteowl Active Member

    Hi, I've got problems with my Hero. Here is my sad tale:

    I was using it one day just fine, later plugged it in for charging overnight, and the next day it wouldn't boot up. It froze at the Htc screen (I think that's what it was). Then I kept it plugged in and waited till today (when I have more time).... I removed the battery, waited, and put it back in. This time it got farther. It went all the way to the fresh screen. I heard the familiar fresh sound and I was excited that it might boot up, but it got no further. The screen went black, then nothing. I've pulled the battery again.

    The fresh I'm using is out of date...could that have finally caused a problem? I did notice there were a few apps that didn't work anymore, but nothing that seemed that serious. I didn't have the time to do the update...so it's still got fresh 2.0d. So I know I need to do an update too.

    I have backups of everything on my computer. I also have notes from the day (May 7, 2010) I rooted and installed fresh. I did the backup of the recovery image and the 1.6.2 flash recovery image. I guess that goes without saying.

    I don't want to do anything until I hear from you guys telling me what to do. I'm computer hip but not very phone savvy. I did flash my Hero when I got it, using this forum, and the xda-developers forum, and a very good youtube video linked to from the xda-developers forum. I've been using my Hero with no problems until now; it's been a year. In fact, I'm due for an upgrade, however, I don't want to pay to go up to an Evo right now, so I'm sticking with my Hero for a while.

    Here's the clincher. I have a phone message saved that I cannot lose. It is from my father who died on Christmas Day 2010. He left the message about a week before he died, and it's very precious to me. No matter what happens to my Hero, I must retrieve this message. Please help me! :)

    Thank you so much!

    Layne

    Advertisement
    :
  2. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    First your voicemail will not be lost because you have that saved with Sprint, if that is your carrier. Now are you able to boot into recovery, if yes, then do so, and clear cache and davlik then reboot and report back


    littlewhiteowl likes this.
  3. littlewhiteowl

    littlewhiteowl Active Member

    Thank you, I'll boot into recovery...as soon as I figure out how to do that.

    Through a friend I just found out that the voice message would be stored with Sprint and not on my phone (it seems so obvious now - I just didn't think about this very deeply or clearly), however, I called into my account from my home phone and there were no old messages there. I'm going to call Sprint and ask if there is any way to retrieve the message. My friend said they probably dump them after a certain period. He called the day after my birthday and six days before he died. It didn't occur to me that Sprint could delete my voice message. I don't expect to get results, but it can't hurt to try.

    Thank you so much for your help. I already feel better now. :)
  4. littlewhiteowl

    littlewhiteowl Active Member

    Where can I find instructions on how to boot into recovery, clear the cache and davlik? Thanks!
  5. genuser

    genuser Well-Known Member


    Boot to recovery...
    Power off
    Hold home key WHILE powering up
    littlewhiteowl likes this.
  6. littlewhiteowl

    littlewhiteowl Active Member

    Regarding the voice mail message from my father...I called Sprint, was transferred to a tech. He kept me on hold a long time, twice, and the whole thing was very odd. He seemed robotic (I kept wondering if it wasn't a real person!). What it boiled down to in the end (which I could have been told in the very beginning) was that Sprint only keeps voice mail for 30 days. So...it's gone. Does that sound right???
  7. littlewhiteowl

    littlewhiteowl Active Member

    Okay, I powered up with Home pressed. The highlight is on "CLEARSTORAGE". I'm assuming I want to "clear storage" - right? What do I do?

    Then I'm asked if I want to delete all user data? Do I? (That scares me - I don't think I want to.) Then there's a <Action> Yes / <Send> No. How do I do answer this...I mean HOW do I choose an answer on the screen and submit it?

    Update:
    This isn't the Recovery screen, right?
  8. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Ok first when was the last time you listened to the message, and yes they usually store them for 30 days only, but if you choose to save the v/mail, then it still should be saved, they are not suppose to delete saved message, but if you simply listened to it but did not save it at the end, then it is most likely lost

    Now back to your phone, since you are on Fresh, I assume you have rooted your phone a while ago, then what recovery image are you using, RA or Clockworkmod, that image is what you use to create a Nandroid backup of your current Rom. If you do not know what you have, then you will do this, download an app from the market called, Rom Manager, then install, once installed, then open the app and allow it Superuser Permission. Then once opened, on top hit the flash a recovery image, once done, then I do not like to boot into recovery from that app, so I simply hit the end key to reboot the phone, then instead of hitting reboot, hit boot into recovery, that should boot you into recovery. Once into recovery, then scroll down to back up and restore, and create a back up, once you have a back up, then hit the back button and then scroll to wipe cache partition, then hit yes wipe cache, then back out and scroll down to advance, hit that and then scroll to wipe davlik, then hit yes to wipe davlik, once done, back out, then hit reboot system now. that will reboot your phone, and let see what happens from there. You will be protected as you created a fresh back up, it will be on your SD card, report back
    . ;)


    littlewhiteowl likes this.
  9. littlewhiteowl

    littlewhiteowl Active Member

    I looked in my backup downloads on my computer. I have recovery-RA-heroc-v1.6.2.img on my Hero as I said in my first post - though I didn't have the entire file name then so maybe the RA essential part was not evident. :)

    Should I try to boot into recovery using volume down instead of Home with the power button? I've read that sometimes there is an issue with that. I am sure I used volume down when I did all this a year ago.... I'll try it.
  10. littlewhiteowl

    littlewhiteowl Active Member

    Report: used volume down and power, came right up, some things scrolled by fast, now it's on a white screen with the three Android skateboarders at the bottom. It has all the Hero info at the top, then in white with a yellow background: SIMLOCK. After that it says:

    SD FAT32 init OK !!!
    Process done, reboot device?
    <MENU> Reset Device

    What is the process that was done?
    If I select Reset Device I will reset to factory, correct? I don't want to do that though, right? Can I reboot and not reset?

    Why am I not getting to the black and green recovery screen?

    I should already have a backup of my fresh 2.0d rom saved on the card.... I did not remove it after installing a year ago and I know the RA recovery image 1.6.2 is there too.

    I'm going to plug in my phone to keep it charged and leave the screen as is till I get a reply. I'll check in the morning. (I'm on Pacific time.)

    Thank you! I'm sorry I know so little about this process....
  11. littlewhiteowl

    littlewhiteowl Active Member

    I couldn't give up.... Okay, so I just tried booting into recovery again and this time it worked by pressing Home and then pressing the power button with Home still down. (When I pressed them simultaneously it did not work before.) What a relief to get this far. And at the bottom of the screen it does say: RA-heroc-v1.6.2.

    Next: I did a Nandroid backup, went to Wipe, then Wipe Dalvik/cache (one command), then back and selected Reboot System Now.

    Upon reboot went through screens: htc, HERO, fresh, htc ani, then stopped.

    So at this point it seems I need to flash with an updated ROM like AOSP 2.3.2. I will download that to my computer and check in tomorrow....
  12. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Umm interesting. What you will need to do is download both the AOSP GB 2.3 Rom and the latest Gapps to your PC, which are the Google applications. Then I would power off your phone, then take the SD card out and insert in your PC, then transfer both Rom and Gapps onto the Root of the SD card, once done, then put back the SD card in the phone, and then try booting into recovery again, if successful, then do a full wipe, since you already have a back up, then flash the Rom, and then flash the Gapps, then reboot the phone, and report back.


    littlewhiteowl likes this.
  13. littlewhiteowl

    littlewhiteowl Active Member

    Thank you! Will be able to have time to do this later tonight I think. I will be reporting back!

    4/13 Update: Working on this....
  14. littlewhiteowl

    littlewhiteowl Active Member

    I have to say I'm proud of myself. :) I got myself through this and I'm successfully rooted and flashed to Aosp CMod 2.3.3 and have installed the Google apps. Wow! This is light years from what I had with my old Fresh 2.0d. - which I loved, by the way, don't get me wrong.

    What I had to do is this (and "this" includes a lot of research and crossing my fingers!):

    I connected my Hero to my computer and used the USB-MS toggle option to save my aosp CMod-HC-20110326-signed.zip and gapps-gb-20110325-signed.zip to the root. Wow, that was a life saver. I was so happy it worked! (I didn't have an adapter for my micro SD card so couldn't copy the files from my computer using a card reader.)

    Then it was easy.... After I rebooted, I delightfully watched the new screens come up and then used Market to get Rom Manager, Superuser, and Titanium Backup, among many other cool apps.

    Thanks for the guidelines. I had to figure out a LOT of details myself, but it all worked out just fine. Now I get to learn about this Rom and what it can do.

    Thank you, Don, and genuser too, for your help!

    Layne
  15. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Great glad you got it working, you will really like the GB rom, enjoy


  16. MsGtx

    MsGtx New Member

    Yeah...that.

    It took me way too long to find this simple thing (the slight-but-critical difference between holding down one button--and just tapping the other--vs. holding down both buttons during the re-booting).

    (And by the way, I couldn't figure out any safe option to back out of that scary "delete all user data?" screen besides pulling the battery.)

    Y'all please spread the word and/or make things clear when you give directions to us poor noobs!

    Unfortunately this thread is now closed, where I thought I had found the ultimate simple directions. Would have really like to have added a little note about the button-pressing issue.
Loading...

Share This Page