[Problem and Solution] After GB Update, missing apps? Avoid reinstalling, try this...General


  1. Bluefab5

    Bluefab5 Active Member

    I need some help with this. I have access to a cpu with windows 7. I found the contents of the .android_secure folder but I'm not sure exactly where I'm supposed to move them to?

    Should I cut or copy of the files?

    Once they are moved how do I unmount the drives?

    THANKS!
  2. RoboCuz

    RoboCuz Well-Known Member

    When you connect your phone to the computer, there should be two drives that show up. One is going to be your SD Card, where the .android_secure folder will exist and have lots of files probably in it.

    The other drive, if you have already done the upgrade, will have a folder as well that will be likely empty or mostly empty. You want to move the contents of the folder from the SD card drive to the emmc or internal drive (the one that shows about 6.5 GB total space).

    Then you just eject the drives and unplug the phone, and reboot. You should be all set.
  3. homerpez

    homerpez Well-Known Member

    I just discovered this unwanted "feature", and couldn't be more upset about it. Virtually all my apps were on the SD, and now vanished. What is Google/Verizon thinking???

    This ranks right up there with the "improvements" made to Google Nav, where it dims the screen in hopes of solving a battery charging problem that I NEVER HAD. (Where supposedly your battery would go dead because supposedly the app runs more power than you can charge - not true for me).

    Thanks for the advice here, I will try it, and hopefully I can get my phone back. But I'm seriously wondering about that I-phone thingy all the kids are talking about.

    EDIT: The method above seems to work. Thanks again, RoboCuz...
  4. jakob95

    jakob95 Well-Known Member

    Well I still have the problem were my icons don't show up on my folder, yet they do in the app launcher.
  5. xfuchsiax

    xfuchsiax Well-Known Member

    Does rebooting the phone without fastboot enabled cause the SD card to unmount? I don't really want to keep fastboot enabled all of the time.
  6. jakob95

    jakob95 Well-Known Member

    Well I still have the problem were my icons don't show up on my folder, yet they do in the app launcher.
  7. LOVEDROIDS

    LOVEDROIDS Member

    So, I have this stupid OTA that has done nothing but mess up my phone so far. I've done every method listed to get the missing apps back... Nothing has worked. If it was just the apps, I could reinstall. But since the "update", I have had a continual warning of low storage space. I have had to remove apps just to make calls! Yesterday I had 182 apps with room to spare. Today, I have 64, and constant warning to remove more. Please help! I hadn't rooted because I assumed the OTA would be more stable. My perfectly reliable "incredible" phone is a glitchy mess and I'm heartbroken.
  8. GrungyNA

    GrungyNA Member

    I am also getting not one but two memory space warnings saying I need to free 512k. I keep deleting apps, cache, etc and its not helping.
  9. NightAngel79

    NightAngel79 Bounty Hunter Administrator Moderator

    What folder do you mean?

    Its not the cache its the data from apps.... go to manage applications and sort by size and try clearing data from them....

    there is a huge thread about low space message but try to move bigger apps BACK TO PHONE first then put back on SD card...
    GrungyNA likes this.
  10. jakob95

    jakob95 Well-Known Member

    I mean on Android you know how you can make folders and stuff on the home screen? Well I have a folder made on my homescreen for "Games" and the icons of the games aren't in the folder(just the name of the game and an android picture on a note), but if I click on the app it works.
  11. Maggu

    Maggu Member

    I'm with you - same problems & issues. When I called Verizon about it, I was told that the update was a success & no one was having any problems except me. Even when I mentioned the Sprint's market + 4.3" screen I was told that no one at Verizon had heard of anything like that. I was pretty much dismissed with suggestion of doing a factory reset.

    I was just on Dell's mobile website & accidentally clicked on feedback, only to see a note saying it recognized my mobile phone as "HTC 001HT (Desire HD SoftBank)". That also explains why one my phone-model specific apps (international calling card dialer app) doesn't work since the GB update.

    Is there anything we can do as a group to get Verizon to quickly fix this embarassing mistake? I tried above steps of copying files from the SD card to the phone's internal folder but it only resulted in the 2nd error others have reported. It got to a point where every click/action resulted in the error message popping up. It only went away after I reversed the copying steps & I'm able to use the phone. The one low on space error is still there continuously, several apps have the generic android icon but they work (i need to unmount/mount after any restart), slightly worse battery life since before GB, etc.

    BTW, I have the original Incredible (preordered & received on day one) & have never rooted it. I absolutely loved it until now & would like to continue doing so...
  12. krelvinaz

    krelvinaz Member

    I have an original Dinc (preordered) and had issues after upgrading my rooted phone using on of the OTA nandroid updates.

    I mounted my phone (plugged in and selected disk drives) to my PC and copied all of the apps in the SDcard (a 32GB) from the .android_secure to the Internal 8gb drive.

    I then copied them to my PC for safe keeping and removed them from the SDcard.

    When done, I unmounted the drives... and did a reboot.

    Everything came up without any issues after the boot including some of the missing apps.
    alostpacket likes this.
  13. LOVEDROIDS

    LOVEDROIDS Member


    Wish I'd tried this...I finally broke down and did a complete factory reset. So far, it seems to have fixed the issues, but I still live in fear every time I download a new app that the low storage notice will pop up. And, even though I backed everything up, I still lost a lot of valuable information within the actual apps.

    One other thing... what, exactly, "upgrades" was I supposed to obtain from this update? Now that my phone is working again, I can't see how it functions any differently. Speed, battery, etc are all the same. Is there anything I can do to retrieve some of the benefits of gingerbread?
  14. euph_22

    euph_22 Well-Known Member

    Android 2.3 Platform Highlights | Android Developers
    You can also google "changes in gingerbread", and ignore anything that has to do with delicious baked treats.
  15. buckeyes822

    buckeyes822 New Member

    OK, I am brand new to the Android Forums and just joined simply because of this issue. I just upgraded to 2.3.4 the other day and have been going crazy trying to figure this out. I have done all the steps in this tread and found that although the icons directly on the home screens do get restored the icons inside folders do not - meaning they are there inside the folders but stay as the default droid icon. However they do work after performing the steps in this thread.

    So... I found another forum website and the issue as they saw it was not only the the .android_secure folder but the HTC Sense Loader is loading before the SD card is mounted. This HAS TO BE AN ISSUE THAT NEEDS TO BE FIXED. Once I found that and go to Settings \ Applications \ Manage Applications \ All tab \ find HTC Sense and select it \ select Force Stop \ hit the home button -- that will restart the HTC Sense and all icons will appear correctly.

    The question now is: Is there an App that will stop and start HTC Sense? I looked for a long time last night and see launcher apps but nothing that will stop and start it. As you all know this is extremely annoying and has to be fixed but I have no hope that it will be. My wife and I both have the Incredible and rotate 3 batteries so instead of charging it in my phone we have a desk battery charger and always have a fully charged battery on hand. Therefore I always do a battery pull - now this is happening every time I change my battery. I even went as far as buying a new 16 GB Micro SD card because I thought the upgrade screwed up my old card.

    Any help or further suggestions would be great. I even looked for boot order apps to see if I could make sure that the SD card was getting mounted before the HTC Sense launcher runs but did not find anything...
  16. jazzfreek

    jazzfreek Member

    I am experiencing the same problem with the icons not refreshing inside folders. I found an easy way to refresh them is with an app called Fast Reboot available in the android market. One click and it kills many running processes and tries to reclaim memory. It only takes a few seconds and you get the icons back. It is a free app. I cannot believe that Verizon let this POS out and didn't notice the problem(s). I think I am through with Verizon after this debacle.
  17. AppsDeacs

    AppsDeacs Member

    *** Update *** this is apparently an issue with the mac os, not showing files and folders that begin with a period, they are hidden.


    Probably a very noob question.

    I have mounted my incredible as a drive on my macbook and i don't see the .android_secure folder on either mounted drive. Does this have something to do with the macbook? I have tried turning on usb debugging with no success either. Thanks for the help.
  18. AppsDeacs

    AppsDeacs Member

    jazzfreak, thanks. I found the solution after my last post.
  19. Markus729

    Markus729 Well-Known Member

    Out of the blue, all my apps on the SD card disappeared, leaving me with a screen full of generic Androids in place of the icon. I simply unmounted the SD card, waited 30 secs and remounted. Fixed.

    Any reason WHY this happens so arbitrarily? pretty frustrating.
  20. RoboCuz

    RoboCuz Well-Known Member

    Yes, if you read my first post....you currently have all your apps on your SD card, you have not moved them to EMMC (internal). you are currently doing the solution listed as "temporary". So anything you do that would cause both internal and external to unmount will cause the SD apps to go missing. If you reboot your phone, mount drives on a PC, etc...all those will cause the .android_secure to get unmounted from the SD card and mounted from internal.

    You should mount your drives to a PC and copy the .android_secure or you will be plagued by this issue periodically. Or continue to do what you just did and umount and mount your SD card if you find them missing.

    Cheers
    RoboCuz
  21. Maggu

    Maggu Member

    Some other problems that I'm seeing since the 2.3 OTA on my Incredible: when I try to make a phone call, it takes about 10-15 seconds before the call is initiated; I'm unable to add a new contact or modify any existing contact information; even when I go to the Gmail Contacts on a website and make changes there, it doesn't reflect the changes on my phone.

    I recently flew and had powered off the phone for the flight (both during to and return flights), when I restarted it each time on landing, it almost seemed like the phone was not shut down but just asleep in how fast it came back on (I'm sure I checked to see that it was shut down all the way). It could have done a fast boot or restarted by itself in my pocket - I'm not sure. I checked the battery status through the menu and Up Time is still in the hundreds of hours.

    Anyone else, seeing anything like this or other weird things on their phones?

    Also, with all these issues I'm wondering if the two year contract we signed obligates Verizon to maintain good service to the phone? Or is the contract one-sided and only requires the users to pay a fine if we do/don't do certain things. I guess, I need to pull up the contract and read it.
  22. LNMeyers

    LNMeyers New Member

    I began to have the same problem soon after the least Android update to my HTC Incredible. None of the programs which I transferred from the internal phone memory to the SD card were operational (error launching application). I spent many hours re-installing everything. It seems that the problem repeated each time I connected the phone to the PC in an effort to download large quantities of mp3s. As soon as I disconnected from the PC, the phone would re-mount the SD card and the programs would disappear again. Again, I repeated the process of re-installing them. After another episode, I sought a Verizon store. The tech there appeared very knowledgeable, but none of his solutions worked. I followed his recommendation for moving the files from the SC card's Android_secure folder to the same-named folder in the phone's internal drive. I made sure to delete the files, as well as the folder on the SD card. I powered down and rebooted. The same problem persisted. Finally, I called Verizon's tech support whose tech (after much discussion with her colleagues) told me to just call *228, select option 1, wait for the registration process to complete, power off and re-boot. Then try to launch the inoperable programs. To my amazement all 'missing' programs were relocated the generic identical gray Droid icons were replaced by each program's original icon and each program was operational. I asked the tech why I was not prompted to run *228 after the update and was told, "The update was by Google for the Android, as modified for HTC, but the *228 is for Verizon. Go figure.....
  23. buckeyes822

    buckeyes822 New Member

    Awww - I was sooo excited to see this last post and just did the *228. BUT, the issue somewhat still exists. As I have posted previously I did the process for moving the Android_secure folder and files a long time ago and all of my apps do work even when they have the generic icon. However my icons that I have in the "root" home screens do come up as they should but anything I have in a folder does not until I use the fast reboot app. Again, I always change my battery with a freshly charged on (because these batteries die so quickly). If I just use the AC adapter then none of this is an issue. Still VERY annoying. I have done everything I can and assume there have to be others out there with the same issue. Hopefully Google and HTC with figure this out because I really feel like there is no one out there that I can directly talk to that can help - or even listen.
  24. Holydoc

    Holydoc Well-Known Member

    After getting the update this morning, I used Drew66's suggestion of just unmounting and remounting the SD card from the phone after a boot to get the APPs on my SD card back. It worked like a charm. I do realize that until Verizon updates this GB UPDATE that it is just a temporary fix. However Verizon has announced a new update to fix this problem:


    http://support.verizonwireless.com/pdf/system_update/incredible.pdf

    So with that in mind, I will just use the temporary fix until Verizon pushes the new update.

    Thanks everyone!
Loading...

Share This Page