Samsung Galaxy S not recognised by Kies software on my Windows 7 64 bit PCSupport


  1. BBradz

    BBradz Member

    When I first got my Samsung Galaxy S 8GB I downloaded the Kies software and everything seemed to work O.K, I was even able to sync some of my music from my pc. I stored them on the phones internal memory and they worked fine, I haven't yet got around to buying a micro sd-card,besides why do I need to buy a card to increase the memory when the phones memory is practically empty.
    Now, a few days later when I connected to my pc, the Kies software launched but doesn't recognise the phone like it did before. It is not recognised in the Windows device manager list, I have uninstalled and re-installed Kies 3 times, all to no result. I noticed at the bottom of the download site it said it only supported Windows 7 32 bit, could that be the reason why it does not work properly?, if it is, why did it work O.K in the beginning?.
    Also when I try to use the music player it just tells me I do not have a sd-card installed, when it worked perfectly well last week.
    Can anybody please help.

    Advertisement
  2. krillo

    krillo Well-Known Member

    Hi

    I basically had the same problem, its caused by drivers not working properly for W7 64bit. There is a work around, but it will require you to get a memory card, at least this solves it for me. This is what I did.

    1. Connected phone = no result, computer does not recognize unit.
    2. Inserted micro SDHC card.
    3. Connect phone.
    4. Mount SD card through notifications menu.
    5. At this point my computer finds the phone, drivers load etc.
    6. Dismount card.
    7. Unplug phone.
    8. Plug in phone, choose KIES from menu (set USB connection to ask in settings)
    9. Kies should now find phone.

    If along the way, Kies does not find your phone again, follow steps 3-9 again.

    If you don't want to get a SD-card you will have to wait until Samsung decides to update Kies to include WIndows 7 64-bit.
    kcyong33, Sibben and BBradz like this.
  3. BBradz

    BBradz Member

    Hi
    Many thanks for info.
    I did contact Samsung support today, and was told they were having teething problems with the Kies software,and somehow he talked me through the problem, my pc now recognises my phone.
    I've discovered that the problem I had with the music player was that when scrolling down the SD card and phone storage, there is a sub- heading Internal SD card, under that heading is Unmount SD card, and although I don't have a card fitted in the phone I accidently chose that option and it removes the results under Total space and Available space. On tapping Mount SD card they show 5.78 GB and 5.15 GB respectively and the music player now works.
    On the subject of SD cards, under the aforementioned heading there is a sub-heading at the top External SD card, what in God's name is that ?. I thought any SD card would be internal. At the bottom there is a sub-heading Internal phone storage, it states the Available space is 1.83 GB which is nowhere what I thought it would be on a phone with a stated 8GB of internal memory. I would have expected it to be more like the 5.78 and 5.15 GB mentioned above.
    I am now totaly and utterly confused - must be my age.
    Cheers
  4. vudluxi

    vudluxi Active Member

    From what I understand regarding the memory of the phone

    External SD card - card fitted by you (up to 32GB)
    Internal SD card - actual phone memory (the 8GB the phone has)
    Internal storage - part of the 8GB

    So if you have the 8GB model then the total space under the internal sd card plus the internal phone storage should be roughly 8GB

    If someone can explain it better please do.
    BBradz likes this.
  5. BBradz

    BBradz Member

    Hi
    Your explanation of memory makes sense, ( sort of ) though why the manufacturer can't just call it internal phone memory and SD card memory I'll never know.
    One more thing I'm trying to get to grip with is, if I want to install say, some navigation software, of approx 200MB, can I install it on onto the phone's memory, or do I have to install it onto a SD card ?.
  6. krillo

    krillo Well-Known Member

    As far as I know you will have to do it on the internal memory, installing apps on "external" cards is only supported in Android 2.2 "Froyo" which we will hopefully get sometime in the future.
    BBradz likes this.
  7. vudluxi

    vudluxi Active Member

    I bought Copilot Live and it automatically installs to the internal memory - no option to put in on the external memory.
    BBradz likes this.
  8. DocNasty

    DocNasty New Member

    whatsoever, Footpunch and BBradz like this.
  9. Machpants

    Machpants Member

    I have found that if I have Kies running when I plug in the phone is just says connecting but never does. SO I plug in the phone, let it connect as a USB device and then run Kies... all good.
    kindofblue and BBradz like this.
  10. BBradz

    BBradz Member

    Hi vudluxi
    I've just bought CoPilot Live v8 software, with maps of UK and Ireland on a DVD.When I run the installation I get to the point where the wizard says "Please select the drive letter of your mounted Android Device" but when I click on the Browse button the phone is not in the list. I've found that if I connect to my PC with the USB cable and select either Samsung Kies or Media player it is recognised by them both, it is also in the list as GT-I9000 -phone when I look in Start > Computer. If I try to rename it, to say give it the letter (F:) it just says "The device name is too long or invalid characters".
    Did you have any problems installing it to your SGS?.
  11. vudluxi

    vudluxi Active Member

    No, I didn't have any problems, but I bought it online from ALK so only had the .apk installation file and had to download the maps from their website.
    So I just copied the file to the external SD card an installed it from there.
    BBradz likes this.
  12. BBradz

    BBradz Member

    Hi
    Following some advice from another post I installed Automount from the Market, and hey presto! my phone is now listed in Start>Computer as Removable disk (F:), and I was able to complete installation of the CoPilot software, but although the DVD I bought was for the UK and Ireland, the only region I seem to have is Iberia, and even that is prompting me to download the maps over Wi-Fi. Also the amount of available memory listed under Internal SD card has gone down from 5.15 Gb to 1.6 Gb, which is a ridiculous amount, when the download from the Market is approx 200 Mb. I'm beginning the think my problems might be solved if I splash out on a 16 Gb micro SD card. All this trouble because I do not have a home wireless connection, and I thought it would be easier to just install it from a DVD instead of trying to find a public access Wi-Fi point. I will be phoning ALK tomorrow to try to sort it out ( hopefully ).
  13. divaboy

    divaboy Member

    Thanks for that decent bit of info :D
  14. immyl

    immyl New Member

    HI All

    thought i would share this:

    two things you need to do: first disconnect your phone, go into settings and sd storage settings then dismount the internal SD and then format it - yes thats right format it

    then you need to mount it back and do a factory reset

    once this is complete, keep your phone disconnected return to the kies software. in the top left click the logo and there is an option that says "driver recovery" - click this - and then close kies

    reconnect the phone and it all works (well it did for me)
  15. amandeep

    amandeep Member

    Just updated Kies to 1.5.1.10074.2
    Connection problems with Windows 7 64bit appears to have been solved!
  16. adambrooks015

    adambrooks015 Member

    Are you sure? i have no luck with Windows 7 32bit after update.
  17. archetypicalone

    archetypicalone New Member

    Hi there

    I just wanted to ask a question - has anyone else tried all these fixes and still had no sucess? No matter what I do, kies doesn't recognise the phone and neither does the computer. Occasionally it will start installing the drivers but theu always cr*p out and come up with the red cross of disappointment. I could use it once as mass storage when WMP recognised it and allowed me to sync some music onto it - now it wont recognise it either. I has tried with and without an external sd card, and with/without the internal sd card mounted, with the phone on and off when plugging in the usb cable (funnily enough, kies will autostart if the usb is plugged in and I turn the phone on, yet wont autostart if the phone is already on and I plug in the usb.
    I'm runnings windows 7 64-bit, have used the drivers that came with the phone on the minidiscs, and uninstalled them and downloaded kies from samsung. I've checked updates in kies and it assures me I am using the most recent version of it.

    If anyone has any ideas on how I can get my phone to connect to my computer, preferably through keis but would be happy to just have computer recognise phone, please let me know as I'm really getting very sad :-(
  18. ogami_ito

    ogami_ito Active Member

    I can connect in mass storage mode. But like poster before me, I cannot connect in any other way and I tried everything. including

    Regedit previous usb drivers
    mount / unmount sd card
    different drivers
    etc
  19. Ninny

    Ninny New Member

    I have never used a smart phone in my life until a few days ago when I bought a Samsung Galaxy S, I had the same initial problems with Kies. The reason it won't connect is because of the buggy software, it will root around on your SD memory and if it comes across any files it doesn't recognise it will reboot and go into an endless loop of doing this. The only way to fix it is to find and delete the files that it's having problems with OR wipe the entire SD memory. Once this is done it should work if you make sure the phone is in Kies USB mode.

    The only problem is once you start putting files and installing apps onto the SD again Kies will probably start having problems again.

    Though I found it more convenient (if maybe slower) to download an App like SwiFTP and do all the file swapping over wireless instead of having to bloody get this USB thing to work.
  20. archetypicalone

    archetypicalone New Member

    Hi again

    Ok, I have now tried deleting all apps downloaded from android market except for a task killer. Didn't change anything.
    Have looked at my device manager - in usb its showing as connected and working, but in portable devices its saying that the phone ' cannot connect - error 10'. Gave up and installed kies to boyfriends computer-runs vista ultimate 64 bit. Every time you plug phone in it installs device and mtf drivers successfully - but phone still doesn't recognise in kies or as mass storage. Just shows as generic in device manager and still can't access phone anywhere. Did trouble shooter finally thru samsung web site and its saying to take it to service centre, it may have faulty board. Beyond ready to cry, ready to scream.

    Any other advice? I just want to sync my contacts! I can do rest via bluetooth.
  21. animal10

    animal10 Member

    Hi,

    I could not connect to Kies until I removed all my music that was in folders on the phone.
    I copied all music back on to phone just in one music folder via mass storage and can now connect to Kies. This is on internal storage, don't have an sd card yet.
    I still can not play music through usb on car stereo like I can a iphone, only works via mass storage mode. Galaxy S does work like iphone in car when I only put a few songs on the phone. Kies software on the phone might have some sort of time out function that is not allowing all the files to be read in time then disconnecting whatever is trying to connect to it.
  22. pepsiboy

    pepsiboy New Member

    I just got a Samsung Galaxy S Vibrant and I absolutely love it. However I hate Kies. I have been having issues with connecting the phone via USB. After installing Kies, the first time the phone successfully connected and I was able to transfer some music to the phone.

    However when I tried to connect the phone a second time I got an error on the phone that the MTP application had crashed and I was forced to close it. After which the phone's screen would flash between the home screen and the MTP application, similar to the following video on Youtube:
    YouTube - Samsung Galaxy S PC connecting problem with Samsung Kies

    I contacted Samsung support on this issue. They immediately responded back and said that if I was running Windows XP and Media Player 11, I needed to follow some steps to remove Media Player 11. I have attached the instructions to this post

    Unfortunately for me I am running Windows 7 Home Premium 64 bit. I responded back with this information and they confirmed that the only work around is to format the internal SD memory card before connecting to the PC. They are working on a firmware update to resolve this issue.

    So to connect I have had to do the following:

    1. Go to Settings and select the SD Memory option
    2. Unmount the internal SD card
    3. Format the internal SD card
    4. Connect the phone to the PC

    Hope this helps people

    Attached Files:

  23. moofychops

    moofychops Active Member

    Hi,
    Having all the above problems. I cannot clear my SD card, it has lots of stuff I need. I cannot believe that this blerdy phone has been released without Samsung realising that a lots of people run Windows 7 64. Just sold my iPhone, I wish I had kept it now and got rid of this useless junk.
    Ron
  24. Vainglorious11

    Vainglorious11 New Member

  25. Footpunch

    Footpunch New Member

    Cheers. Works a treat now:)

Share This Page