Short click to dial in browser not working?Support


  1. cbEck

    cbEck Member

    Today I looked up a restaurant with Google search in the browser, and tried to click on the phone number to call. The button press registers, but instead of going to the dialer with the phone number, it does nothing...:mad: The navigation links work, just not the phone number.

    Is anyone else having this problem or know of a potential fix? It seems some other phones have had this issue after going to 2.2

    Advertisement
  2. stevevt

    stevevt Active Member

    I can't exactly tell what you mean by "Google search in the browser". Are you saying you go to google.com in the stock browser and do a search? Or are you using the Google search widget?

    I just tried both of these methods and neither allowed me to make a call after looking up a business. However, it's also possible you were referring to some other lookup method. If so, please post what it is.

    Note that I just tested that I'm still able to look up and call businesses using the search function in Google Maps, which is how I always find them anyhow, and why I didn't notice the other ways aren't working.
    cbEck likes this.
  3. ckspeed

    ckspeed New Member

    Same problem here on my Droid X, just happened a few days ago to my knowledge. Haven't found a fix for it yet.

    I haven't installed any new apps recently either.
  4. ckspeed

    ckspeed New Member


    I can use the voice and/or text search feature from the Google widget or from the main Google web page, say for example searching for Home Depot in my local city and Google will bring up a list of local Home Depots with their phone numbers in a blue box. I used to be able to simply click on them and the dialer would launch. This is no longer working, the box it there, with the phone number, but clicking it does nothing.

    I can still highlight a number in a website and dial from the browser, this problem appears to be limited to the "blue box" one touch dial button.
    cbEck likes this.
  5. cbEck

    cbEck Member

    I was using the stock android browser and Google as well as the google search widget. Neither one worked for me.

    Using Google maps/places does work though. Good to know I'm not the only one. Thanks.
  6. i have seen three posts like this one with no solution. i am having the same problem but the number wont even highlight. it just comes us as normal text.

    please help?
    anyone?
  7. Still no answer?
  8. Mirage2521

    Mirage2521 Member

    Anyone? This is a very frustrating issue. My will not one-touch dail from browser google maps or text messages.
  9. mapiualuta

    mapiualuta New Member

    I have the same issue. Anyone find a resolution?

    I have a Motorola Photon, Android version 2.3.4, and clicking on phone numbers in the browser, or the call button in maps brings up the dialer, but with no number filled in.

    UPDATE: I solved the problem by uninstalling the Google Maps updates, then reinstalling them.
  10. mapiualuta

    mapiualuta New Member

    Did you ever find a solution?
  11. ffeatccn

    ffeatccn Member

    Thanks for posting- your solution worked after I re-booted, too. When I reboot the dialer link works for a while but then fails after a few hours or a day. I'm afraid this means that an app somewhere is causing it to fail but I don't know which one. Any suggestions on best practice to narrow down which apps might be causing a failure?

    Razr, rooted, 2.3.6, .181
  12. Bivey

    Bivey New Member

    I have been dealing with this problem for some time. The problem is with the browser that you are using. I have a web site that was designed for my business and I use it to dial my customers. When it stopped working I uninstalled the update for Chrome and it starting to work again. Mine is currently not working and I have tried Chome, firefox, best browser and CM browser. I will keep trying. I believe dolphin does work.
Loading...

Share This Page