1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Simple Root .1 Three steps to Root EVO


Last Updated:

  1. garyray

    garyray Member This Topic's Starter

    Joined:
    Jun 14, 2010
    Messages:
    11
    Likes Received:
    2

    Advertisement
    thelonewizard likes this.
  2. DucatiDude

    DucatiDude Well-Known Member

    Joined:
    May 30, 2010
    Messages:
    215
    Likes Received:
    44
    How can you do this on a Mac? Thanks.
     
    blake247 likes this.
  3. Sprockethead

    Sprockethead Well-Known Member

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    It is so much simpler. I spent forever trying to unravel a mess I made, and this fixed it all up for me.
     
  4. DucatiDude

    DucatiDude Well-Known Member

    Joined:
    May 30, 2010
    Messages:
    215
    Likes Received:
    44
    Anyone? Anyone at all?
     
  5. Sprockethead

    Sprockethead Well-Known Member

    Joined:
    Apr 29, 2010
    Messages:
    291
    Likes Received:
    13
    Yeah, I just told you above. This program is the best program that I have ever used for the evo. I recommend it without hesitation. You are crazy (or just trying to do something specialized) if you don't use it. If all you are trying to do is root your phone, then just use this program. Of course, if you care to learn a tiny bit about what is going on behind the scenes then do it manually. But why?
     
  6. HopeofCarter

    HopeofCarter Well-Known Member

    Joined:
    Apr 16, 2010
    Messages:
    121
    Likes Received:
    14
    Used it today, went fine. Put on fresh .5
     
  7. garyray

    garyray Member This Topic's Starter

    Joined:
    Jun 14, 2010
    Messages:
    11
    Likes Received:
    2
    I believe he was asking how to do so on a Mac.
    From what I read Simple Root is not on Mac. Use a friends pc if you can.

    If I can get a phone today (I think bestbuy is sold out) I will root today.
     
  8. st0921

    st0921 Member

    Joined:
    May 31, 2010
    Messages:
    5
    Likes Received:
    1
    @HopeofCarter, did you use it after the recent OTA update or did you use it before the update? It seems like a lot of people are having errors for rooting after the update...
     
  9. HopeofCarter

    HopeofCarter Well-Known Member

    Joined:
    Apr 16, 2010
    Messages:
    121
    Likes Received:
    14
    I used it before the update. Something told me not too. Plus I was busy with school :). Glad I didn't. Fresh .5 is so much more faster and smoother.

    I'm guessing you have the ota? :(
     
  10. st0921

    st0921 Member

    Joined:
    May 31, 2010
    Messages:
    5
    Likes Received:
    1
    Yup, that's the case for me. so, i'm waiting for an updated unrevoked... good for you.
     
  11. autorail1

    autorail1 Well-Known Member

    Joined:
    Sep 26, 2009
    Messages:
    399
    Likes Received:
    15
  12. Zameus

    Zameus Well-Known Member

    Joined:
    Jun 17, 2010
    Messages:
    143
    Likes Received:
    17
    Can't root this way with new OTA. The new OTA killed ROOT. Have to wait until they find another exploit.
     
  13. jakanala2

    jakanala2 New Member

    Joined:
    Jul 1, 2010
    Messages:
    2
    Likes Received:
    0
    Can anyone help? I have been reading about the OTA and the vulnerabilities of security. I have all the recent updates (firmware, prl and htc updates).

    2 questions: If I install Unrevoked will this open my htc evo to vulnerabilities? Also what is this superuser persmission I hear about? What is this superuser, does he or the program have access to all of the data on my phone and if I use my own encrypted passphrase? Does this add security back to my phone?

    My phone is working perfect otherwise. I don't know how to program so rooting the phone is not necessary especially since I only need the wireless tether very seldom.

    can anyone answer my questions, please? thanks KG
     
  14. jakanala2

    jakanala2 New Member

    Joined:
    Jul 1, 2010
    Messages:
    2
    Likes Received:
    0
    Does the new updates cause the Unrevoked and Wireless Tether to not work?
     
  15. st0921

    st0921 Member

    Joined:
    May 31, 2010
    Messages:
    5
    Likes Received:
    1
    If you have the recent OTA update installed, neither unrevoked or simple root will work. You can install the unrevoked, but it won't do anything to your root access. As of now, the OTA wins over both rooting methods. So, I don't think you will be exposed to any vlunerabilities... and you will not be able to use the free wireless tether app, since you won't get the root access. Unrevoked team is working to release the revised version to offer easy root access.
    Superuser permission is basically you are granting root access to apps that require the root access for them to properly work. So, you will first root your phone, then grant those apps permission to access the root. Sure there might be potential vulnerabilities when you grant root access, but most apps that require root access only need certain system info which i'm not sure exactly what those are... For any malicious programs, users will report their experiences in their app review. you can also check this forum or xda-developer site to see if there are any unfriendly reports on certain root apps.

    Hope this addresses your questions.
     
    vss123 likes this.
  16. st0921

    st0921 Member

    Joined:
    May 31, 2010
    Messages:
    5
    Likes Received:
    1
    That is correct for now. The OTA blocked the root access.
     
  17. scrface

    scrface Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    119
    Likes Received:
    2
    Anyone know how I can install net framework 4 on vista?i need it to run simple root and both standalone and web installer hang on install
     
  18. John Kotches

    John Kotches Active Member

    Joined:
    May 7, 2010
    Messages:
    37
    Likes Received:
    1
    If you search for the version of .net simple root asks for you'll find a link to download from Microsoft's website.

    Once yoiu install and reboot you should be good to go.
     
  19. rcubed3r

    rcubed3r Well-Known Member

    Joined:
    May 21, 2010
    Messages:
    50
    Likes Received:
    22
    Can this be used with the new OTA update yet?

    Ron
     
  20. gx1400

    gx1400 Well-Known Member

    Joined:
    Jun 15, 2010
    Messages:
    86
    Likes Received:
    13
    Not yet. Right now to root the new OTA, its all manual with adb commands. I'm sure you won't have to wait too much longer before theres an fairly automated process coming out of xda
     
  21. RockandRoll24

    RockandRoll24 Member

    Joined:
    Jun 12, 2010
    Messages:
    8
    Likes Received:
    0
    Ok, I rooted (I think) with the 3 step method on the XDA Forum. I was previously rooted before, but I wanted NAND unlocked for Fresh's new ROM. Having some problems though... I cannot flash any new roms! I dont even know if I have root permissions right now. I installed Titanium backup and it claims I do not. I have ROM Manager, but that too is not working correctly. Every time I try to flash clockwork recovery, I get "an error occurred while attempting to run privileged commands". Tried fixing permissions - no luck. I have booted into recovery but am unable to wipe dalvik etc.... Its not even an option under the advanced menu. Anyone have any insight on this?! I have also tried returning to a stock rooted rom to see if I could do a wipe and get to Fresh 5 from there. Still, when I try to install from SD in recovery mode, I get a few lines of system info like it is about to start, and then nothing. Right back to recovery mode. I would really appreciate ANY input on this! Thanks!!
     
  22. lloydcabraham

    lloydcabraham Member

    Joined:
    Jun 21, 2010
    Messages:
    5
    Likes Received:
    0
    Hey guys, new to this rooting. Trying not to brick my phone and need a little of your expertise. Had the latest OTA 1.47... Did the OTA simple root and it seemed to do fine but seems my NAND is still locked? Can't get rid of the Sprint bloatware and wireless tether won't work. Wanted to flash to Fresh anyway. Can I go back and use Simpleroot .1 just to unlock NAND? If so, do I just skip step 1 and go straight to step 2? Once I do that, how do I get Fresh on here?

    Thanks for your help.
     
  23. strongsteve

    strongsteve Active Member

    Joined:
    Jun 3, 2010
    Messages:
    32
    Likes Received:
    3
  24. cabbie

    cabbie Well-Known Member

    Joined:
    Mar 23, 2010
    Messages:
    1,344
    Likes Received:
    553
  25. strongsteve

    strongsteve Active Member

    Joined:
    Jun 3, 2010
    Messages:
    32
    Likes Received:
    3
    After flashing Chris' "Sprint Lovers ROM", 4G is rocking pretty solid..

    [​IMG]
     

Share This Page

Loading...