1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Streaming Media Player issues/Virtuous 3.0.1?


  1. Todd M

    Todd M Well-Known Member

    Just curious if anyone else is seeing this issue with Virtuous and Streaming Media Player. This was working fine until I loaded 3.0, and now it appears broken.

    When trying to view a video (streamed) from my Dropbox account, I get an error message that states "Video is not for streaming play. Would you like to download the file?" I have 3 video files that played fine before I loaded the ROM, so I am wondering if there is a player/codec issue with either the ROM or my load. A stock Incredible plays the files fine, as well as a friend's stock X.

    The Streaming Media Player seems to not function correctly. There is an icon that pops up when viewing the Recent Apps, but it will not play any file that I throw at it now, it just errors out. I don't know if this a me thing or a ROM thing...

    Advertisement
    :
  2. anicotra

    anicotra Well-Known Member

    try toggling the audio fix in virtuous buddy.
  3. Todd M

    Todd M Well-Known Member

    Thanks for the response anicotra. I forgot about that.

    I toggled it, and now it gives a different error. The files still don't play, but instead of immediately getting the previous message, I now get a message: 'Cannot play video. Sorry, this video cannot be played.' It has a loading animation, then the error. Before, there was short loading animation, then the 'Video is not for streaming play. Would you like to download the file?'

    I was able to play the same files in 2.7, so I am thinking it is something with 3.0(.1), but I can't narrow it down. It might be related to this toggle, but I can't figure this one out.
  4. anicotra

    anicotra Well-Known Member

    The only other difference maybe the version of flash. I don't remember if there are options for different versions of flash, or unmodified flash for hulu.
  5. Eris Lover

    Eris Lover Well-Known Member

    I had never tried to stream a video from dropbox until now and noticed the same problems. Videos that play fine if local on phone storage will not stream. Would be really cool if I could do this.
  6. Todd M

    Todd M Well-Known Member

    OK, well it seems that it's not just me then. You're right, I loaded the same video to my sd card, and it played fine, but won't stream. It would under 2.7, so it might be something with flash but I don't know how to go about finding a solution/work-around.

    If there is an issue with this, what's the best way to go about getting a resolution to the issue? Would something show in logcat? How does one use a different version of Flash to see if that's the culprit?
  7. Todd M

    Todd M Well-Known Member

    I still have not been able to find a way to have streaming video play on this. I have went back to 2.7 and it's fine, but with 3.0.1 it is broken.

    Does rmk monitor this forum at all?
  8. anicotra

    anicotra Well-Known Member

    Yes he does.

    I think there is a differrnce in the version of Flash between 2.7 and 3.0.
  9. Todd M

    Todd M Well-Known Member

    OK. I guess if I want streaming play I will have to go back to 2.7 or find another ROM unless this is a fixable issue with 3.0. Then again, if I am the only that has the issue, it's probably not on the radar, or it's something with the native player and Flash that isn't a ROM issue.
  10. lan04

    lan04 New Member

    Its not just you ...i have the same issue
  11. Todd M

    Todd M Well-Known Member

    Well, I hate to say it, but I am glad that you are having the problem too because I was beginning to think I was the only one. Unfortunately I haven't been able to find a work around other than dumping the current ROM for an older one or another one completely.

    I am getting ready to flash Redemptive rEVOlution to see if this problems exists on another ROM or if it is Flash based. If it works on the new ROM, I'll stick with that one.
  12. Fatal

    Fatal Active Member

    Stupid question but did you guys try to Download the Flash & Streaming Audio Fix v3 from RomManager?

    I was having problems prior to downloading that similar to yours.
  13. Todd M

    Todd M Well-Known Member

    Thanks for the reply!

    Sure did. Downloaded both options and tried them both with no joy. I get two separate errors when I try each patch. The Hulu patch gives me the "Video is not for streaming play. Would you like to download the file?" error. And, the non-Hulu patch says the file is not a valid file to play at all. I tried this again this morning just for kicks, and still no dice.

    Still, on 2.7 or a stock INC and X it works fine... I will try 3.1 later when it's released, and if that doesn't work, I'm going to try Redemptive rEVOlution 1.8. I doubt its fixed in 3.1 since I and one other appear to be the only ones with the problem. I have posted this problem in several forums and either no one else has the problem, or I am one of the few that uses streaming media from Dropbox. rmk has been busy with 3.1 so he hasn't answered pm's on this yet.
  14. Fatal

    Fatal Active Member

    Are you running v3.0.0 or v3.0.1 Virtuous?

    3.0.1 answered my own question. I'll have to investigate. Give me some time
  15. Todd M

    Todd M Well-Known Member

    Thanks Fatal. I have run out of things to try, but I don't have the coding expertise to see what else it could be.

    I appreciate the help.
  16. Todd M

    Todd M Well-Known Member

    OK, now this is bigger. I updated to 3.1 and still the same. On a whim, I loaded Redemptive 3.1. STILL NO GO. So it's not ROM related. Must be something somewhere else, but I am not sure what that would be. I thought maybe it was some system setting that I was restoring, but I loaded the other ROM, went to Market, downloaded Dropbox, and the files would not play on a fresh load.

    Of to other regions of the Web to find where a fix might be...
  17. MarcM

    MarcM Well-Known Member

    I fixed my by re-installing flash from my Titanium backup.
  18. Todd M

    Todd M Well-Known Member

    Tried that, too. No luck. Do you know what version of Flash you reflashed to? I can't seem to find an older one to load on here and bypass getting it updated. I don't know if my version that i reflashed might be the newer one.
  19. MarcM

    MarcM Well-Known Member

    Mine is 10.1.95.2
  20. Todd M

    Todd M Well-Known Member

    OK, I flashed back to Flash_v10.1.92.8.apk and it still didn't help. I don't know. Guess I have a strange issue...
Loading...

Share This Page