Touchscreen Not WorkingSupport


  1. mqureshi79

    mqureshi79 Well-Known Member

    So I wake my transformer up yesterday and the touch screen doesn't respond... at all.

    No problem... I'll just power down, power back up. Ten thousand tries later, no dice.

    Okay, i'll leave it off for a few hours, see what happens. Nuffink.

    Finally, I swallow my pride and do a hard reset (power+vol down), wiping everything and starting again. Annoying, but hey, if it fixes the problem...

    ...wait... uhm. its still not working? bugger.

    Called TigerDirect. They have it in stock, have shipped out a new one. Packaging up this one now and sending it back in.

    To My friends at Asus: The wide world of google (whom i did consult for advice) informs me that others have had this issue, and there are no fixes out there. Hope it doesn't happen again, else I'll be forced to head down the path of the 10.1 Galaxy tab (which I don'ts want to).

    Oh yeah, and please push 3.1 out to us. Quickly.

    Advertisement
  2. clgwli

    clgwli Well-Known Member

    I had this happen to me. There was a fix for me.... the docking station. As soon as I plugged it in, everything worked again. I was ready to send it back after being on the phone with the tech support even.

    I just wish I had not done the hard reset before trying that. Silly me.

    The guys at ASUS said they were working on a fix for it. We'll see if they do. I hope you get your new one soon.
  3. IsuGuy

    IsuGuy New Member

    This happened to me as well and the fix was to let the battery totally drain until it was dead and would not turn the TF on. Once i plugged it back in it started working again.

    *edit* this took over 3 days!!
    larrymg likes this.
  4. mqureshi79

    mqureshi79 Well-Known Member

    thanks man... They told me it'll ship out today (and I live in Chicago, so it should arrive tomorrow).

    re: Dock fix -> Thats good to know. i can't find the dock in stock anywhere, so hopefully I'll get one soon, so the next time this happens, i'll have something to try before I wipe everything!

    Hope they can fix it soon!
  5. larrymg

    larrymg New Member

    Transformer 2 weeks old, working great. Today I pressed the power button to come out of standby. Lock screen displayed (No lock code installed), screen completely unresponsive to any commands. I have tried all of the methods for restart, hard reset, etc to no avail. Current status is welcome display screen requesting startup. No response to any touch commands. ASUS support is only reachable via email and no follow-up after 48 hrs. I was ready to return the Ipad 2 I was also evaluating after earlier returns of the disappointing galaxy tab and the Xoom, but not now. IMHO the whole process with android tablet manufacturers and their convoluted introduction, distribution, and support is a joke. I have never been a big fan of Apple but they are winning this battle so far. BTW, before anyone suggests the docking station will resolve the problem, I have this thought: If I could find a docking station (which I can't) for an additional $150, why should I have to buy that option to have a functional tablet?

    Update: Tried every fix I could identify on the forums as I was also draining the battery as Isuguy suggested. After 4 days waiting for the battery to drain, I was able to restart the TF and get active responses to the touchscreen. Unfortunately I had performed a reset and wipe earlier so I am having to reload everything. I am happy to have a functioning TF again, but have serious concerns about this failure and this awkward repair method. Additionally, I have still not had a response from ASUS support from 5 days ago.
  6. mqureshi79

    mqureshi79 Well-Known Member

    I CAN'T BELIEVE THIS SH+T!!!!

    Had transformer for about a week when the problem in my OP happened. Got the new one on Thursday after returning to Tiger Direct... This morning, the same thing happens! Am really pissed!

    Am returning and getting the samsung... Fail asus. Fail.
  7. larrymg

    larrymg New Member

    Update: Tried every fix I could identify on the forums as I was also draining the battery as Isuguy suggested. After 4 days waiting for the battery to drain, I was able to restart the TF and get active responses to the touchscreen. Unfortunately I had performed a reset and wipe earlier so I am having to reload everything. I am happy to have a functioning TF again, but have serious concerns about this failure and this awkward repair method. Additionally, I have still not had a response from ASUS support from 5 days ago.
  8. satguyjim

    satguyjim Active Member

    I had the same thing happen to me on my first TF(which I returned). I have one coming from Amazon and the first thing that I will try to install (just in case) is my Bluetooth Mouse. Hopefully it will work fine till I get my hands on a KB dock (which I was planning to purchase anyways).
  9. Pro$pect

    Pro$pect New Member

    Hey guys,
    Received my TF yesterday and during the setup (@ wifi login !!) my touchscreen stopped.

    aarrrrggghhhhh! Waited for so long, and now this!!

    But there's good news. I used the method IsuGuy mentioned, and that is to totally drain de battery. It now works!

    Thank god I didn't charge the thing when I got it, cause it took me about 3 hours (I just kept turning the screen on). Hopefully this was a one time incident.

    *edit
    ASUS Holland just called to ask what the problem was (I mailed them yesterday evening).
    It's now 10:15 AM, great Job ASUS!

    I explained the problem and the solution.
    Apparently I was the first in Holland to have the problem, cause it was new to them.
    Then again the Transformer hasn't been available in Holland that long, so it's hard to say if it's a common problem.
  10. kukukakikakek

    kukukakikakek New Member

    does the "draining" method works? so the TF screen wouldn't stop responding anymore?

    i'm considering to buy the TF, but i read so many review about touchscreen problem on asus TF after installing 3.1 Android...

    i wonder if asus has fixed the problem already?
  11. clgwli

    clgwli Well-Known Member

    I only had the issue before 3.1 update. Since then it has never happened again. I do use the docking station a lot though which is what got my tablet working again in the first place. No sure if it has been fixed or not, but like I said I haven't had it happen nor has others I know who own the tablet experienced the same thing since 3.1
  12. kukukakikakek

    kukukakikakek New Member

    oh, thanks...

    so the problem wouldn't happen if i immediately upgrade to 3.1?

    but on other forum they say the problem happen after they upgrade to 3.1
  13. Tristosterone

    Tristosterone Member

    I had this problem with my Transformer TF101 recently. Every now and then it would slow down and the screen would stop responding properly.

    The only way to fix it was as others say to drain the battery.

    I have now managed to fix the problem by changing the input method in settings. It was set by default to use the ASUS keyboard method, but I changed this to use the Andriod one.

    Since doing this the tablet works like a rocket and the problem has not come back!

    Happy Dayz
  14. andrewappletre

    andrewappletre New Member

    Hi I have the Ases Eee Pad screen, but neither the touch screen nor the keyboard will do anything. I don't know how to remove the batteries and try a hard reset. Does anyone know a way of getting the tablet working again?

Share This Page