Support Unable to connect to home WiFi Router.

Discussion in 'Android Devices' started by LeonaDroid, Nov 29, 2011.

  1. LeonaDroid

    LeonaDroid New Member
    5

    Nov 29, 2011
    2
    0
    5
    Seriously Underpaid Software Developer
    Devon, UK
    Hi I'm new here, be gentle :)

    I've searched this forum and seen other phones with this issue, I don't know if its a general Android issue, or related to certain phones, so I thought I'd post this here to see if anyone has come across and or found a fix for it, its very annoying.

    The phone will sometimes not connect to my home wifi router, it see's it, it shows up the in the list, but if I long press and select connect, it just says Scanning.... disconnected, and refuses to connect to it.

    Yet other times it will connect automatically just fine.

    I have checked for other wifi signals and there are other 'neighbouring' routers around, but they are all on lower channels like 1,2 and I have set my router as far away as possible to them on 11. My Wii, PS3, HP Printer and Android 2.2 tablet, have no trouble at all with my router and connect fine, but the phone will not.

    I have tried restarting the router, that sometimes solves it, but then in the morning, we are back to not connecting again, I've tried deleting the wifi settings from the phone and putting them in again and password, that doesn't work either.


    There are no spaces in the SSID and I use WPA2 Protection.


    I have a Netgear DSG834 router if that helps.



    Any ideas?
     

    Advertisement

  2. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member
    53

    Feb 8, 2011
    389
    66
    53
    Social media coordinator at Sony Mobile
    In some of the cases that I've seen this type of issue one thing that did help is updating the router. For this you'd need to go to the manufacturer's website and follow the instructions on how to do this. I do hope this helps you.
     
  3. radiosw97

    radiosw97 Member
    5

    Dec 6, 2011
    6
    0
    5
    I tried the update on my siemens router but it kept dropping the connection. In the end I bought the latest Netgear N300 and perfect connection ever since. Hope this helps,
     
  4. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member
    53

    Feb 8, 2011
    389
    66
    53
    Social media coordinator at Sony Mobile
    So it was most likely a compatibility problem with your phone and that router. Glad is working fine though. :)
     
  5. radiosw97

    radiosw97 Member
    5

    Dec 6, 2011
    6
    0
    5
    Yes cheers think it was :)
     
  6. Cyverm555

    Cyverm555 New Member
    5

    Jan 1, 2012
    2
    0
    5
    Hi!
    Erm... I have a small problem with my phone's wifi connection as well.
    The wifi connection is alright at first, but after some time it starts to disconnect on its own, and weirdly reconnects without me doing anything (but watching it). I've already tried two different WiFi routers, and still both return the same results of automatic disconnecting and reconnecting. It's not too big a problem, but it can get a little irritating when you're doing something important and the connection just disappears on its own.

    Thanks in advance!
     
  7. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member
    53

    Feb 8, 2011
    389
    66
    53
    Social media coordinator at Sony Mobile
    Does that happen even when you are using the phone or when the screen goes off?
     
  8. lordpiti

    lordpiti New Member
    5

    Jan 11, 2012
    1
    0
    5
  9. LeonaDroid

    LeonaDroid New Member
    5

    Nov 29, 2011
    2
    0
    5
    Seriously Underpaid Software Developer
    Devon, UK
    Thank you for your replies, I have updated the routers' firmware, but that didn't make any difference.
    I guess the next step is to replace the router then?
     
  10. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member
    153

    Jun 14, 2011
    1,042
    151
    153
    I had a similar issue and resolved this via these steps:

    1. Restart router so the phone connects to the router.
    2. Log on the Market with the phone and download Wifistatic.
    3. Open Wifistatic and tap "Add Configuration" and then accept the auto setup.

    This may resolve you issue, it has worked for many but not all unfortunately.
     

Share This Page

Loading...