updated to 2.1, Google now German!Support


Last Updated:

  1. global2

    global2 Well-Known Member This Topic's Starter

    Joined:
    Mar 29, 2010
    Messages:
    107
    Likes Received:
    7
    Just did my OTA update to 2.1 on my new Droid, but my Google browser defaults to German language. Tried Google settings, Droid settings, can't seem to change. I even powered off and back. I used the Select Location in Google, but it can't seem to find my location, though I have enabled GPS location. For now, I have to scroll down and select Google in English option on the Google mobile home page every time I go to browser. Any help appreciated and has anyone else had this happen?

    Found a workaround: Opened browser, clicked Google in English at bottom of portal page, made it a bookmark favorite. The went to homepage, added the shortcut to the Favorite (Google in English), then trashed the original Google browser icon off the Homepage. Whew!! Not bad for a newbie with only one cup of coffee in me.
     

    Advertisement

Share This Page

Loading...