USB connectivity on Mac and Linux?Support


Last Updated:

  1. lotus49

    lotus49 Well-Known Member This Topic's Starter

    Joined:
    May 9, 2011
    Messages:
    1,510
    Likes Received:
    230
    I am having problems connecting my SGS2 to my Mac and Linux machines, which is particularly annoying bearing in mind the total lack of support for these two platforms (yes I know there is Kies Mini but it doesn't recognise my phone - thanks Samsung).

    When I plug my phone into a Windows 7 machine, the computer recognises it and I can manipulate files on the phone and SD card.

    When I plug it into my Mac, nothing happens. Aperture recognises that a camera is plugged in but cannot access the photos and there seems to be no other way of accessing anything.

    When I plug it into my Linux machine, it is recognised and I can see the contents of the root of /sdcard and the SD card but I cannot access the contents of any file or folder (all the folders show as empty).

    This isn't much use to me because I never use Windows :(. My main machine is the Mac and that's the one I'd really like it to work on but Linux would be better than a poke in the eye with a sharp stick.

    Has anyone else had any joy with this on a Mac or Linux computer? If so, what did you do?

    PS I have seen in several places on the net that the notification bar should have a "mount usb" option when plugged in but I don't get that. I just get the MTP Application filling my home screen.

    PPS Kies Air does work but it's pretty sucky and I'd rather have direct access to the device and the micro SD card.
     

    Advertisement
  2. akashibar

    akashibar New Member

    Joined:
    May 19, 2011
    Messages:
    4
    Likes Received:
    2
    Connect the galaxy s 2 to your mac, when the mtp screen shows up on your screen press the home button to clear it. Then go to applications, settings, wireless and network, usb utilities, uplug the usb from your phone, touch the "connect storage to pc" on phone , it will tell you to plug in back the usb, then your done.
     
    mtberic and lotus49 like this.
  3. lotus49

    lotus49 Well-Known Member This Topic's Starter

    Joined:
    May 9, 2011
    Messages:
    1,510
    Likes Received:
    230
    Excellent thank you. I haven't tried this on my Mac yet but it worked perfectly on my Linux machine. I'm sure it will work just as well on the Mac.
     
  4. mtberic

    mtberic New Member

    Joined:
    Oct 11, 2011
    Messages:
    1
    Likes Received:
    0
    You save my life! hahah, thank you very much!
     
  5. MJC UK

    MJC UK Well-Known Member

    Joined:
    Sep 3, 2011
    Messages:
    87
    Likes Received:
    4
    Yeah its the same on Mac. Not sure you have to plug it in the first time though? Im sure i just got straight to settings... hmmm
     
  6. computerandu

    computerandu New Member

    Joined:
    Jan 11, 2012
    Messages:
    4
    Likes Received:
    0
  7. Alex Taylor

    Alex Taylor Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    52
    Likes Received:
    3
    Which OS is your Android running? Android 3 devices cannot be connected to a Mac via USB (while other OS's can). You can check out SyncMate, this utility connects your Mac and Android (aven those running Android 3 OS) and syncs them.

    Hope this help.
     

Share This Page

Loading...