Why will my Samsung Galaxy S2 not connect to home wifi??Support


  1. roisinbg

    roisinbg New Member

    Hi,
    I got a new Samsung Galaxy S2 yesterday, and while the 3g internet is working fine, I cannot get it to connect to my wifi at home.
    I'm with Sky if that makes a difference?
    The phone connects to other wifi spots such as the cloud and the wifi in the Three shop where I bought it.
    I've tried turning it on/off, resetting the router etc but it just says 'authenticating' and then 'disconnected'. It doesn't even connect for a few seconds.
    Would really appreciate any help!
    Thanks

    Advertisement
    :
  2. WilfMoralee

    WilfMoralee Well-Known Member

    Is your router secured? If so, are you definitely typing the right password in?
    hpb1964 likes this.
  3. `sundance

    `sundance New Member

    I was having the same 'authenticating' and then 'disconnected' 5 seconds after trying to connect my GS2 with my Linksys WRT54GS router. The latest linksys firmware didn't work.
    Im now using router firmware from dd-wrt.com and its connecting and staying connected :)
  4. ironass

    ironass Well-Known Member

    From my experience, Sky routers are a nightmare to connect to at the best of times.

    The problem obviously isn't with your phone as it is connecting to other routers.

    I can only suggest throwing yourself on the mercy of the Sky Customer Service Department I'm afraid.

    Good luck!
  5. Slug

    Slug Check six! Moderator

    If you're using WPA/WPA2 security, check that the router is set to use AES encyption. I saw similar behaviour using TKIP with my Desire Z, and switching encryption protocol sorted it out.
  6. Junk10

    Junk10 Member

    I have the same problem with the wifi, and before anyone advises it is a router problem I have no problems with a Samsung Omnia 7, Iphone 3, two windows 7 lap tops and a playstation 3.
    My two work routers service 16 phones and it is only my Samsung Galaxy S2 that drops out or fails to connect.
    And yes, I have tried all the sleep settings along with hard resets, firmware updates and disabeling 3g.
    Great phone but something is missing in the WIFI department.
    babsy01 likes this.
  7. Danw1920

    Danw1920 Member

    I was having the same problems, it would constantly say Authenticating... Remembered.. Disabled and never connect. I have changed the encryption to WPA2 AES and it works fine now:D.

  8. mattyhall22

    mattyhall22 Member

    Turn your Sky router off at the plug for 15 seconds then turn it back on and try again. This is how I sorted mine out, it was driving me mad!! :)
  9. Slug

    Slug Check six! Moderator

    How many devices are connected to the router simultaneously, and are they using DHCP to obtain their network addresses? If the latter, how long is the lease time? I'm wondering if the pool of available IP addresses has been exhausted, meaning that the GS2 is unable to obtain one from the router.
    jorricks likes this.
  10. curi0us

    curi0us Member

    This worked for me. Great. Thanks..:D
  11. Junk10

    Junk10 Member

    For the test I only had the Omnia and CS2 on wifi, unsure of DHCP (builder not IT), using DLINK DIR-615, tried all the different security settings and bands on the router without any help, please see you tube.
    YouTube - ‪Samsung Galaxy S2 wifi difficulty vs Samsung Omnia 7‬‏

    Hi Everyone
    I received a new handset on Thursday and had a similar problems with limited or no wifi connection.
    I updated the firmware, which did help a lot.
    I also downloaded various wifi apps that identified the signals and a wifi fixer that locked the signal, band 11 that helped a lot.
    I purchased the best Netgear N300 Duel Band Modem Router and the phone is flying all the wifi apps have been removed and I can use it half way down the street.
    Unfortunately all my neighbors now live in my wifi shadow.
    The SGS2 has a very poor wifi reception compared to all my other devices and if it was not for the overall appeal of the device I would of returned it rather than accommodating it with expensive new wifi upgrades.
    I thank the eclipse_mint team at eBay for their time, patience and effort.
    Samsung please note the GS2 has very poor wifi reception
  12. Slug

    Slug Check six! Moderator

    First up, great idea with the video. A picture really is worth a thousand words.

    Tbh I don't know what's up. I could see a valid IP address on the GS2, so provided your router is on the same 192.168.0.* subnet the GS2's traffic should route fine. The fact that the Omnia works fine only confuses me further, as that rules out a straightforward misconfig on the router. The following is a bit of stumbling about in the dark hoping that I'll trip over the problem, so bear with me. :confused:

    Assuming this is your home router, can you disconnect all wireless devices, reboot the router (to reset all its inteface tables etc) then try connecting only the GS2? Once it's showing as connected, go into the router's browser config and look at "Network Settings" - there should be an entry at the bottom under "Dynamic DHCP Client List" corresponding to your GS2's IP & MAC addresses. "Wireless" under the "Status" tab should also display the GS2 as a connected device.

    Also check "Network Filter" under the "Advanced" tab to ensure that the GS2's MAC and or NAME hasn't inadvertantly been added to the "blocked" list. It's unclear from the user manual whether this actually prevents clients connecting or just blocks network traffic, so better safe than sorry for now.
    jorricks likes this.
  13. Junk10

    Junk10 Member

  14. mvchamp

    mvchamp New Member

    This worked for me too. Thanks a ton dude. :)
  15. androidexpat

    androidexpat Well-Known Member


    This is ok if you run into this problem while at home with your own router but is a major issue if one runs into this problem at all public wifi places.
  16. gaasim

    gaasim New Member

    The problem with Wi-Fi is present, but to me even more bizarre because Skype works without problems, but nothing else is going on the internet.
  17. Gurba

    Gurba Well-Known Member

    I had issues with a router/modem a while back. I could connect to the innternet with my to PCs with both cable and wifi, I could connect to the internet with at least to phones with wifi. However, after several months of use, I was suddendly unable to connect to the internet with my two BD-players with cable. The end of the story was return of the router/modem and get the old to-piece router and modem down from the attick. Works like a charm. :)
  18. gaasim

    gaasim New Member

    Solution, very simply manually enter all the IP address, subnet mask, default gateway, preferred DNS server and alternate DNS server, and must work perfectly.
  19. Marrr

    Marrr Member

    One thing I noticed as i had a bad signal which kept dropping is change the channel on the router. If you download and install the wifi analyzer app you can scroll through to a screen which will tell you what channel it thinks is strongest, change to this channel on the router and see how you get on. My connection is rock solid now.
  20. ri1030

    ri1030 New Member

    Just the same problem i have with my SGS2, have to try to re-enable my wifi few time to get it have access to internet tho its show connected.
    at first i tot its my linksys router DHCP problem so i tried static (I used static for my laptop too).

    Screen shot of my SGS2 screen.
    [​IMG]

    and i have do a manual verify that sgs2 show connected but in router it is not as it doesnt show in the ARP Table. after a few turn on-off of SGS2 wifi and the IP address dedicated to SGS2 show in ARP Table the I can internet on SGS2.
    [​IMG]
    Junk10 likes this.
  21. Junk10

    Junk10 Member

    Hi Gurba, router connecting without fail to:
    Palm treo pro, IPhone 3, Omnia 7, 2 X Windows 7 lap tops and Play station 3.
    So the problem is not with the router that is why this subject is with an android forum not a router forum.
    Thanks
  22. Junk10

    Junk10 Member

    Hi ri1030, thank you for your solution.
    But this is a pain if you use wifi other than your own, I believe it is a bug with the sgs2.
  23. Junk10

    Junk10 Member

    Hi Marr, thank you but like most solutions it a fix for the home wifi but the problem is that you can not change all the wifi you use to suit the sgs2.
    It is the phone that has the problem not all the routers.
  24. Junk10

    Junk10 Member

    For a fix it may work but I do not have access to all the routers I use and it would be a backward step in connectivity if the sgs2 needs to be manually configured, Samsung should just supply a cable
  25. ri1030

    ri1030 New Member

    yes I believe too. very frustrated have to turn on and off few time to get connected to wifi.
    sometime after leave it for a while it will can't go internet again, even tho it show connected.
    if Cyanogen Mod for SGS2 out, i will probably root it.
Loading...

Share This Page