Will not turn on, will not respond to chargerSupport


Last Updated: 2011-11-30 10:01:41
  1. swetm222

    swetm222 New Member

    Just this morning i grabbed for my liquid E its turned off, I tried to turn it on it won't respond when i try the power button. first thing i tried was take the battery out and put it back, still nothing no response form the phone at all, i tried to restore from instructions i read in another thread, I did power + vol down + camera, it vibed and showed droid next to "!" couldnt get any further, I havent been able to get back to this screen, any ideas? I dont wanna turf this fone.

    Advertisement
  2. Rayaz_XL

    Rayaz_XL Member

    Did you get any luck with this problem? My Liquid has the same exact problem I need help!!
  3. Monkeywoman

    Monkeywoman New Member

    its not the phone your gonna turf, its acer!
  4. gcombar

    gcombar New Member

    Did you solve this problem? mine is the same!:confused:
  5. dgallant

    dgallant Member

    Hey guys it's been a while since i was on here. I have acer liquid e for about a year, im on my second one the first one i had was DOA in one day. Anyways Fido replaced the phone with a new one.

    Now I have a new problem like these guys in here. It turns on without a problem get pass all the screens and then it says please need to plug in a charger i do that but it does not seem to work as it keeps asking me to plug in my charger. Plus the touch screen does not work also. Tried a hard reset but still does the same thing.

    Does anyone know whats the warranty on these phones?

    Thanks.

    Don.
  6. dgallant

    dgallant Member

    My phone is working, found out the phones carry a 1 year warranty. I had a month left, so i took it into fido and they sent it out for repaired. Got the phone back yesterday. The tech guy said they had to replace the Sim board and reflashed it.
    The phone was updated to v2.2 all is good so far.
  7. vagswag

    vagswag New Member

    hey guys, yesterday out of no where my phone started turning on and off just like that... the battery was low so i thought it was nothing and just left it... later on got home pluged it in was working fine charging then again while on charger started the same thing on and off... now it wont turn on.. assuming the battery is dead and wont charge.. the phones stock only thing is its unlocked for different carriers was originally fido..
    tryed the 3 button thing.. nothing tryed hard reset but nothing comes up on screen.. any suggestions would be great..
    just depressing perfect phone dont even play with it and now i can use it..
    can unlocking it have something to do with this problem?

    thanks corey

    oh and when i try the button thing it will vibe but no screen
  8. ftinessdvdatho

    ftinessdvdatho New Member

Share This Page