Xperia Neo WiFi problemsSupport


  1. cherry314159

    cherry314159 Member

    I have a brand new Neo. I first connected to my home's WiFi without problems.
    When I tried to connect to other WiFi networks, in many cases it fails by not
    being able to get an IP address. It then tries continously and never fully connects.
    When I went back home I can experience the same problem. I'm running 2.3.4
    and the WiFi sleep policy is set to never (original setting). The only way I can
    get it to connect again is if I power off the phone and power on again. And that
    works only in some places.

    I've seen similar problems reported by others. Some responses suggested
    changing the router firmware because of "incompatibilities". What's the deal
    here? I can't change the firmware in router's that I don't control. If there are
    issues then they should be clearly stated. Who has the problem and what is it?

    Note that other Android devices (from other manufacturers: LG, Samsung)
    work just fine in the same WiFi areas! This is something specific to the Xperia.

    I'm actually kind of shocked the such a problem even exists. SE QA must have
    some real issues to let this kind of problem out in the field.

    Advertisement
    :
  2. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    There
  3. cherry314159

    cherry314159 Member

    It is completely unreasonable to request resetting or upgrading a router. In most cases this is out of one's control. More importantly, this does NOT happen with other android devices or laptops! I have now tried on many private and public WiFi networks and it's annoying to
    have to turn off and on the device to see it works or not.

    I have to conclude that SE has put out a very buggy release and trying to blame it on other devices. Can you just list the technical reasons for these failures? Is it possible to downgrade to a release that has WiFi working? I can't believe your QA dept can allow a release in such poor condition.
  4. sakthiananth

    sakthiananth New Member

    Hi there,
    I own xperia neo v i experiencing lot of signal barrier when i connect to my office WLAN, One of colleagues own HTC explorer that works good with very good signal strength even faster when compare to neo. what i suppose to do for fair signal strength guys
  5. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    @cherry314159 - The upgrading of the routers firmware is simply one fix, there are many others that are not as intrusive. Given the specific problem you have this may be solved by simply installing Wififxr from the market.

    @sakthiananth - Can you elaborate on what you specifically by "experiencing lot of signal barrier" and I will see if I can offer a solution for you.
  6. cherry314159

    cherry314159 Member

    Is it possible to install an older version of the firmware?
    Specifically, I would like to install the version that was used
    to pass WiFi complicance:
    http://certifications.wi-fi.org/pdf_certificate.php?cid=WFA11196
    Clearly, the version that was shipped (2.3.4) is not compliant;
    the certificate does not state the version number.

    I do have wififxr install and it does help in some cases, but not
    all. I've made sure that the routers I control don't use channel 11;
    that helps as well. Of course, I can't change routers I don't
    control.
  7. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    You can but as this involves using third party tools to modify the firmware it is unfortunately something I can not assist with. However other people on here should certainly be able to assist with this.
  8. pzw

    pzw Member

    This problem seems to be an interoperability issue between Draft N and Standard N, devices and routers. Had this problem this morning; the only way I could resolve it was to switch from a Standard N router, to an older Draft N router I had laying around.
  9. israel batalha

    israel batalha New Member

    Troca do flex gt- c3500 como trocar
  10. Deniel

    Deniel New Member

    Hi All,

    let me inform you about one nice finding I just revealed with my xperia neo.
    I have the newest version of software running on my Neo and brand new router from ISP. I had problem to access internet via wifi even though my Neo is paired with router. Means: correct pre-shared key, no MAC filtration on router, correct channel etc. (another devices - like phones laptops had not any problems with internet and connection was working fine). I was using authentication type: WPA2-PSK and encryption: AES

    what I discovered:

    authentication type: WPA2-PSK and encryption: AES - paired with router (Neo MAC visible in MAC-address table) but no internet access

    authentication type: WPA2-PSK and encryption: TKIP - no problem anymore :)

    It looks like some problem with AES encryption. But this is question for developers and vendoooooors :)
Loading...

Share This Page