1. Download our Official Android App: Forums for Android!

General Cannot access contacts

Discussion in 'Android Devices' started by kgoyankees, Jun 6, 2016.

  1. kgoyankees

    kgoyankees Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jun 28, 2014

    Jun 28, 2014
    6
    0
    5
    Male
    Phoenix AZ
    I received new phone and before Sat I was able to open and add contacts to the contact app. As of Saturday it asks me for permission to allow contacts access your contacts. I hit allow and then it says I disabled a permission. I checked all permissions and none are turned off. I went to Verizon Corp. store and they said same thing that no permissions are turned off. Has anyone else had the same issue and if so is there a fix? I cannot view or add contacts to my contacts app
     

    Advertisement

  2. rdsok

    rdsok Android Enthusiast
    Rank:
     #256
    Points:
    53
    Posts:
    279
    Joined:
    Feb 24, 2010

    Feb 24, 2010
    279
    70
    53
    Before you do anything that you think of or that may be suggested... First make certain you have your contacts already backed up.

    If they are being saved to your Google account... Log onto your account with a standard computer and go to the Google Contacts to ensure they are all there. If they exist there... that should work as a backup... if not or you wish to make doubly certain you are safe from loosing your contacts...

    Open the Contact app you are using and export your contacts to a file. Then copy that file to a computer or onto your Google drive ( if you have an account of course ) or somewhere in the cloud that you can get to later if needed to restore.

    Once you are certain you have a backup plan... then reset the Contact app and clear it's cache. If your contacts are in your Google account... resync your account and it should repopulate your Contact app. If your contacts were not in your Google account, import them from the backup you made earlier.

    If you use a different contact app than the default, the instructions should still be similar but may have minor differences.
     
  3. kgoyankees

    kgoyankees Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jun 28, 2014

    Jun 28, 2014
    6
    0
    5
    Male
    Phoenix AZ
    Thank you and my contacts are in there. When I go to view those contacts in the contacts app or when I go to add a contact from the phone is when I get the attached request then message saying that I have disabled a required permission. I have gone into every app that requests an enable of contacts and still does not work. I wonder if the phone needs to be rebooted?
     

    Attached Files:

  4. doogald

    doogald Android Expert
    Rank:
     #52
    Points:
    483
    Posts:
    6,699
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,699
    1,930
    483
    I'll start this by saying I don't have a Marshmallow phone, so I can't check this myself.

    In addition to looking at the permissions for the Contacts app in settings / apps, did you also look at the permissions for "Contacts Storage"? Maybe that one somehow had permission explicitly denied for contacts.

    Do you have any third party apps in settings / security / device administrators? It may be that there is some security app that is blocking access to contacts for some reason.
     
  5. Thom

    Thom  
    VIP Member
    Rank:
     #22
    Points:
    1,318
    Posts:
    11,959
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    11,959
    4,939
    1,318
    Male
    Software Developer
    Keene, NH USA
    Try a test run in Safe Mode disabling all apps that were added without uninstalling them?

    ... Thom
     
  6. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #2
    Points:
    4,238
    Posts:
    36,798
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    36,798
    35,065
    4,238
    Male
    IT
    Pennsylvania
    Go to menu>settings>apps and scroll to contacts. Tap contacts>permissions and see what's turned off. FYI I have storage off for contacts by default and it has never given me a problem adding them. permissions_contacts.png
     
  7. kgoyankees

    kgoyankees Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jun 28, 2014

    Jun 28, 2014
    6
    0
    5
    Male
    Phoenix AZ
    Interesting my Droid on Marshmellow does not have a permission for contacts within the contact permission section
     
  8. Thom

    Thom  
    VIP Member
    Rank:
     #22
    Points:
    1,318
    Posts:
    11,959
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    11,959
    4,939
    1,318
    Male
    Software Developer
    Keene, NH USA
    Mine does (Turbo 2 Marshmallow) and has only Contacts and Phone enabled.

    ... Thom
     

Share This Page

Loading...