1. Download our Official Android App: Forums for Android!

Support cannot connect to internet on Memopad HD7

Discussion in 'Android Devices' started by gabddb, Jan 1, 2014.

  1. gabddb

    gabddb Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    2
    Joined:
    Sep 24, 2013

    Sep 24, 2013
    2
    0
    25
    Asus Memopad HD7 stopped connecting to internet.
    "obtaining IP Address"....signal strength ..excellent.....65Mbps
    trying to connect to a Belkin N Wireless router
    flashes to .."avoided poor internet connection"

    Tablet connected flawlessly up until several days ago

    wireless icon in upper right taskbar has an x on it that I cannot seem to remove

    HELP!

     

    Advertisement

  2. BSydz

    BSydz Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    951
    Joined:
    Mar 31, 2012

    Mar 31, 2012
    951
    944
    163
    The Mitten
    I have a similar issue, but mine is router related. Every few days I have to reboot my router, this a known issue with my router. There is also a known compatibility issue with some routers and some android devices. I can't remember the specifics so this may not apply to you.

    So, first try to restart the tablet. Then if that doesn't help, restart the router. Let me know how it goes. Good luck!
     
  3. MonkeyNews

    MonkeyNews Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 24, 2014

    Jan 24, 2014
    1
    0
    5
    Hi there, been looking everywhere for an answer other than actually contacting asus. My wifi connection was working perfectly until this morning, simply assumed it was an issue on my end and headed out the door. The wifi then didn't work at either my workplace or my fathers house, so i'm assuming it's an issue with the tablet.

    I haven't changed any settings, it just says 'obtaining ip address', and will eventually crop up with 'avoided due to poor connection', even though it's running at 67mbps and my phone/laptop are connected with no issues.

    So...any help chaps?

    Edit: I have restarted both the device and my wifi.
     
  4. jacobbrandon19

    jacobbrandon19 Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    93
    Joined:
    Apr 18, 2012

    Apr 18, 2012
    93
    2
    16
    Are you the network admin? Is it possible that your network's subnet mask has been changed to limit the number of devices allowed to connect? Have you tried a different type of security on your home router to see if that works, or turn off security to see if that works? If it does, you could always use mac address filtering instead of a security key.
    Aside from restarting both devices, that's all I can think of. Good luck.
     
  5. pacswoman

    pacswoman Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 15, 2012

    Jan 15, 2012
    1
    0
    5
    I have also had the same problem today, cannot get my Asus Memopad to connect, have excellent signal strength but keep getting the "avoided poor internet connection" when attempting to connect to my WiFi.

    The way I have managed to resolve it after trying all the above suggestions with no resolution, was to change my config for my router from DHCP to static IP address, this then connected straight away and so far seems ok.
     
  6. Hoib

    Hoib Newbie
    Rank:
    None
    Points:
    15
    Posts:
    16
    Joined:
    Nov 20, 2010

    Nov 20, 2010
    16
    0
    15
    Can I just chime in here quickly. This may not be the answer, but... this fixed my similar issue.

    Look at the SSID you're trying to connect to. It's at home, right. And what is its name (SSID). If you've left it at it's default (ex: "Linksys" or "netgear" or cisco" or ???) then what happened to me might be happening to you. Here's why....

    If you've left router#1 at it's default SSID and say you took your device to someone's house. And in that house (or a house nearby) that owner has also left it at the default, when you visit, your device sees the SSID on router#2 and says, "Hey, there's an SSID I know, let me connect to it." And say for instance that it does succeed - it remembers those successful connection values. Now take that device back near router#1. It's going to look for that SSID, it will see it in the selection list and attempt to connect to it -but- with the old previous values from router#2, MAC address, sub-net, IP assignment. And you get, the result you're seeing. Connection may not even be possible.

    What I did to cure this: Renamed the router to a unique SSID. Should have done that I know on set up. Now, say you don't want to and can't change SSID on router#1. OK, go outside the building where router#1 sits. Get completely away (down the driveway or street and distance the device from router #1 and the default SSID. Be watching because someone else might have left their router open and with the default SSID you're trying to escape from. Router #1 will still appear but not in range. That's what you want in order to do the next step which is: Press to connect -BUT- hit Forget. This clears the offending values and permits you to start fresh - with no values. Re-introduce your device to router#1.

    If you do this while still in range of router#1, it may not expunge the values stored. That's why the best thing to do is get some distance, so the device can't "see" anything with that SSID.

    It's worth a try, right?

    H
     
  7. bevraige

    bevraige Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Apr 15, 2014

    Apr 15, 2014
    2
    1
    6
    Hi I have the same issue and as far as I can see after searching is it seems to be a common problem for this tablet but I have yet to see a real solution. I know its not network and has nothing to do with anyone's router. I have tried everything I have found that people suggested. Finally, I did a factory reset. This worked for a day. I reloaded all my apps etc. and then tonight I was at home watching Netflix on my tablet when I lost connection and am again getting the same code "avoided poor connection" in my case I was connected to a free att hotspot earlier in the day and then had the issue at home on my own network. I would really like a real answer but I haven't heard back from Asus. It won't let me go static or change any options.
     
    Fastguy007 likes this.
  8. bevraige

    bevraige Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Apr 15, 2014

    Apr 15, 2014
    2
    1
    6
    I talked to someone in Asus support. After they asked if I reset my router and I of course answered yes, they said I need to send it in for repair. I at first thought it was an issue with this tablet but I have seen many other android devices with the Jellybean 4.2.2 having connectivity issues. The difference is this tablet doesn't allow very many setting changes to get around it. SO now I'm thinking I should find a fix for the android software? I'm not sure.
     
  9. droidroll

    droidroll Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 28, 2014

    Apr 28, 2014
    1
    0
    5
    I had the same issue, and tried many of the suggestions of the above posters, to no avail. What worked for me (and, note that I use the AT&T Uverse internet service at home, with a static IP address, so I'm not sure whether it will work for all routers/providers or those with dynamic IP addresses) was this:

    Go to your home computer and get into your wifi settings (for me, with AT&T, it was a matter of inputting "192.168.1.254/" into my browser in order to access/see my router settings). Specifically, look at what the IP address, default gateway, primary DNS, and secondary DNS are. Leave that screen up on your computer, because you'll need it in a second:

    On your Asus MemoPad HD7, click on the wifi icon, then click on your home network. The options are "forget network" or "modify network" or something like that. Choose "modify network" and go to "advanced network settings" or something like that. In the IP address, default gateway, primary DNS, and secondary DNS fields, replace the numbers prepopulated in those fields on the tablet screen with the numbers that show in the corresponding fields on your computer screen. Your tablet should now recognize the internet connection.

    Good-luck! Please let me know if this works!
     
  10. Fastguy007

    Fastguy007 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 15, 2014

    Jun 15, 2014
    2
    0
    5
    Thx, this is working for a week now! So the factory reset works! And you don't have to loose any app or data! (open settings of google play or amazon app store):)
    Although i didn't install all my apps! ( You'll never know which app ruined the connection or maybe my memory was getting full!)
     
  11. Fastguy007

    Fastguy007 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 15, 2014

    Jun 15, 2014
    2
    0
    5
    It still works ! I just didn't install a certain app which I till this day haven't installed. (App connected to my network drive ( USBdrive connected to TPLink-router))
     
  12. Meerky

    Meerky Member
    Rank:
    None
    Points:
    16
    Posts:
    51
    Joined:
    Jul 12, 2013

    Jul 12, 2013
    51
    2
    16
    Midwest USA
    I've had my Asus HD7 tablet only about a month or so and this problem hit me last night. After constantly connecting for over a month, it just kept trying to obtain an IP address or said it avoided a poor internet connection (even though while connecting it said signal strength was excellent). I use a whitelist with a password, but disabled it as well and no change.

    I was able to connect to my home wifi by assigning a static IP as suggested above. Does this mean though that the tablet won't be able to connect to a public wifi anymore? If that's the case and this is a common recurring problem (and not an issue with all tablets), I might opt to just return this tablet for a better one.
     
  13. TheBattman

    TheBattman Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 6, 2014

    Nov 6, 2014
    2
    0
    5
    I've had my ASUS MeMo Pad HD7 and have had several issues - but the latest being the above original post's issue - It tries to connect - "obtaining IP Address"... then after a while, "avoided poor connection". Yet this with ANY and ALL WiFi access points.

    At home, my "fix" was to assign a static IP address to my ASUS device. But that doesn't help when trying to hit public access spots or other networks where I don't have any administrative permissions... This is insane. It was a sudden change - went from wifi working all the time to not at all...
     
  14. colinkhalid

    colinkhalid Lurker
    Rank:
    None
    Points:
    25
    Posts:
    1
    Joined:
    Dec 7, 2014

    Dec 7, 2014
    1
    0
    25
    Male
    I have an ASUS Memo Pad 8 and experienced the same problem of connection to wifi access points first working and then refusing to connect. The problem does seem to be related to the signal strength, I can now connect to any of my home / work access points if I put the tablet so close that it is touching the router. If I do this it connects every time and stays connected if you move away.

    It seems that the "avoid poor internet connections" feature is preventing the connection from happening. Unfortunately the is no option that I can find to turn it off, ( at least in the wifi>advanced menu on the Memo Pad 8)

    However like Meerky I needed to set the i.p address, subnet mask, default gateway and DNS manually to get internet connectivity. Which is strange since the settings obtained by the tablet from the routers DHCP server are the same as those I entered manually. This worked the first time I connected manually but on subsequent connections it failed.

    Just like to add that to prevent the connection from dropping I had to turn off wifi optimization

    Will post any futher findings
     
  15. asusfanatic

    asusfanatic Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 31, 2014

    Dec 31, 2014
    1
    0
    5
    Male
    i have the same problem today, but i can´t change the IP address.
    Someone have another idea for this problem?
     
  16. Jenko1447

    Jenko1447 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Jan 1, 2015

    Jan 1, 2015
    1
    0
    15
    I just got mine to connect by turning off the DHCP and setting a Static IP address. When I check my wireless Access Point, it was trying to assign an odd IP (169.254.1.xxx) instead of a regular one (like 192.168.1.xxx). I only changed the Static IP Address and left everything else same.
     
  17. Onktebong

    Onktebong Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 16, 2015

    Jun 16, 2015
    2
    0
    5
    What worked for me was to clean out the files under ...
    /data/misc/dhcp
    ... and then restarting the tablet.
    Hey presto!
    Note: My Asus MeMO Pad 7 HD (ME173X) is rooted. And I guess this won't work on an unrooted device.

    The last time I encountered this problem I had to do a factory reset to overcome this glitch. I literally spent days trying to find a better solution. Please let me know if this works for you. Good luck!
     
  18. stratop80

    stratop80 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 24, 2016

    Oct 24, 2016
    1
    0
    5
    Male
    Found this glitch yesterday.
    Your solution makes sense, and ¡¡ Yes, it works !! :)
    Thank you!
     
  19. Aminuddin

    Aminuddin Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 13, 2016

    Dec 13, 2016
    1
    0
    5
    Male
    Can you please advice how to find /data/misc/dhcp
     
  20. svim

    svim Android Expert
    Rank:
     #41
    Points:
    608
    Posts:
    3,660
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,660
    2,717
    608
    Illinois
    You need to have a rooted tablet to access anything in /data. At that point you can use a file manager app or terminal app. But if your Asus Memo isn't rooted read through some of the previous suggestions in this thread. Or start your own detailing what kind of problem your having (the more details you provide the better) and what you've tried to do to fix it.
     

Share This Page

Loading...