1. Check out our companion app, Forums for Android! Download from Google Play

Root Droid Pro Bootstrap & Clockwork Mod

Discussion in 'Android Devices' started by mahst687, Dec 8, 2010.

  1. mahst687

    mahst687 New Member
    Thread Starter

    Dec 8, 2010
    I successfully bootstrapped and was able to enter clockwork recovery. Here's some additional info:

    Droid X bootstrap appears to work... can anyone verify this other than myself?

    You can enter Clockwork Recovery only through the Reboot Recovery button in the bootstrap program.

    I successfully backed up my Droid Pro with Clockwork version which runs from the bootstrap. I have not tried a restore to see if it works... has anyone?

    I have tried to rom manager and flash a new recovery. Upon restart, phone tries to enter clockwork recovery but freezes on load. I tried to get the phone flashed with the same recovery that is in the bootstrap program but no success.

    This is where I am at. If anyone can share any new info, please do... I will continue on my side to try different things. I am also trying to get koush and tbh involved to help without success so far.

    Thanks Everyone!


  2. bigdinosaur

    bigdinosaur New Member

    Dec 8, 2010
    Haven't been able to boot into Recovery, but the Droid X bootstrapper successfully installs. Clockwork also flashes a recovery, but gets stuck at a black screen when trying to boot into recovery. Also to note, the guys behind the Fission Droid X roms list the Droid Pro under their compatability -- I private messaged them and said they are just waiting for an SBF to leak. Heres to hoping!
  3. kingtks

    kingtks New Member

    May 27, 2010
    so far so good
    download and installed z4root from forum
    downloaded and installed droid 2 bootstrap from forum
    then flashed droid 2 recovery from clockworkmod. so far so good.
    doing a backup now. havn't tried a custom rom yeet
  4. frankbonatelli

    frankbonatelli Well-Known Member

    May 13, 2010
    Globally employed
    Kelowna, BC Canada
    Had my Pro for two hours. Rooted, Bootstrapped, Deodexed deleted all the bloat ware deleted default home & gapps. ADB pulled framework-res and manipulated the notification bar color, changed the display information images (3g wifi BT) for ginger bread ones. So far very fun to tweak.
    A note on Bootstrap I am able to enter clockwork via reboot push n hold volume down and power button. Hold then down until the "M" fades away then for 2 seconds more. It will then pop into the clcokwork screen. I think its trying to enter the fastboot hBoot screen and of course this is locked so I get tossed into clockwork. Works every time.

    I also have the latest OTA update installed.
  5. Laaambert

    Laaambert New Member

    Feb 13, 2011
    i apologize in advance for being completely clueless about this stuff and having to post this but i finally got brave enough to run the permanent root option via z4root on my droid pro. but now what do/should/could i do? i came from an HTC TouchPro 2 and had that thing tweaked harder than a meth-head that just won the lottery. but i don't know where to proceed from here. can't find clockworkmod or bootstrap in market, if there is another forum that i havent found yet (i look up one thing and before you know it i have 7 other tabs open taking me in 13 different directions). i just wanna have fun with my phone.

    any help is appreciated for this NOOB.

  6. thememonster

    thememonster New Member

    Sep 24, 2010
    Hi there. I'm trying to boot into recovery from my droid pro. I tried what you suggested which is hold volume down + power button until 2 seconds after "M" fades away. These steps only let me reboot normally without the clockwork recovery screen. Can you help me with this, please? Thanks!
  7. Bugly

    Bugly Well-Known Member

    Jan 30, 2011
    VW mechanic
    Tacoma, Washington
    so.... what was the concensus? Does the droidx bootstrap work on this device?
  8. chinkster

    chinkster Well-Known Member

    Feb 7, 2010
    through my research on here and xda, people have used droid2 and droidx bootstrap...i am in the same boat as you...why don't they have a droidpro bootstrap!
  9. krazykaigh

    krazykaigh Active Member

    Mar 14, 2011
    I have the Droid Pro. It is on Verizon network. I am a Cricketeer (haha - that is a copywritten phrase - by who... BY ME. So donate to me whenever you say, type, think, or HEAR it)


    I Rooted phone with Superoneclick, this is after the April or May (Verizon or Motorola) update that disallows z4 or easyroot or dorootwin (NONE OF THEM WORK NOW... Don't believe the hype. As of August 25, 2011, I could only get SuperOneClick to root my Droid Pro)

    I tried using RomManager (even bought Pro) but I couldn't get it to go into recovery mode, HOWEVER; I did not do what I did after using Droid2Bootloader.apk and I suggest someone try the key combo first and if that fails do the Droid2Bootloader (Maybe the Droid X Bootloader may work - didn't do key combo with that either)

    After installing Droid 2 Bootloader, I hit the Bootstrap Recovery Button (on top). I allowed it SuperUser permission. Then I hit the "Reboot Recovery"

    Okay follow me:
    The phone shuts down, goes black - At that moment I held the:
    Volume Down + Power buttons - how long you may be asking, I HELD THEM UNTIL THE Motorola "M" disappears and at least two seconds aftwards and VOILA I am in Clockworkrecovery!!! I did a nandroid backup and now I am in my phones HEAD!!!! YESSSS

    I will flash cyanogen tonite and see what happens!!!
  10. bsweetness

    bsweetness Well-Known Member

    Sep 2, 2010
    It's true that those options you mentioned don't work for root, but in addition to SuperOneClick, aRoot works as well. But if you don't want to hook up to a computer to root/unroot, the Gingerbreak 1.2 works for rooting/unrooting directly on the phone with the last version of Froyo installed (it won't root the Gingerbread update, just Froyo).

    Have fun with Cyanogen. I liked it, but too many things were missing for me to keep it on my phone. Once they get everything worked out on the Pro, then I'll give it another look.
  11. kathyo894

    kathyo894 New Member

    Feb 6, 2012
    When I rooted my Droid Pro, I mistakenly deleted 3 of the "Authenticator" apps through Titanium Backup. Now, my contacts app "force closes" when I attempt to add a new contact or modify an existing contact. I realize this was a mistake and that I can't restore these system apps through Titanium Backup. So, I'm trying to fix my phone.

    I was told to make a nandroid backup using CWM -- the only app I saw that would do this was ROM Manager. Are there others? I also downloaded Bootstrap for Droid2.

    Using ROM Manager, I flashed CWM Recovery, and it did install. But, when I tried to make a backup, nothing happens - it reboots but there is not backup file available in the "Manage & Restore backups." It seems like this has happened to other people, but I don't understand how to fix it.

    Also - I do not understand how to use the Droid Boostrap app. I started it and pressed Reboot Recovery and it booted into a recovery mode, but I wasn't sure what to do from there. When I turned the phone off and then back on it was normal again. What is this about volume down and power??

    I am sorry, but I"m really new to this and will need terms to be defined. I would really appreciate any help I can get and would honestly be willing to pay someone a few bucks to walk me through the process step by step.



Share This Page