1. Are you ready for the Galaxy S20? Here is everything we know so far!

Eris wifi issues

Discussion in 'Android Devices' started by ck_csra, Dec 6, 2009.

  1. ck_csra

    ck_csra Lurker
    Thread Starter

    Earlier today I exchanged my Moto Droid for an Eris. When I got home, I tried connecting it to my wifi network and started having some issues. My SSID didn't show up in the wifi settings page. I tried to manually enter my wifi settings and that didn't work as well, reboot the phone, pull the battery, search forums, but had no luck finding a solution.

    I have a Linksys WRT-160N wireless-N router. The router is currently set up with a network mode as "Mixed" as I have both wireless-N and wireless-G devices connecting to the router. While troubleshooting, I changed the router's network mode to "Wireless-G only." The moment I did that, the Eris could see the SSID and connect. I also tried "Wireless-BG," and the Eris connected with no problems.

    I had no issues with the Moto Droid, and am kind of regretting switching now due to this issue. Has anyone else experienced problems getting their Eris to talk to a mixed-mode wireless-N router?

    1. Download the Forums for Android™ app!


  2. cmassey3

    cmassey3 Lurker

    I have the same router and the same problem.
  3. JackButler

    JackButler Member

    I had issues with logging in successfully to my router...from the Market I got WiFinder and it synced up fine, though I don't use it:>)
  4. ck_csra

    ck_csra Lurker
    Thread Starter

    Thanks for chiming in. At least I know it's a problem not isolated to me.

    I also tried the WiFinder app, and still couldn't see the SSID in mixed mode.
  5. dg370

    dg370 Newbie

    I have the Linksys WRT350N here and set to mixed mode. I could not connect until I enabled SSID broadcast. When I disable SSID broadcast the ERIS losses connection.
  6. gener1c

    gener1c Member

    I use a d-link dir-655 and have the same issue. It just seems the eris can not connect to any ssid unless it is vissible. I also tried it on and old linksys wrt54g and ended up with the same results.
  7. AwesomeIT

    AwesomeIT Well-Known Member

    I don't have my Eris yet because I just ordered it today, but here is something you can try. I'm not sure how indepth the WIFI settings are, but if you're not broadcasting your SSID I would recommend checking for a setting on the Eris that tells it to connect even if the SSID is not broadcasting. Windows has this option in its' native wireless manager or it could be that there is no setting for this and the Eris just doesn't connect to a wireless network that doesn't broadcast the SSID or it could also be the firmware on your Linksys router. You can check the Linksys website to see if there are any updated firmware for your router, and if so you can update the firmware through the web interface for the Linksys router.

    Another option is you can try DD-WRT. It's an open source firmware alternative for many routers, including most Linksys models. A lot of tech savy individuals like DD-WRT better (some just want people to think their cool because they use the super secret DD-WRT firmware n00bs don't know about) but it's worth a shot if you really want to keep the Eris and use it on your network without broadcasting the SSID and you've exhausted all other solutions. Or, you can pick up a different model router and test it out.
  8. dg370

    dg370 Newbie

    The ERIS does not have the ability to select an option to connect 'even if the SSID is not broadcast'. I previously used a WinMob which had no issues connecting.
  9. ck_csra

    ck_csra Lurker
    Thread Starter

    Thanks for the tips. The SSID on that router was set to broadcast. I did check the firmware and noticed it did need to be updated. After updating, it still didn't work.

    I would LOVE to put DD-WRT on it, but I have an incompatible version. There are 3 or 4 versions of the router out there, and of course I have the only router that you can't put DD-WRT on. /sigh

    My 2 concerns:
    *it was a problem with my Eris and I would need to swap it out before my 30 days are up
    *when I needed to connect to wifi (say on a plane, or a friends house) I wouldn't be able to or couldn't trust that it could

    After taking it to work and it connecting fine on wireless-N, and trying it at a local coffee house, I'm going to chalk it up to being unlucky and having a POS router, especially after someone else confirmed it.
  10. Kevo

    Kevo Newbie

    Just got my Eris today and wanted to chime in and say I am having the exact same issues. I have a Belkin router that is B+G+N and broadcasts SSID but for whatever reason my Eris cannot pick it up. The frustrating thing is that it still finds my neighbors wireless networks, which happen to all be password protected.

    I also have issues with the Eris being stuck in 1X and not 3G. I live in a major metropolitan area where it should absolutely get 3G. 1X is really, really slow.
  11. itsglorious

    itsglorious Newbie

    The issue regarding being stuck in 1X is being fixed in the OTA update that is happening this week, iirc.
  12. ck_csra

    ck_csra Lurker
    Thread Starter

    I hear ya. Does taking the router out of mixed-mode work for you?

    Does anyone know of an official way to report this as a bug? Would it be best to contact HTC or Verizon?
  13. erisuser1

    erisuser1 Android Expert

    It seems to me that at least you have an acceptable workaround without any further effort.

    If you use your home wireless network mostly for internet access, it is unlikely that your DSL/Cable/Optic link is faster than WiFi-G; in which case you won't notice a difference in application speed because the wireless router is not the rate limiting factor. WiFi-N isn't doing anything for you in that scenario, except perhaps being a little more robust in congested areas (where there is lots of channel interference from nearby APs).

    If you are streaming video between wireless clients in your home network, or sharing/printing very large files between wireless machines on your LAN, then perhaps you would notice a difference in that case.

    I guess the iPhone 3GS doesn't do WiFi-N, either, for what that's worth.

  14. squirrellydw

    squirrellydw Member

    I use an Apple Airport Extreme and it is in a mixed mode and mine works fine. I did however have to type in the SSID name since I have my set to not broadcast. Once I type in the correct name (case sensitve) it worked fine.
  15. Fathawk

    Fathawk Newbie

    My Eris connects fine to my network.

    Try going into the router UI and changing from using WEP to MAC filtering and add your devices plus you phones MAC's to the "Allow" list. My phone connects instantly when I turn the Wi-Fi on.

    Most router UI's default IP is

    From there you can config the router to MAC filter.
  16. jaboda79

    jaboda79 Member

    My Eris connects fine to my home network, but it will not find my work WiFi. My co-workers iPhone works fine, but I just can't get it to work. Tried manually entering the IP to no avail. I know when he connects, it redirects him to a seperate page that I'm not seeing. Is there an app that can help?

    I also tried to manually enter the redirect page, but no go.
  17. slhenderson87

    slhenderson87 Newbie

    I came to this thread for the same issues. However, I had a router at my nieces that broadcasting. Two other people at this party had ipods and had no trouble connecting. I couldn't even see the router. Ironically, I could see other wifi networks in the neighborhood that the ipods couldn't see. WTH is up wth that?
  18. JoeBCC

    JoeBCC Lurker

    i also have this problem, with the belkin n+ router running in mixed mode
    when i change it to only b/g it works fine, but i need the wireless n for my computer...any suggestions?
  19. timmywa

    timmywa Well-Known Member

    I have wrt54gs at home with dd-wrt and my Eris works without it broadcasting the ssid. I just had to manually enter the info in Eris settings. My brother has a d-link N router and my Eris would connect and get signal (on G), but the actual data transfer wouldn't work all the time. I never had the chance to mess with his router. My laptop has N and it was doing great on that router so who knows.
  20. slhenderson87

    slhenderson87 Newbie

    Like I said, my niece's router was broadcasting. The other phones were i-phones, not ipods. They could see the SSID and connected. I couldn't even see it even though I could see other networks further away. They couldn't see these other networks. I was about ten feet from the router I couldn't see.
  21. Reloader1

    Reloader1 Lurker

    I have a WRT54GS...any suggestions on router settings?..can see it, but cannot connect.

  22. morozovsv

    morozovsv Lurker

    I have different issue, i can find my belkin router, its wap protected, i type in my password and it wont connect to it.
  23. sean connery

    sean connery Newbie

    I have a netgear and my Eris connects fine but for some reason it will lock up my router and make it reset. some times it's fine but other times I get the reset problem. my laptop and iPod touch work fine and don't cause the reset but for whatever reason my Eris does. come to think of it, Every HTC phone I've had does it. any suggestions ?

    Sent from my Eris using Tapatalk
  24. doogald

    doogald Extreme Android User

    Have you guys checked to see if your routers are the latest firmware release? Quite often the manufacturers update the firmware to fix bugs.
  25. sean connery

    sean connery Newbie

    yes, that was the 1st thing I did then I changed the channel but it still does it.

    Sent from my Eris using Tapatalk

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date

Share This Page