1. Are you ready for the Galaxy S20? Here is everything we know so far!

Flash custom ROM or TWRP to HTC One M8

Discussion in 'Android Lounge' started by M_Eight, Jun 6, 2020.

  1. M_Eight

    M_Eight Lurker
    Thread Starter

    Hello forum,
    im struggling on this for a while. Sadly i cant find anyone with the exact same problem as I am facing.
    I'm running Ubuntu and installed adb and fastboot. I have NOT installed any drivers for the HTC.

    First I try to sum up my situation:
    Ive (successfully?) unlocked the HTC One M8 via the HTC websites unlock token.
    Then I tried to flash twrp:
    " fastboot flash recovery twrp-3.3.1-0-m8.img
    < waiting for any device >
    target reported max download size of 800000000 bytes
    sending 'recovery' (20202 KB)...
    OKAY [ 1.847s]
    writing 'recovery'...
    (bootloader) HOSD CL#820405
    (bootloader) start@1
    (bootloader) recovery@100%
    (bootloader) Update partition OK
    (bootloader) end@Done
    OKAY [ 2.605s]
    finished. total time: 4.452s"
    But after restarting, I wasn't able to get into TWRP...

    Then when I tried flashing some TWRP image again, I got errors telling me it failed due to S-ON.

    So I tried to boot it directly:
    "fastboot boot twrp-3.3.1-0-m8.img
    downloading 'boot.img'...
    OKAY [ 1.968s]
    booting...
    ^C^C^C"
    This gets stuck and does not do anything then. The Screen shows:
    "download 100%" but it wont boot at all.
    I was able to somehow get out of this by running "fastboot reboot".

    Now useally this happens:
    "fastboot boot twrp-3.3.1-0-m8.img
    downloading 'boot.img'...
    OKAY [ 1.216s]
    booting...
    FAILED (remote: oem unlock is false)"
    USB Debugging enabled, OEM unlock is set in Android Developer Settings.
    "fastboot oem unlock" is not working either.
    Also this does not work:
    "fastboot oem device-info
    ...
    (bootloader) [ERR] Command error !!!"

    Additional Informations:
    (I can not upload any pictures so i have to type a lot.)
    When I start with Volume down + Power I get the following Screen with black background:
    "hTC download mode
    *** UNLOCKED ***
    htc_himaruhl PVT S-ON
    LK-1.01.0000
    RADIO-UNKNOWN
    OpenDSP-UNKNOWN
    OS-2.32.401.1
    Oct 21 2016,15:49:40(820405)

    system info
    show barcode
    reboot to bootloader
    reboot to download mode
    reboot
    power down"
    When I select reboot to bootloader the screen has white background and shows:
    "*** Software status: Modified ***
    *** UNLOCKED ***
    HTC_HIMAR 128 SHIP S-ON

    CID-HTC__034
    LK-1.01.0000
    OS-2.32.401.1
    [...]
    REBOOT
    REBOOT TO BOOT-LOADER
    BOOT TO DOWNLOAD MODE
    BOOT TO RECOVERY MODE
    POWER DOWN"
    I'm missing something like a "FASTBOOT" option. But calling "fastboot devices" lists the device from both screens (black & white).

    As far as I understood, I need to boot into TWRP as S-ON prevents me from flashing.

    I would be really happy to get a hint on how I can proceed.
    Thank you guys.
     


  2. M_Eight

    M_Eight Lurker
    Thread Starter

    BIG Fail. I just forgot that this is actually a HTC M9 Prime Camera Edition!
    Did not remember that after having two more HTC M8s over time. They look just the same.
    I will see if this knowledge gonna help...
     
  3. M_Eight

    M_Eight Lurker
    Thread Starter

    So i still cant boot TWRP for M9:

    fastboot boot twrp-3.0.0-0-hima.img
    downloading 'boot.img'...
    OKAY [ 1.179s]
    booting...
    FAILED (remote: oem unlock is false)

    nor can I flash it:

    fastboot flash recovery twrp-3.0.0-0-hima.img
    target reported max download size of 134217728 bytes
    sending 'recovery' (18672 KB)...
    OKAY [ 1.200s]
    writing 'recovery'...
    (bootloader) Image verification failed...

    FAILED (remote: Err! Stop flashing due to S-ON...
     
  4. M_Eight

    M_Eight Lurker
    Thread Starter

    I also can't access the default recovery option of the phone anymore.
    Could be best to restore this, but is there still a way to get back with all my limitations?
     
  5. M_Eight

    M_Eight Lurker
    Thread Starter

    Flashing some random recovery file I found fails too:

    fastboot flash recovery HTC_One_M9_1.32.401.8_recovery_signed.img
    target reported max download size of 134217728 bytes
    sending 'recovery' (32848 KB)...
    OKAY [ 1.907s]
    writing 'recovery'...
    FAILED (remote: size too large)
    finished. total time: 1.947s
     
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    where are you getting these twrp files from? are they made specifically htc one M8? looks like you tried flashing twrp for the m9. you need to be very careful as the files you use can be device specific. using the wrong file can have dire effects.
     
    MrJavi likes this.
  7. M_Eight

    M_Eight Lurker
    Thread Starter

    I thought I have a M8 but after flashing the TWRP for M8 I found out that my device really is an M9 Prime Camera Edition...
    So now things are messed up. Big Fail of mine.
    Now I need a way to get back to stock images, but I guess I've bricked the easy ways.
     
Loading...

Share This Page

Loading...