1. Download our Official Android App: Forums for Android!

Gmail Sync problem, Fresh 2.0d

Discussion in 'Android Devices' started by derspiess, Apr 22, 2010.

  1. derspiess

    derspiess Member
    Thread Starter
    Rank:
    None
    Points:
    35
    Posts:
    53
    Joined:
    Oct 17, 2009

    Oct 17, 2009
    53
    0
    35
    Cincinnati, OH
    I did something stupid and had to revert to a backup I did a few days ago, which went fine except for one thing. Gmail syncs *to* my phone, but my phone will not sync to Gmail. I noticed that any messages I read or deleted on the phone still appeared unread when I logged into Gmail on my pc. So then I tried sending a test email from my phone and it's stuck as "Sending".

    Looked through all my gmail settings & can't figure out what the issue is. Anyone know where else I can look?
     

    Advertisement

  2. ccapasso

    ccapasso Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,127
    Joined:
    Jan 12, 2010

    Jan 12, 2010
    1,127
    278
    163
    Have you tried removing the account then adding it back to your phone?
     
    derspiess likes this.
  3. mcapozzi

    mcapozzi Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    323
    Joined:
    Mar 17, 2010

    Mar 17, 2010
    323
    35
    43
    Computer SuperGenius aka Systems Administrator
    Liverpool, NY
    This has happened to me once while I was trying to send a 500KB attachment from the phone. Rebooting the phone fixed it.

    -Mike
     
    derspiess likes this.
  4. riggsAndroid

    riggsAndroid Member
    Rank:
    None
    Points:
    16
    Posts:
    34
    Joined:
    Mar 25, 2010

    Mar 25, 2010
    34
    6
    16
    I've had this issue before when reverting. I think the problem is what date our Gmail sync thinks it is and what day it really is due to our nandroid.

    I have found that removing the account and re-adding it works, or even just changing the Sync Amount in settings under labels to a different value, I usually jsut change it from 3 days to All for 5 minutes, then back to 3 days, and it syncs right up.

    This happened to me yesterday and that was my fix. Works fine.
     
    derspiess likes this.
  5. derspiess

    derspiess Member
    Thread Starter
    Rank:
    None
    Points:
    35
    Posts:
    53
    Joined:
    Oct 17, 2009

    Oct 17, 2009
    53
    0
    35
    Cincinnati, OH
    Thanks for the responses. For whatever reason, it won't let me remove my Google account. I get a message telling me to go to Settings -> About Phone to do a factory reset, and there's no option for that that I can see. I don't really want to take that drastic of a step in any case.

    Also tried setting my # of days under labels to 999, waiting a few minutes, then setting it back, and that's not clearing the problem.

    I'm really not in the mood to wipe and/or reinstall the ROM but if this keeps up, I may have to.
     
Tags:

Share This Page

Loading...